別のデバイスが切断された後、アプリケーションが新しいスキャン デバイスを見つけることができません
この記事では、別のスキャナーが切断された後にスキャナーが接続されている場合に、アプリケーションでスキャン デバイスが見つからない場合に発生するエラーを回避するのに役立ちます。
元の製品バージョン: Windows 10、Windows 8.1
元の KB 番号: 4537086
現象
次のような状況で問題が発生します。
- デバイス上の Web サービス (WSD) スキャン デバイスを Windows ベースのコンピューターに接続します。
- WSD スキャナーを切断します。
- USB スキャナーなどの別のスキャン デバイスをコンピューターに接続します。
- 新しいスキャナーを使用するアプリケーションを起動します。
このシナリオでは、アプリケーションが正しく動作しない可能性があります。 たとえば、アプリケーションで新しいスキャナーが見つからない場合があります。
この問題が発生すると、スキャナー ドライバーが メソッドを呼び出したときに WIA_ERROR_OFFLINE エラーが発生する
IStiDevice::LockDevice
可能性があります。
注:
この問題は、最大 19H2 (バージョン 1909) までのWindows 10バージョン (つまり、バージョン 1909 Windows 10) に適用されます。 この問題は 20H1 (Windows 10 バージョン 2004) で修正されています
原因
この問題は、サービスが WSD スキャナーを初期化するときに"Windows イメージ取得 (WIA)" サービスでエラーが発生した場合に発生します。 初期化プロセスがエラーなしで成功した場合、この問題は発生しません。
回避策
この問題を回避するには、次のいずれかの方法を試してください。
- 接続されているスキャナー デバイスをアンインストールし (たとえば、デバイス マネージャーを使用して)、スキャナーを再接続します。
- "Windows イメージ取得 (WIA)" サービスを停止し、サービスを再起動します。
- スキャナーの接続中にコンピューターを再起動します。
詳細
WIA スキャナー アプリケーションまたはドライバーで発生する可能性があるエラーの詳細については、「 エラー コード」を参照してください。