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バックグラウンド インテリジェント転送サービスを使用してファイルをダウンロードするときのエラー: コンテンツ ファイルのダウンロードに失敗しました

この記事では、プロキシ サーバーの背後にいる場合、または HTTP 1.1 範囲要求をサポートしていないファイアウォールの背後にある場合に発生する問題について説明します。

元の KB 番号: 922330

現象

バックグラウンド インテリジェント転送サービス (BITS) を使用してファイルをダウンロードしようとすると、失敗します。 さらに、次のエラー メッセージがアプリケーション ログに記録されます。

イベントの種類 : エラー
イベント ソース:Windows Server Update Services
イベントの分類: (2)
イベント ID:364
日付: 日付
時間: 時間
ユーザー: N/A
コンピューター: ServerName
説明: コンテンツ ファイルのダウンロードに失敗しました。 理由: サーバーは必要な HTTP プロトコルをサポートしていません。 バックグラウンド インテリジェント転送サービス (BITS) では、サーバーが Range プロトコル ヘッダーをサポートしている必要があります。

具体的には、次の操作のいずれかまたは両方を実行しようとすると、この問題が発生します。

  • Microsoft Windows Server Update Services (WSUS) で更新プログラムを承認します。 この状況では、ダウンロード プロセスがトリガーされます。 ただし、ダウンロード操作は失敗します。 更新プログラムの上に赤い X が表示されます。
  • Microsoft Baseline Security Analyzer (MBSA) Management Pack for Microsoft Operations Manager (MOM) 2005 の Mssecure.cab ファイルをダウンロードしようとするとします。

原因

コンピューターがファイアウォールの内側またはプロキシ サーバーの背後にある場合、この問題が発生する可能性があります。 この問題は、次のいずれかの条件に該当する場合に発生します。

  • プロキシ サーバー環境では、HTTP 1.1 範囲要求機能はサポートされていません。
  • SonicWALL ファイアウォール デバイスの背後にあり、[ ゲートウェイ AV で HTTP Byte-Range 要求を有効にする] 設定がデバイスに対して有効になっていません。

バックグラウンド モードで BITS を使用してファイルをコピーすると、ファイルは複数の小さな部分にコピーされます。 この種のコピー操作を実行するために、BITS は HTTP 1.1 Content-Range ヘッダーを使用します。 プロキシ サーバーの背後にいる場合、またはこのヘッダーを削除するファイアウォールの内側にいる場合、ファイルのコピー操作は失敗します。

注:

BITS がフォアグラウンド モードでファイルをコピーする場合、BITS はこのヘッダーを使用しません。

解決策 1: プロキシ サーバーが HTTP 1.1 範囲要求をサポートしていない

HTTP 1.1 範囲要求をサポートするようにプロキシ サーバーの設定を変更します。 この方法でプロキシ サーバーを変更できない場合は、フォアグラウンド モードで動作するように BITS を構成します。 これを行うには、次の手順を実行します。

  1. [ スタート] をクリックし、[ 実行] をクリックし、次のいずれかのコマンドを入力して、[OK] をクリック します

    既定の WSUS インストールによって作成された MSDE または WMSDE データベースで WSUS 2.0 を使用している場合は、次のコマンドを入力します。

    %programfiles%\Update Services\tools\osql\osql.exe -S %Computername%\WSUS -E -b -n -Q "USE SUSDB update tbConfigurationC set BitsDownloadPriorityForeground=1"
    

    Microsoft SQL Server の既存のインストールを使用するように WSUS 2.0 を構成した場合は、次のコマンドを入力します。

    %programfiles%\Update Services\tools\osql\osql.exe" -S %Computername% -E -b -n -Q "USE SUSDB update tbConfigurationC set BitsDownloadPriorityForeground=1"
    

    既定の WSUS インストールによって作成された Windows 内部データベースで WSUS 3.0 を使用している場合は、次のコマンドを入力します。

    %programfiles%\Update Services\Setup\ExecuteSQL.exe -S %Computername%\MICROSOFT##SSEE -d "SUSDB" -Q "update tbConfigurationC set BitsDownloadPriorityForeground=1"
    
    If you configured WSUS 3.0 to use an existing installation of SQL Server, type the following command:
    
    ```console
    %programfiles%\Update Services\Setup\ExecuteSQL.exe -S %Computername% -d "SUSDB" -Q "update tbConfigurationC set BitsDownloadPriorityForeground=1"
    
  2. Update Services サービスを再起動します。 これを行うには、次の手順を実行します。

    1. [スタート][ファイル名を指定して実行] の順にクリックし、「services.msc」と入力して [OK] をクリックします。
    2. [ サービス ] ダイアログ ボックスで、[サービスの 更新] を右クリックし、[ 再起動] をクリックします。

解決策 2: [ゲートウェイ AV で HTTP Byte-Range 要求を有効にする] 設定が有効になっていない

SonicWALL 構成ツールの [内部設定] ページの [ゲートウェイ AV で HTTP Byte-Range 要求を有効にする] チェック ボックスをオンにします。 SonicWALL ファイアウォール機能を変更する方法の詳細については、SonicWALL サポートにお問い合わせください。 これを行うには、次の SonicWALL Web サイトにアクセスします。

SonicWALL のサポート

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