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静的プロキシが構成されているときに DirectAccess クライアントが接続できない場合がある

この記事では、Windows サーバーにリモート アクセスロールがインストールされている場合に発生する問題の回避策について説明します。

元の KB 番号: 3017472

現象

以下のシナリオについて考えてみます。

  • リモート アクセス (DirectAccess) の役割が Windows Server 2012 R2 ベースのサーバーにインストールされている。
  • Windows 8 または Windows 8.1 クライアントは、企業ネットワークの外部にある場合に、企業接続のためにこの DirectAccess サーバーに接続します。
  • DirectAccess クライアントで構成されている静的プロキシ サーバーがある。
  • 静的プロキシ サーバーは手動で構成されているか、グループ ポリシーを使用して設定されます。 構成は、.pac プロキシ構成ファイルの静的パスである場合もあります。

このシナリオでは、DirectAccess クライアントが会社の接続のために DirectAccess サーバーに接続できず、"接続中" 状態でスタックしている可能性があります。 クライアントから静的プロキシ設定を削除してからクライアントを再起動すると、DirectAccess クライアントが接続できるようになります。

原因

この問題は、静的プロキシが構成されていることが検出されるとすぐに、IP ヘルパー サービスによって DirectAccess サーバーへの接続がキャンセルされるために発生します。

この問題を回避するには、以下のいずれかの方法を使用します。

回避策 1

プロキシ サーバーを使用しない場所にローミングする DirectAccess クライアントがある場合は、イントラネット上の WPAD を使用してクライアントのプロキシ設定を取得できます。 これにより、クライアントがローミング中で DirectAccess サーバーに接続する必要があるときに、DirectAccess クライアントがプロキシを使用しないようにすることができます。

回避策 2

詳細設定で DirectAccess サーバーの例外を追加して、DirectAccess サーバー アドレスについてのみプロキシをスキップできます。 たとえば、DirectAccess サーバーの例外として directaccess.contoso.com を追加したり、複数の DirectAccess サーバーがある場合は *.directaccess.contoso.com を追加したりできます。