次の方法で共有


SMB ファイル サーバーの共有アクセスが DNS CNAME エイリアスを介して失敗する

この記事では、正規名 (CNAME) を使用してサーバー メッセージ ブロック (SMB) サーバーにアクセスするときの問題を解決する方法について説明します。

現象

以下のシナリオについて考えてみます。

  • Windows Server ベースのコンピューターやネットワーク接続ストレージ (NAS) などの SMB ファイル サーバーがあります。
  • サーバーには、NetBIOS 名、ドメイン ネーム システム (DNS) 完全修飾ドメイン名 (FQDN)、エイリアス (CNAME) を使用してアクセスできるファイルとリソースがあります。
  • Windows 10、Windows 11、Windows Server 2016、またはそれ以降のバージョンの Windows Server を実行しているクライアントがある。
  • クライアントでは、NetBIOS 名または FQDN を使用して、アプリケーションまたはユーザー アカウントを使用して SMB 共有にアクセスできます。

このシナリオでは、次のいずれかのコマンドを実行して、CNAME を使用して SMB 共有にアクセスすると、コマンドは失敗します。

  • \\CNAME.contoso.com\share_name
  • \\CNAME\share_name
  • NET USE * \\CNAME\share_name
  • NET USE * \\CNAME.contoso.com\share_name
  • New-PSDrive -Name "x" -PSProvider "FileSystem" -Root "\\CNAME\share_name" -Persist
  • New-PSDrive -Name "x" -PSProvider "FileSystem" -Root "\\CNAME.contoso.com\share_name" -Persist

また、次のいずれかの例のようなエラー メッセージが表示されることがあります。

\\CNAME.contoso.com\share_name にはアクセスできません。 このネットワーク リソースを使用するアクセス許可がない可能性があります。 アクセス許可があるかどうかをこのサーバーの管理者に問い合わせてください。

アカウント制限により、このユーザーはサインインできません。 たとえば、空白のパスワードは許可されません。サインイン時間が制限されているか、ポリシー制限が適用されています。

\\CNAME.contoso.com\share_name にはアクセスできません。 このネットワーク リソースを使用するアクセス許可がない可能性があります。 アクセス許可があるかどうかをこのサーバーの管理者に問い合わせてください。

ログオン失敗: ターゲット アカウント名が正しくありません。

原因

この問題は、次のいずれかの理由で発生すると考えられます。

  • 構成の問題または SMB サーバー サービスの強化の問題。
  • ファイル共有サーバーの DNS エイリアス (CNAME) レコードのサービス プリンシパル名 (SPN) がありません。

解決方法

この問題を解決するには、DNS CNAME を使用してファイル サーバーの別名を構成しないようにします。 代わりに、netdom コマンドを使用してエイリアスを定義して構成します。

Netdom computername <ComputerOriginalName> /add:<Alias>

詳細については、「 DNS CNAME レコードの代わりにコンピューター名エイリアスを使用するを参照してください。