次の方法で共有


電源障害またはシステム クラッシュの直前に作成されたディスク パーティションは、フォーマットまたは使用できません

この記事では、システムのクラッシュや電源障害の直前に作成されたディスク パーティションを適切にフォーマットできない、または使用できない問題について説明します。

元の KB 番号: 2539626

現象

以下のシナリオについて考えてみます。

  • ディスク管理または DiskPart を使用して、ディスクに新しいパーティションを作成します。
  • パーティションを作成した直後に、コンピューターの電源が失われるかクラッシュし、再起動が強制されます。

このシナリオでは、ドライブ文字が割り当てられないディスク パーティションが作成される可能性があります。 パーティションは使用できないため、パーティションのフォーマットを試みるとエラーが発生する可能性があります。 パーティションは正常に削除できますが、その代わりに新しいパーティションを再作成しようとするとエラーが発生します。

例えば次が挙げられます。

  • ディスク管理でパーティションをフォーマットしようとすると、次のエラー メッセージが表示されることがあります。 エラーの詳細については、システム イベント ログを確認してください。 ディスク管理コンソールを閉じ、ディスク管理を再起動するか、コンピューターを再起動します。"

  • ディスク管理では、"ボリュームの削除" を正常に選択できます。ただし、[新しいシンプル ボリューム] を選択して再作成しようとすると、ディスク管理が長時間停止します。 数分後、次のエラー メッセージが表示されます。"ディスク管理コンソール ビューが最新でないため、操作を完了できませんでした。 更新タスクを使用してビューを更新します。 問題が解決しない場合は、ディスク管理コンソールを閉じてから、ディスク管理を再起動するか、コンピューターを再起動してください。

    ディスク パーティションは正常に再作成されますが、ボリュームがフォーマットされたり、ドライブ文字に関連付けられたりすることはありません。

  • DiskPart では、 select partition コマンドを使用して問題のあるパーティションを選択し、 delete partition コマンドを使用して正常に削除できます。 ただし、"パーティション プライマリの作成" などのコマンドを使用してパーティションを再作成すると、DiskPart は長時間ハングします。 数分後に、次のエラー メッセージが表示されます。

    仮想ディスク サービス エラー:
    操作がタイムアウトしたとき。

    DiskPart は、最新ではないオブジェクトを参照しています。
    RESCAN コマンドを使用してオブジェクトを更新します。
    問題が解決しない場合は、DiskPart を再起動するか、コンピューターを再起動します。

原因

この問題は、コンピューターが新しいボリュームを作成したが、新しく作成されたボリューム デバイスのすべての適切なレジストリ エントリが正常にディスクに書き込まれる前に予期せずクラッシュまたは電源が失われたために発生します。 その結果、ボリュームは部分的にしかインストールされていません。 ボリュームを削除して再作成しようとすると、古い正しくインストールされていないボリュームが新しいボリュームの作成に干渉するため、作成は失敗します。

解決方法

  1. デバイス マネージャーを開始します。 (スタート メニューで、[コンピューター] を右クリックし、[プロパティ] を選択します。次に、[デバイス マネージャー]) をクリックします。
  2. [ストレージ ボリューム] カテゴリを展開します。
  3. [ストレージ ボリューム] カテゴリで、[不明なデバイス] というラベルの付いたデバイスを右クリックし、[アンインストール] を選択します。
  4. デバイス マネージャーを閉じます。
  5. ディスク管理または DiskPart を使用して、問題のあるパーティションを削除します。

これで、ディスク管理または DiskPart を使用してボリュームを正常に作成してフォーマットできるようになりました。