この記事では、プライマリ パーティションをアクティブとしてマークした後にコンピューターが起動しない問題の解決策を示します。
元の KB 番号: 315261
現象
Windows ディスク管理スナップイン ツールを使用してプライマリ パーティションをアクティブとしてマークすると、コンピューターが起動せず、次のエラー メッセージが表示されることがあります。
NTLDR がありません。
Ctrl+Alt+Del キーを押して再起動してください。
原因
この動作は、アクティブとしてマークされたパーティションに Windows ブート ファイルまたは別のオペレーティング システムのブート ファイルが含まれていない場合に発生します。 Intel ベースのコンピューターでは、システム パーティションは、起動時にアクティブとしてマークされているプライマリ パーティションである必要があります。 このパーティションは、コンピューターが起動時にアクセスできるディスク上に配置する必要があります。 アクティブなシステム パーティションは一度に 1 つだけ存在できます。 別のオペレーティング システムを使用する場合は、コンピューターを再起動する前に、まずシステム パーティションをアクティブとしてマークする必要があります。
解決方法
重要
以下の手順を実行する前に、重要なデータ ファイルの適切なバックアップがあることを確認してください。
この動作を解決するには、次のいずれかの手順を実行します。
フロッピー ディスクを起動し、ディスク ユーティリティを使用してアクティブパーティションを手動で変更して、アクティブパーティションを変更してみてください。
- Microsoft Windows 95、Microsoft Windows 98、または Microsoft Windows Millennium Edition (Me) ブート フロッピー ディスクを使用して、コマンド プロンプトで起動します。
- コマンド プロンプトで、「 fdisk」と入力し、Enter キーを押します。
- 大きなディスクサポートを有効にするように求められたら、 Yesをクリックします。
- アクティブパーティションの設定をクリックし、アクティブにするパーティションの番号を押して、Enter キーを押します。
- Esc キーを押します。
- ブート フロッピー ディスクを取り外し、コンピューターを再起動します。
Windows XP ブート ディスクを使用してコンピューターを起動します。 詳細については、「 システム修復ディスクの作成」を参照してください。
誤ってアクティブとしてマークされたパーティションが FAT ファイル システム、FAT32 ファイル システム、または NTFS ファイル システムでフォーマットされている場合は、Windows 回復コンソールを使用して動作を修正できる可能性があります。
詳細については、「 Windows のシステム回復オプションは何ですか?」を参照してください。
Note
システム パーティションは、Windows の起動に必要なファイル (Ntldr、Boot.ini、Ntdetect.com など) を含むディスク ボリュームを指します。 Intel x86 ベースのコンピューターでは、システム パーティションはアクティブとしてマークされているプライマリ パーティションである必要があります。 Intel x86 コンピューターでは、これは常にドライブ 0 であり、オペレーティング システムの起動時にシステム BIOS が検索するドライブです。
回復コンソールを使用して、Windows XP CD-ROM から現在のアクティブ パーティションのルート ディレクトリに Ntldr ファイルをコピーします。 次のステップを実行します。
Windows XP セットアップ フロッピー ディスクを使用するか、Windows XP CD-ROM を使用して、コンピューターを起動します。
セットアップ画面で F10 キーを押すか、R キーを押して修復します。
C キーを押して回復コンソールを起動します。
次のコマンドを使用して、Windows XP CD-ROM からシステム パーティションのルートに Ntldr ファイルをコピーし、各コマンドの後に Enter キーを押します。
ドライブ C のルートに移動するには、「
cd ..
」と入力します。d と 2 つのピリオド (..) の間にスペースがあります。
CD-ROM ドライブの文字を入力します。
「
cd i386
」と入力します。「
Copy ntldr c:
」と入力します。「
Copy ntdetect.com c:
」と入力します。「
Bootcfg /add
」と入力します。「
Exit
」と入力します。
パーティションが Windows を使用してフォーマットされていない場合は、回復コンソールの fixboot コマンドを実行して、アクティブなパーティションを起動可能にする必要がある場合もあります。
Windows を起動したら、Windows ディスク管理スナップイン ツールを使用して、元のシステム パーティションをアクティブ パーティションとしてリセットしてから、コンピューターを再起動することをお勧めします。