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システムが応答を停止する、ファイル サーバーのパフォーマンスが低下する、またはファイル サーバー上にあるファイルを操作するときに遅延が発生する

この記事では、ファイル サーバー上にあるファイルを操作するときに発生するパフォーマンスの問題を解決する方法について説明します。

元の KB 番号: 822219

現象

ネットワーク経由でファイルを操作すると、次の現象が 1 つ以上発生する可能性があります。

  • ファイルおよびプリント サーバーとして構成されている Windows ベースのファイル サーバーは応答を停止し、ファイルとプリント サーバーの機能は一時的に停止します。

  • 共有リソースにあるファイルを開き、保存、閉じる、削除、または印刷すると、予期せず長い遅延が発生します。

  • ネットワーク経由でプログラムを使用すると、パフォーマンスが一時的に低下します。 通常、パフォーマンスは約 40 ~ 45 秒間低下します。 ただし、一部の遅延は最大 5 分続く場合があります。

  • ファイルのコピー操作またはバックアップ操作を実行すると、遅延が発生します。

  • 共有リソースに接続すると、または Windows エクスプローラーで接続されているネットワーク ドライブに赤い X が表示されると、Windows エクスプローラーの応答が停止します。

  • ファイル サーバーにログオンすると、 [Windows へのログオン] ダイアログ ボックスに名前とパスワードを入力すると 空白の画面が表示されます。 デスクトップが表示されません。

  • リモート プロシージャ コール (RPC) を使用するか、名前付きパイプを使用してファイル サーバーに接続するプログラムが応答を停止します。

  • サーバーは一時的に応答を停止し、次のような 1 つ以上のイベント ID メッセージがファイル サーバーのシステム ログに表示されます。

  • 共有リソースに接続しようとすると、次のいずれかのメッセージのようなエラー メッセージが表示されます。

    • エラー メッセージ 1

      システム エラー 53。 ネットワーク パスが見つかりませんでした。

    • エラー メッセージ 2

      システム エラー 64。 指定されたネットワーク名は利用できなくなっています。

  • ネットワーク リソースから断続的に切断され、ファイル サーバー上のネットワーク リソースに再接続することはできません。 ただし、サーバーに ping を実行することも、リモート デスクトップ サービス セッションを使用してサーバーに接続することもできます。

  • 複数のユーザーがサーバー上の Microsoft Office ドキュメントにアクセスしようとすると、 File は編集用にロックされます 2 番目のユーザーがファイルを開いたときにダイアログ ボックスが常に表示されるとは限りません。

  • ネットワーク トレースは、SMB サービス クライアント コマンドとファイル サーバーからの応答の間に 30 ~ 40 秒の遅延があることを示します。

  • Access 2.0 データベース ファイル (.mdb ファイル) を Microsoft Access 97、Access 2000、または Access 2002 で開こうとすると、次のようなエラー メッセージが表示されることがあります。

    ディスクまたはネットワーク エラー。

  • Microsoft Word ファイルを開こうとすると、次のエラー メッセージが表示されることがあります。

    Word は、このファイル file_nameからの読み取りに失敗しました。 ネットワーク接続を復元するか、フロッピー ディスクを交換してやり直してください。

原因

この問題は、コンピューターにインストールされている Microsoft 以外のプログラムが古いカーネル モード フィルター ドライバーを使用している場合に発生する可能性があります。 次の条件に該当する場合、カーネル モード フィルター ドライバーが古くなっている可能性があります。

  • 次のいずれかのプログラムがコンピューターにインストールされています。

    • ARCserve Backup Agent for Open Files または ARCserve Open File Agent from Computer Associates International, Inc. がコンピューターにインストールされており、プログラムのOfant.sys ドライバーが古くなっています。

    • Open Transaction Manager がコンピューターにインストールされ、プログラムのOtman.sys ドライバーが古くなっています。

      Note

      Open Transaction Manager は、VERITAS Software Corporation の特定のプログラムに含まれていますが、VERITAS プログラムとは別にインストールすることもできます。 たとえば、Open Transaction Manager は[ファイルを開く]オプションに含まれる場合があります。 このプログラムは、VERITAS Backup Exec に含まれる場合があります。

    • Otman4.sysまたはOtman5.sysドライバを使用するVERITASプログラム(Open File Optionなど)がコンピュータにインストールされており、プログラムのOtman4.sysまたはOtman5.sysドライバが古くなっています。

  • プログラムのドライバーは、Microsoft 以外のウイルス対策プログラムによってコンピューターにインストールされているフィルター ドライバーと互換性がありません。 その結果、サーバー上のフィルター ドライバーが正しくない状態コードをサーバー サービスに返す可能性があります。 たとえば、フィルター ドライバーは、STATUS_OPLOCK_BREAK_IN_PROGRESS コードではなくSTATUS_SUCCESS コードを返す場合があります。

解決方法

この問題を解決するには、プログラムの製造元に問い合わせて、フィルター ドライバーの更新プログラムの可用性について問い合わせてください。 Ofant.sys ドライバーの最新の更新プログラムを入手するには、コンピューター の関連付けに問い合わせる方法の詳細については、「 Computer Associatesを参照してください。

Open Transaction Manager を個別にインストールした場合は、コロンビア データ製品 Inc. に問い合わせて、この問題を解決できる更新プログラムの可用性について問い合わせてください。 コロンビアデータ製品に問い合わせるには、 Columbia Data Productsにアクセスしてください。

VERITAS に問い合わせる方法の詳細については、 VERITAS サポートを参照してください。

詳細

重要

このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 したがって、次の手順を注意深く実行してください。 保護のために、レジストリを変更する前に、バックアップします。 その後、問題が起こった場合は、レジストリを復元できます。 レジストリのバックアップと復元方法の詳細は、「Windows のレジストリのバックアップおよび復元の方法」を参照してください。

この問題を一時的に回避するには、サーバー上のサーバー サービスを再起動します。 サーバー サービスを再起動するには、次の手順に従います。

  1. [スタート] ボタンをクリックし、 [ファイル名を指定して実行] をクリックします。

  2. [ 開く ] ボックスに「 cmd」と入力し、[ OK] をクリック

  3. コマンド プロンプトで、次の行を入力し、各行の後に Enter キーを押します。

    net stop server
    net start server
    

この問題をトラブルシューティングするには、次のいずれかの方法を使用します。

  • パフォーマンス ログとアラートを使用して、PhysicalDisk パフォーマンス オブジェクトの Avg.Disk Queue Length カウンターを監視します。 通常の条件下では、待機中の入出力 (I/O) 要求の数は、通常、物理ディスクに含まれるスピンドルの数の 1.5 ~ 2 倍以下です。 ほとんどのディスクには 1 つのスピンドルがありますが、通常、独立ディスク (RAID) デバイスの冗長アレイには複数のスピンドルがあります。 プログラムが少数の連続する I/O 操作を実行すると、I/O バインド操作がキューに入ると、 現在のディスク キューの長さ カウンターが急増します。 また、System パフォーマンス オブジェクトの Context Switches/sec カウンターが増加することがあります。

  • クライアントまたはサーバーで日和見ロックを無効にします。 クライアントで日和見ロックを無効にするには、次のレジストリ値を 1 に設定します。

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters\OplocksDisabled

    サーバーで日和見ロックを無効にするには、次のレジストリ値を 0 に設定します。

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\EnableOplocks

    日和見ロックを無効にする方法の詳細については、「 Windows での日和見ロックの構成を参照してください。

  • レジストリを編集して、フィルター ドライバーを一時的に非アクティブ化します。

    カーネル モード フィルター ドライバーを一時的に非アクティブ化する方法の詳細については、「 Windows でカーネル モード フィルター ドライバーを一時的に非アクティブ化する方法を参照してください。

    Ofant.sys ドライバーの情報を格納するレジストリ キーは Ofadriver です。

関連情報

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