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Windows XP SP3 ベースまたは Windows Small Business Server 2003 SP1 ベースのコンピューターでターミナル サービス Web アクセスまたはリモート Web ワークスペースを使用する場合、リモート コンピューターに接続したり、リモート アプリケーションを起動したりすることはできません。

この記事では、TS Web Access またはリモート Web ワークスペースを使用するときにリモート コンピューターに接続したり、リモート アプリケーションを起動したりできない問題の回避策について説明します。

元の KB 番号: 951607

現象

Windows XP Service Pack 3 (SP3) ベースまたは Windows Small Business Server 2003 Service Pack 1 (SP1) ベースのコンピューターでは、次の現象が発生します。

  • リモート デスクトップ Web 接続 (TSWeb) を使用してリモート コンピューターに接続しようとすると、 Connect ボタンが無効になります。 TSWeb ページには、次の警告メッセージが含まれている場合もあります。

    リモート デスクトップ Web 接続 ActiveX コントロールがインストールされていません。 インストールされているバージョンのコントロールを使用しないと、接続を確立できません。

    Note

    リモート デスクトップ接続 6.0 クライアントをインストールしようとすると、コンピューターに既にインストールされていることを示すメッセージが表示されます。

  • リモート Web ワークスペース (RWW) Web サイトを使用してリモート コンピューターに接続すると、リモート デスクトップ接続 ActiveX コントロールをダウンロードできないことに気付きます。 または、次のエラー メッセージが表示されます。

    サーバー名が無効です。

    Note

    リモート Web ワークスペースは、Microsoft Windows Small Business Server (Windows SBS) で使用できる機能です。

  • ターミナル サービス Web アクセス (TSWA) Web サイトを使用してリモート コンピューターに接続したり、リモート アプリケーションを起動したりすると、次のエラー メッセージが表示されます。この Web サイトには、このシステムにインストールされていないターミナル サービス クライアントが必要です。 最新のクライアントをインストールし、先に進む前に最新の Windows 更新プログラムがあることを確認します。

  • Windows ホーム サーバーを使用して [リモート アクセス コンピューター] ページにアクセスすると、次のエラー メッセージが表示されることがあります。アドオンが無効になっています。この Web ページでは、無効になっているアドオンが要求されています。 アドオンを有効にするには、ここをクリックしてください。 さらに、Windows Home Server またはホーム コンピューターに接続しようとすると、次のエラー メッセージが表示される場合があります。

    この機能を使用するには、Windows ホーム サーバーの Web サイト アドレス https://my.homeserver.com Internet Explorer の信頼済みサイト ゾーンに追加する必要があります。 Windows Home Server の Web サイト アドレスを追加するには、Internet Explorer の [インターネット オプション] ダイアログ ボックスを開き、[セキュリティ] タブをクリックします。[信頼済みサイト] を選択し、[サイト] ボタンをクリックします。 [追加] ボタンを使用して Web サイトのアドレス https://my.homeserver.com を追加し、[閉じる] を押します。

    Note

    ホーム サーバーの URL を信頼済みサイトの一覧に追加すると、同じエラー メッセージが表示され、接続できません。

  • Web サイトのリモート アクセスを使用して Windows ホーム サーバーにアクセスすると、次のエラー メッセージが表示されることがあります。

    アドオン無効 この Web ページは、無効になっているアドオンを要求しています。 アドオンを有効にするには、ここをクリックしてください。

    さらに、Windows ホーム サーバーに接続しようとすると、次のエラー メッセージが表示される場合があります。ホーム サーバーまたはホーム コンピューターにリモートで接続するには、Microsoft ターミナル サービス クライアント コントロール アドオン、または Microsoft RDP アドオンをインストールして Web ブラウザーで有効にする必要があります。 アドオンのインストールを拒否した場合は、ページを更新し、メッセージが表示されたらインストールします。 それ以外の場合は、Web ブラウザーのステータス バーの [アドオンの管理] アイコンを使用してこのアドオンを有効にするか、このアドオンを有効にする方法に関する Web ブラウザーのドキュメントを参照してください。

原因

この問題は、リモート デスクトップ接続クライアントの ActiveX コントロールが Web ブラウザーで有効になっていない場合に発生します。 既定では、Windows XP Service Pack 3 (SP3) または Windows Small Business Server 2003 SP1 をインストールした後、ActiveX コントロールは無効になります。

回避策

この問題を回避するには、次の手順に従ってください。

  1. Internet Explorer を起動します。

  2. この問題の原因となっている Web サイトにアクセスしてください。

  3. Windows Internet Explorer 7 を使用している場合は、次の手順に従います。

    1. [ Tools メニューの Manage Add-ons をポイントし、 [アドオンの有効化] または [アドオンの無効化] をクリック。 [ Manage アドオン ] ダイアログ ボックスが表示されます。
    2. アドインの一覧で、Microsoft ターミナル サービス クライアント コントロール ActiveX コントロールまたは Microsoft RDP クライアントコントロール ActiveX コントロールを検索します。 コントロールが見つからない場合は、このセクションの最後にある「アドオンの一覧にコントロールが表示されない場合」の手順を参照してください。
    3. コントロールをクリックし、[ 有効] をクリックし、[ OK] をクリックして アドオンの管理ダイアログ ボックスを閉じます。

    Internet Explorer 6 を使用している場合は、次の手順に従います。

    1. [ Tools メニューの [アドオンの管理] クリック。 [ Manage アドオン ] ダイアログ ボックスが表示されます。
    2. アドインの一覧で、Microsoft ターミナル サービス クライアント コントロール ActiveX コントロールまたは Microsoft RDP クライアントコントロール ActiveX コントロールを検索します。 コントロールが見つからない場合は、このセクションの最後にある「アドオンの一覧にコントロールが表示されない場合」の手順を参照してください。
    3. コントロールをクリックし、[Enable] をクリックし、[OK] をクリックして管理アドオン ダイアログ ボックスを閉じます。
  4. Internet Explorer で信頼済みサイトにサイトを追加します。

  5. Internet Explorer を再起動します。

  6. リモート コンピューターに接続してみてください。 または、リモート アプリケーションを起動してみてください。

アドオンの一覧にコントロールが表示されない場合

アドオンの一覧に Microsoft Terminal Services クライアント コントロール ActiveX コントロールが表示されない場合があります。

この問題を解決するには、次の手順を試して、Internet Explorer を既定の構成にリセットしてコントロールの表示を試みることができます。

  1. Internet Explorer を起動します。
  2. [ File] をクリックし、[インポートとエクスポート ] をクリック
  3. ウィザードの手順に従って、お気に入りをエクスポートします。
  4. [ツール][インターネット オプション]の順にクリックします。
  5. [ Advanced] をクリックし、[ Reset] をクリックします。

Internet Explorer が既定の構成にリセットされたら、リモート コンピューターに接続するか、リモート アプリケーションを起動してみてください。 機能しない場合は、回避策の手順に従って、Microsoft ターミナル サービス クライアント コントロール ActiveX コントロールを有効にします。 コントロールがまだ一覧にない場合は、レジストリを変更してキーが存在する場合は削除できます。

重要

この記事には、レジストリを変更する方法に関する情報が含まれています。 レジストリを変更する前に、必ずバックアップしてください。 問題が発生した場合にレジストリを復元する方法を確認してください。 レジストリをバックアップ、復元、および変更する方法の詳細については、マイクロソフト サポート技術情報の記事を表示するには、次の資料番号をクリックします。 322756 Windows でレジストリをバックアップおよび復元する方法

次のレジストリ キーが存在する場合は削除します。

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7584C670-2274-4EFB-B00B-D6AABA6D3850} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{971127BB-259F-48C2-BD75-5F97A3331551} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{9059F30F-4EB1-4BD2-9FDC-36F43A218F4A} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EB89FF4-7F78-4A0F-8B8D-2BF02E94E4B2} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4EDCB26C-D24C-4e72-AF07-B576699AC0DE} HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390F3D8-0439-4C05-91E3-CF5CB290C3D0}

レジストリ キーが削除されたら、Internet Explorer を終了して再起動し、リモート コンピューターへの接続またはリモート アプリケーションの再起動を試みます。

これで問題が解決しない場合は、mstscax.dll ファイルを再登録できます。 これを行うには、次の手順を実行します。

  1. Internet Explorer を終了します。

  2. Startをクリックし、Run をクリックし、次のテキストをOpen ボックスにコピーして貼り付け、OK: %windir%\system32\regsvr32 mstscax.dll

  3. 確認プロンプトで、 OKをクリックします。

  4. Internet Explorer を再起動し、リモート コンピューターに接続するか、リモート アプリケーションを起動します。

詳細

Windows XP Service Pack 2 (SP2) では、ターミナル サービス ActiveX コントロールを有効にするために Msrdp.ocx ファイルをインストールする必要がありました。 Windows XP Service Pack 3 (SP3) には、この ActiveX コントロールが既に含まれており、Mstscax.dll ファイルを使用してインストールされています。 既定では、この ActiveX コントロールは Windows XP Service Pack 3 (SP3) では無効になっています。