Ескертпе
Бұл бетке кіру үшін қатынас шегін айқындау қажет. Жүйеге кіруді немесе каталогтарды өзгертуді байқап көруге болады.
Бұл бетке кіру үшін қатынас шегін айқындау қажет. Каталогтарды өзгертуді байқап көруге болады.
Эта статья поможет устранить последовательную проблему проверки подлинности при подключении к SQL Server, связанной со службой подсистемы локального центра безопасности (LSASS).
Симптомы
Вы можете столкнуться с проблемами подсистемы безопасности, связанными с LSASS. Драйвер проверка подлинности Windows может показать сообщение об ошибке "Имя входа из ненадежного домена и не может использоваться с сообщением об ошибке проверка подлинности Windows".
Проверьте, отображает ли журнал ошибок Microsoft SQL Server следующие записи:
Сбой подтверждения SSPI с кодом ошибки 0x80090311, состояние 14 при установке подключения с интегрированной безопасностью; подключение закрыто. Причина: ошибка AcceptSecurityContext. Причину ошибки указывает код ошибки Windows.
Сбой подтверждения SSPI с кодом ошибки 0x80090304, состояние 14 при установке подключения с интегрированной безопасностью; подключение закрыто. Причина: ошибка AcceptSecurityContext. Причину ошибки указывает код ошибки Windows.
Ошибки Kerberos также могут отображаться в системном журнале событий на сервере, на котором выполняется SQL Server в течение одного и того же диапазона времени. Код ошибки, приведенный ниже, указывает:
Ошибка — 2146893039 (0x80090311): для проверки подлинности невозможно связаться с центром.
Причина
Эти ошибки возникают, когда LSASS перестает отвечать.
Решение
Чтобы устранить ошибки LSASS, выполните следующие действия.
Проверьте правильность регистрации имени субъекта-службы на контроллере домена (DC).
setspn -QИспользуйте команду илиsetspn -Lкоманду для запроса имени участника-службы и имени субъекта-службы соответственно в вашей учетной записи.