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ADRMS Troubleshooting: File Management Task fails with error 0x80045380 after adding templates to FSRM task


Symptoms

After adding a new ADRMS template to FSRM task, we get the error below when trying to run the File Management Task:

Exception from HRESULT: 0x80045380  Context: - Exception encountered = Exception from HRESULT: 0x80045380

Cause

FSRM uses a single RMS session handle regardless of how many RMS jobs are currently running, and any new job that starts will use the existing session handle if it is available. Otherwise it will create a new one. The list of RMS templates is cached per session handle so FSRM will only see the templates that were created at the time the session handle was created.

Normally, this is not an issue since we create the RMS session handle when a new RMS job starts running and destroy it at the end, however in this case there is one or more RMS jobs that are configured to run continuously so the session handle is essentially permanent. Any new RMS jobs that start will reuse the RMS session handle that was created by the continuous RMS job and as such will only see the list of RMS templates that were cached for that session handle.

Resolution

To resolve this issue, restart the FSRM Service running on the FSRM server.