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Azure App Service: Kudu console is not reachable

Introduction

Recently went through a downtime of an OSS application and even the Kudu Console wasn´t accesible. Kudu console gives you access to manage your app service from a web browser and enables you to manage the resources and the possibility to use CMD/PowerShell. 

To access to Kudu Console just go to the browser and type: yourdomain.scm.azurewebsites.net. 

Issue: WebApp is down and Kudu console is not reachable

Error 503 the service is unavailable

Possible Causes: 

  •  Request is taking too much time to resolve
  •  App service is having a high memory/CPU consumption
  •  App service is going through an exception

 
For this case specific the downtime error was related to a Wordpress App Service + MySQL in App running on Windows which was running webjobs and some Site Extentions.   

Root cause was one of the Site Extensions App host file (applicationHost.xdt) that was updated automatically and was overwriting the Application Host file of the Wordpress App Host file.  

The Site Extensions are usually updated and may impact the Azure App Service applicationhost.config file.

The App host file (applicationhost.config) includes all the configuration of the app service and is located on the directory: 

D:\local\AppData\ApplicationInsightsProfiler>
That said, one of the Site Extensions of the App Service was overwriting this applicationhost.config file

Solution:

  If scaling up your app service or restarting your app service not works at all, try the following: 

  •   Verify if you can access via FTP Client to your App files
  •    Backup your entire App Service
  •    For this specific case since the App Service is related to a Wordpress site, try renaming the plugins folder to something like "plugins-old"
  •    Enable logs through Azure Portal on the Configuration Settings.
  •    Go to your FTP Client, connect to your site and go to the SiteExtensions folder, then try remove all extensions that are not critical to your app.