이 문서는 Azure Portal에서 예약 인스턴스 사용량 세부 정보 다운로드를 사용할 수 없는 이유를 이해하고 문제를 해결하는 데 도움이 됩니다.
증상
- Azure Portal에 로그인하고, 예약으로 이동합니다.
- 예약을 선택합니다.
- 예약 개요 페이지에서 기본 보기는 지난 7일 동안의 사용량을 보여 줍니다. CSV로 다운로드를 선택하여 예약의 사용 세부 정보를 다운로드할 수 있습니다.
- 시간 범위를 변경하면 CSV로 다운로드 하는 옵션을 사용할 수 없게 됩니다.
원인
기술적 제한으로 인해 Azure는 7일 이상 데이터 다운로드를 지원하지 않습니다. 예약이 많은 고객의 긴 기간은 많은 양의 데이터를 생성합니다. API를 통해 데이터를 반환하면 Azure 리소스에 부담이 됩니다.
해결 방법
우리는 고객이 더 오랜 기간 동안 데이터를 다운로드하려고 한다는 것을 이해합니다. 그러나 현재 장기간 예약 사용량 현황 데이터를 다운로드할 수 있는 방법은 없습니다.
다음 단계
- 예약에 대한 자세한 내용은 Azure Reservations란?을 참조하세요.