Azure Load Balancer 문제 해결

이 페이지에서는 기본 및 표준 공통 Azure Load Balancer 질문에 대한 문제 해결 정보를 제공합니다. 표준 Load Balancer에 대한 자세한 내용은 표준 Load Balancer 개요를 참조하세요.

Load Balancer 연결을 사용할 수 없는 경우 가장 일반적인 증상은 다음과 같습니다.

  • Load Balancer 뒤에 있는 VM이 상태 프로브에 응답하지 않음
  • Load Balancer 뒤의 VM이 구성된 포트의 트래픽에 응답하지 않습니다.

백 엔드 VM에 대한 외부 클라이언트가 부하 분산 장치를 통과하면 클라이언트의 IP 주소가 통신에 사용됩니다. 클라이언트의 IP 주소가 NSG 허용 목록에 추가되어 있는지 확인합니다.

문제: 표준 ILB(내부 Load Balancer)에서 아웃바운드 연결이 없음

유효성 검사 및 확인

표준ILB는 기본적으로 안전합니다. 기본 ILB는 기본 아웃바운드 액세스 IP라는 숨겨진 공용 IP 주소를 통해 인터넷에 연결할 수 있도록 허용했습니다. IP 주소가 고정적이거나 소유한 네트워크 보안 그룹을 통해 잠겨 있지 않으므로, 프로덕션 워크로드에는 권장되지 않습니다. 최근에 기본 ILB에서 표준 ILB로 이동한 경우 네트워크 보안 그룹을 통해 IP를 잠그는 아웃바운드 전용 구성을 통해 명시적으로 공용 IP를 만들어야 합니다. 서브넷에서 NAT 게이트웨이사용할 수도 있습니다. NAT Gateway는 아웃바운드에 권장되는 솔루션입니다.

문제: 표준 ELB(외부 Load Balancer)에 대한 인바운드 연결 없음

원인

표준 부하 분산 장치 및 표준 공용 IP 주소는 네트워크 보안 그룹에서 열지 않는 한 인바운드 연결에 대해 닫힙니다. NSG는 허용된 트래픽을 명시적으로 허용하는 데 사용됩니다. 서브넷에 NSG가 없거나 가상 머신 리소스의 NIC가 없으면 트래픽이 이 리소스에 도달할 수 없습니다.

해결

수신 트래픽 을 허용하려면 가상 리소스의 서브넷 또는 인터페이스에 네트워크 보안 그룹을 추가합니다.

문제: 백 엔드 풀에 가상 머신 확장 집합이 배포된 부하 분산 장치의 기존 LB 규칙에 대한 백 엔드 포트를 변경할 수 없습니다.

원인

Virtual Machine Scale Set에서 참조하는 부하 분산 장치에 대한 상태 프로브에서 사용하는 부하 분산 규칙에 대해 백 엔드 포트를 수정할 수 없습니다.

해결

포트를 변경하려면 Virtual Machine Scale Set을 업데이트하여 상태 프로브를 제거하고 포트를 업데이트한 다음 상태 프로브를 다시 구성할 수 있습니다.

문제: 부하 분산 장치의 백 엔드 풀에서 VM을 제거한 후에도 적은 트래픽이 부하 분산 장치를 통과합니다.

원인

백 엔드 풀에서 제거된 VM은 더 이상 트래픽을 수신하지 않습니다. 적은 양의 네트워크 트래픽은 Azure 내의 스토리지, DNS 및 기타 함수와 관련될 수 있습니다.

해결

확인하려면 네트워크 추적을 수행할 수 있습니다. Blob 스토리지 계정에 사용되는 FQDN(정규화된 도메인 이름)은 각 스토리지 계정의 속성 내에 나열됩니다. Azure 구독 내의 가상 머신에서 nslookup을 수행하여 해당 스토리지 계정에 할당된 Azure IP를 확인할 수 있습니다.

문제: 실패한 상태의 부하 분산 장치

해결

  • 실패한 상태의 리소스를 식별한 후에는 Azure Resource Explorer로 이동하여 이 상태에 있는 리소스를 식별합니다.
  • 오른쪽 상단 모서리의 토글을 읽기/쓰기로 업데이트합니다.
  • 실패한 상태의 리소스에 대해 편집을 선택합니다.
  • PUTGET을 차례로 선택하여 프로비전 상태가 성공함으로 업데이트되었는지 확인합니다.
  • 리소스가 실패 상태에서 벗어나면 다른 작업을 진행할 수 있습니다.

문제 해결 및 지원 사례에 필요한 네트워크 캡처

지원 사례를 열기로 결정한 경우 더 빠른 해결을 위해 다음 정보를 수집합니다. 단일 백 엔드 VM을 선택하여 다음 테스트를 수행합니다.

  • 가상 네트워크 내의 백 엔드 VM 중 하나에서 프로브 ps ping 포트 응답(예: ps ping 10.0.0.4:3389)을 테스트하고 결과를 기록합니다.
  • 이러한 ping 테스트에서 응답을 받지 못하면 PsPing을 실행하는 동안 백 엔드 VM 및 가상 네트워크 테스트 VM에서 동시 Netsh 추적을 실행한 다음 Netsh 추적을 중지합니다.

다음 단계

앞의 단계에서 문제가 해결되지 않으면 지원 티켓을 엽니다.