Microsoft 퀀텀 개발 키트(QDK)는 .qs 또는 .qasm 파일로 작업할 때 언어별 기능과 함께 VISUAL STUDIO CODE(VS Code)의 표준 기능을 사용합니다. 이 참조 가이드에서는 VS Code 명령 팔레트에서 액세스할 수 있는 주요 QDK 명령과 다른 기능 및 추가 콘텐츠에 대한 링크를 설명합니다. 일반적인 VS Code 지침은 VS Code 설명서를 참조 하세요.
QDK 확장의 대부분의 명령은 명령 팔레트 보기 > 메뉴에서 액세스할 수 있습니다. 명령 팔레트를 열고 QDK:를 입력하면 .qs, .qasm 또는 .qsc 파일에서 필터링된 명령 목록을 볼 수 있습니다.
Tip
바로 가기 키 또는 Ctrl + K + S를 사용하여 VS Code 명령에 대한 사용자 지정 바로 가기 키를 만들 수 있습니다. 자세한 내용은 VS Code에 대한 키 바인딩을 참조하세요.
Commands
대부분의 QDK 명령은 Q# 및 OpenQASM 프로그램 작성 및 실행과 관련이 있으며 , .qasm또는 .qsc 파일이 활성화된 경우에만 사용할 수 있습니다.qs. 다른 명령은 일반적으로 사용할 수 있습니다.
일반 명령
| Command | Action | Notes | 대체 사용자 작업 |
|---|---|---|---|
| QDK: Q# 프로젝트 만들기 | 활성 폴더에 qsharp.json 매니페스트 파일을 포함하여 Q# 프로젝트를 생성하고, 기본 src 파일이 포함된 main.qs 하위 폴더를 생성합니다. |
Q# 프로젝트에 대한 자세한 내용은 Q# 프로젝트 작업을 참조 하세요. | 파일 탐색기 대상 폴더를 마우스 오른쪽 단추로 클릭하고 Q# 프로젝트 만들기를 선택합니다. |
| QDK: Microsoft Quantum Notebook 만들기 | Q# + Python 프로그램을 실행하고 Azure Quantum에 작업을 제출하는 샘플 Jupyter Notebook을 엽니다. | Jupyter Notebook QDK에 대한 자세한 내용은 QDK Python 패키지로 Azure Quantum 작업 제출을 참조하세요. | N/A |
| QDK: Azure Quantum 작업 영역에 연결 | Azure 계정 또는 연결 문자열 사용하여 Azure Quantum 작업 영역에 연결합니다. 인증되면 Microsoft 양자 패널 아이콘(왼쪽 아래)을 선택합니다. | Azure Quantum 연결에 대한 자세한 내용은 Azure Quantum 작업 영역에 연결을 참조하세요. | Quantum 작업 영역을 마우스로 가리키고 + 아이콘을 선택합니다. |
| QDK: QDK 플레이그라운드 열기 | 파일 탐색기에서 Q# 및 OpenQASM 샘플 프로그램의 온라인 폴더를 엽니다. 로컬 양자 시뮬레이터에서 프로그램을 편집하고 실행하고, 기본 제공 디버거를 사용하여 중단점을 설정하고 코드를 단계별로 실행할 수도 있습니다. | 자세한 내용은 샘플 폴더의 추가 정보 파일을 참조하세요. | N/A |
| QDK: Azure Quantum 작업 영역 새로 고침 | 연결된 양자 작업 영역의 최신 변경 내용을 동기화합니다. | 연결 문제가 있는 경우 작업 영역 이름 옆에 경고 아이콘이 나타납니다. | Quantum 작업 영역을 마우스로 가리키고 새로 고침 아이콘을 선택합니다. |
| QDK: Microsoft Quantum Python 가상 환경 만들기 | 폴더를 만들고 선택한 패키지를 사용하여 Python 가상 환경을 설치합니다. | 데스크톱 VS Code에서 사용할 수 있지만 웹용 VS Code에서는 사용할 수 없습니다. | N/A |
| QDK: 블로흐 구 | 블로흐 구 시각화 도구를 엽니다. | 자세한 내용은 QDK에서 Bloch 구 시각화 도우미를 사용하는 방법을 참조하세요. | N/A |
| QDK: Changelog 표시 | 현재 및 모든 이전 릴리스 버전의 QDK 업데이트를 보여 주는 새 탭에서 변경 로그를 엽니다. | 변경 로그는 오픈 소스 QDK GitHub 리포지토리에서도 사용할 수 있습니다. | N/A |
| 탐색기: 양자 작업 영역 보기에 집중 | 파일 탐색기 열고 구성된 경우 연결된 양자 작업 영역에 중점을 둡니다. 구성된 작업 영역이 없는 경우 기존 작업 영역을 추가하라는 메시지가 표시됩니다. | Azure Quantum 연결에 대한 자세한 내용은 Azure Quantum 작업 영역에 연결을 참조하세요. | N/A |
활성 파일 형식에 따라 사용할 수 있는 명령
| Command | 프로그램 파일 형식 | Action | Notes | 대체 사용자 작업 |
|---|---|---|---|---|
| QDK: 회로 표시 |
.qs, .qasm |
실행하기 전에 프로그램의 회로 다이어그램을 표시합니다. | 자세한 내용은 양자 회로 다이어그램 시각화를 참조 하세요. | 진입점 작업 옆의 메뉴에서 또는 프로그램의 각 사용자 정의 작업 위에 있는 코드 렌즈 옵션 회로 를 선택합니다. |
| QDK: 파일 실행 및 히스토그램 표시 |
.qs, .qasm |
현재 프로그램을 실행하고 결과의 히스토그램을 새 창에 표시합니다. | 정렬 및 필터 옵션에 액세스하려면 히스토그램 창에서 필터 아이콘을 선택합니다. | 진입점 작업 옆의 메뉴에서 코드 렌즈 옵션 히스토그램 을 선택합니다. |
| QDK: 현재 QDK 프로그램에 대한 QIR 가져오기 |
.qs, .qasm |
새 편집 창에서 현재 Q# 또는 OpenQASM 코드에 대한 QIR 소스를 엽니다. 프로그램은 Base, Adaptive RI 또는 Adaptive RIF 대상 프로필을 사용하여 QIR 원본을 내보내야 합니다. | QIR에 대한 자세한 내용은 Quantum 중간 표현 및 QDK 개발자 블로그를 참조하세요. | N/A |
| QDK: 리소스 예측 계산 |
.qs, .qasm |
기본 제공 버전의 리소스 추정기를 호출합니다. | 자세한 내용은 Microsoft Quantum 리소스 추정기 소개를 참조하세요. | N/A |
| QDK: 도움말 | .qs |
VS Code에서 QDK 확장에 대한 간략한 개요를 엽니다. | N/A | N/A |
| QDK: 파일 실행 및 회로 다이어그램 표시 |
.qs, .qasm |
현재 프로그램을 실행하고 출력이 있는 프로그램의 회로를 표시합니다. | 자세한 내용은 양자 회로 다이어그램 시각화를 참조 하세요. | N/A |
| QDK: API 설명서 표시 | .qs |
새 창에서 API 설명서를 엽니다. 이 창을 검색하려면 Ctrl+F를 누릅니다. | 자세한 내용은 Q# API 참조를 참조하세요. | N/A |
| 디버그: 디버깅 시작 |
.qs, .qasm, .qsc |
디버거에서 현재 프로그램을 엽니다. | 자세한 내용은 양자 코드 디버깅 및 테스트를 참조하세요. | F5 키를 누르고 진입점 작업 옆에 있는 코드 렌즈 옵션 디버그를 선택하거나 오른쪽 위 모서리에서 실행 아이콘을 선택한 다음 디버깅 시작을 선택합니다. |
| QDK: 프로그램 실행 |
.qs, .qasm, .qsc |
기본 양자 시뮬레이터에서 현재 프로그램을 실행합니다. | 자세한 내용은 Q# 프로그램 시작을 참조 하세요. | Ctrl+F5를 누르고 진입점 작업 옆에 있는 코드 렌즈 옵션 실행을 선택하거나 오른쪽 위 모서리에서 실행 아이콘을 선택한 다음 실행을 선택합니다. |
패널 보기
Q# 및 OpenQASM 프로그램은 VS Code 패널에서 다음 보기를 사용합니다.
| View | Action |
|---|---|
| 디버그 콘솔 | 실행 출력 또는 디버그 출력을 표시합니다. |
| 문제 | 미리 컴파일된 오류 검사를 표시합니다. |
Q# 및 OpenQASM 코드 편집
VS Code의 일반적인 코드 편집 기능 대부분은 Q# 및 OpenQASM 프로그램을 사용할 때도 사용할 수 있습니다.
- 사전 컴파일 오류 검사
- 정의로 이동
- References
- 함수 서명
- 매개 변수 정보
- 컨텍스트 인식, 네임스페이스 멤버 및 형식 멤버 완성을 포함한 완료 제안입니다.
- Linting - Q# 파일에서 매니페스트 파일에서 프로젝트당 linting을 구성합니다. 자세한 내용은 Q# 프로젝트 작업을 참조 하세요.
자세한 내용은 VS Code 설명서의 IntelliSense 를 참조하세요.
일반적인 작업
다음 표에서는 QDK 확장을 사용할 때 일반적인 작업에 대한 명령을 나열합니다.
Q# 파일 및 프로젝트 작업
| 과업 | Action | Notes |
|---|---|---|
| 새 Q# 파일 만들기 | 선택 파일 > 새 파일 > 텍스트 파일. 확장자를 사용하여 파일을 저장합니다 .qs . |
설정하는 Files: Default Language = qsharp경우 새 파일은 자동으로 Q# 서식으로 설정됩니다. |
| Q# 프로젝트 만들기 | 파일 탐색기의 열린 폴더에서 QDK: 명령 팔레트에서 Q# 프로젝트 만들기 를 선택하거나 파일 탐색기에서 폴더를 마우스 오른쪽 단추로 클릭하고 Q# 프로젝트 만들기를 선택합니다. | Q# 프로젝트에 대한 자세한 내용은 Q# 프로젝트 작업을 참조 하세요. |
| 샘플 파일 만들기 | 빈 .qs 파일이나 .qasm 파일에 샘플을 입력한 다음 옵션 목록에서 샘플 프로그램을 선택합니다. |
QDK: 명령 팔레트에서 QDK 플레이그라운드를 열어 파일 탐색기에서 Q# 및 OpenQASM 샘플 프로그램의 온라인 폴더를 열 수도 있습니다. |
Azure Quantum에 연결
| 과업 | Action | Notes | 대체 사용자 작업 |
|---|---|---|---|
| Azure Quantum 작업 영역에 연결 | Microsoft 양자 패널 아이콘(왼쪽 아래)을 선택합니다. Quantum 작업 영역에서기존 작업 영역 추가를 선택합니다. 프롬프트에 따라 구독 및 작업 영역을 선택합니다. | 여러 작업 영역에 연결할 수 있습니다. Quantum 작업 영역 옆에 있는+를 선택하여 다른 작업 영역을 연결합니다. 작업 영역 연결은 VS Code 세션 간에 유지됩니다. | 명령 팔레트에서 QDK를 선택합니다. Azure Quantum 작업 영역에 연결합니다. |
| Python 프로그램을 사용하여 프로그래밍 방식으로 연결 | 기존 작업 영역 연결을 마우스 오른쪽 단추로 클릭하고 Python 코드 복사를 선택하여 작업 영역에 연결합니다. 결과 코드를 Python 프로그램에 붙여넣습니다. | 자세한 내용은 QDK Python 패키지를 사용하여 Azure Quantum 작업 제출을 참조하세요. | N/A |
프로그램 실행
| 과업 | Action | Notes | 대체 사용자 작업 |
|---|---|---|---|
| 로컬 양자 시뮬레이터에서 Q# 또는 OpenQASM 프로그램 실행 |
또는 파일에서 오른쪽 상단의 .qasm 아이콘을 선택한 다음 .qs을 선택합니다. |
양자 시뮬레이터에 대한 자세한 내용은 스파스 양자 시뮬레이터를 참조 하세요. | Ctrl+F5를 누르거나 명령 팔레트에서 QDK: 파일 실행 및 히스토그램 표시 또는 QDK: 파일 실행 및 회로 다이어그램 표시를 선택하거나 진입점 작업 위에 코드 렌즈 실행 옵션을 선택합니다. |
| 프로그램 디버그 | Q# 또는 OpenQASM 프로그램에서 오른쪽 위에 있는 실행 아이콘을 선택한 다음 디버깅 시작을 선택합니다. | VS Code의 Q# 디버거에 대한 자세한 내용은 양자 코드 디버깅 및 테스트를 참조하세요. | F5 키를 누르거나 진입점 작업 위의 메뉴에서 코드 디버그 코드 렌즈를 선택합니다. |
| 작업 영역에서 공급자 및 대상 보기 | Microsoft 양자 패널 아이콘(왼쪽 아래)을 선택합니다. Quantum 작업 영역에서 작업 영역을 확장한 다음 공급자를 확장하여 작업 영역에서 사용 가능한 공급자를 확인합니다. 개별 공급자를 확장하여 사용 가능한 대상을 봅니다. | 작업을 제출하기 전에 대상 이름을 마우스로 가리키면 상태 및 큐 시간을 볼 수 있습니다. | N/A |
| Azure Quantum에 작업 제출 | Q# 또는 OpenQASM 프로그램에서 작업 영역, 공급자 및 대상을 선택합니다. 현재 프로그램을 제출하려면 대상 옆에 있는 화살표를 선택합니다. | 자세한 내용은 VS Code용 QDK 확장을 사용하여 Azure Quantum 작업 제출을 참조하세요. | N/A |
| 작업 결과 보기 | 작업 영역을 확장한 다음 작업을 확장합니다. Azure Storage에서 작업 출력을 열려면 작업 이름 옆에 있는 클라우드 아이콘을 선택합니다. | 작업은 최신에서 가장 오래된 작업으로 나열됩니다. | N/A |