다음을 통해 공유


BizTalk Server 도구 문제 해결

이 항목에서는 BizTalk Server 포함된 도구를 사용하는 동안 발생하는 일반적인 문제에 대한 정보를 위한 중앙 집중식 위치를 제공합니다.

알려진 문제

BizTalk Server 도구 및 유틸리티가 UAC를 지원하는 Windows 시스템에서 올바르게 작동하지 않을 수 있음

문제

UAC(사용자 계정 컨트롤)를 지원하는 시스템에 BizTalk Server 설치된 경우 BizTalk Server 포함된 도구가 성공적으로 시작되지 않거나 제대로 작동하지 않을 수 있습니다.

원인

특정 권한 수준에 대해 플래그가 지정된 응용 프로그램을 실행할 때 필요한 수준이 응용 프로그램을 실행하는 사용자의 수준보다 높은 경우 UAC는 응용 프로그램 권한을 필요한 수준으로 임시 향상할 수 있다는 메시지를 표시합니다. BizTalk Server 함께 제공되는 도구에는 권한 상승을 자동으로 요청할 수 있는 올바른 플래그가 없으므로 도구는 애플리케이션을 실행하는 사용자의 현재 권한 수준에서 실행을 시도하고 더 높은 권한 수준이 필요한 경우 실패합니다.

해결 방법

이 문제를 해결하려면 관리자 권한으로 모든 BizTalk Server 도구를 실행합니다. 관리 권한이 있는 도구를 실행하려면 애플리케이션을 마우스 오른쪽 단추로 클릭한 다음 관리자 권한으로 실행을 선택합니다.

사용자 계정 컨트롤에 대한 자세한 내용은 를 참조하세요 https://go.microsoft.com/fwlink/?LinkId=99167.

BizTalk 맵 편집기 도구 상자가 비어 보일 수 있음

문제

Visual Studio에서 맵 편집기 도구 상자를 열면 도구 상자에 어느 펑토이드도 표시되지 않는 경우가 있습니다.

원인

Visual Studio 추가 기능 및/또는 패치 설치/제거로 인해 도구 상자가 손상되었을 수 있습니다.

해결 방법

이 문제를 해결하려면

  1. 실행 중인 Visual Studio 인스턴스를 모두 닫습니다.

  2. 관리자 권한으로 Visual Studio 명령 프롬프트 를 시작합니다.

  3. 명령 프롬프트에서 다음 명령을 입력합니다.

    devenv.exe /setup