적용 대상:
- Microsoft Defender for Endpoint(macOS용)
- 엔드포인트용 Microsoft Defender 플랜 1
- 엔드포인트용 Microsoft Defender 플랜 2
- Microsoft Defender XDR
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라이선스를 찾을 수 없음
macOS에서 엔드포인트용 Microsoft Defender 배포되는 경우 macOS 쉴드에서 엔드포인트용 Microsoft Defender 위에 x가 있는 오류 메시지가 나타납니다.
x 기호를 선택합니다.
메시지
x 기호를 선택하면 다음 스크린샷과 같이 옵션이 표시됩니다.
필요한 작업을 선택하면 다음 스크린샷과 같이 오류 메시지가 표시됩니다.
다른 방식으로 이 메시지가 발생합니다. 터미널을 사용하여 큰따옴표 없이 mdatp 상태를 입력하는 경우 다음 스크린샷과 같은 메시지가 표시됩니다.
원인
macOS 패키지 다운로드 설치 패키지에 엔드포인트용 Microsoft Defender 배포 및/또는 설치한 경우 오류가 발생할 수 있지만 라이선스 설정을 포함하는 구성 스크립트를 실행하지 않았을 수 있습니다. 15단계: 디바이스 및 구성 상태 확인을 참조하세요. 이 시나리오의 문제 해결에 대한 자세한 내용은 구성 스크립트를 실행하지 않은 경우를 참조하세요.
macOS 에이전트의 엔드포인트용 Microsoft Defender 최신이 아닌 경우 오류 메시지가 발생할 수 있습니다. 이 시나리오의 문제 해결에 대한 자세한 내용은 macOS의 엔드포인트용 Microsoft Defender 최신이 아닌 경우를 참조하세요.
macOS에서 엔드포인트용 Microsoft Defender macOS 디바이스를 오프보딩하고 다시 등록하는 경우 오류 메시지가 발생할 수 있습니다.
라이선스가 사용자에게 할당되지 않은 경우 오류 메시지가 발생할 수 있습니다. 이 시나리오의 문제 해결에 대한 자세한 내용은 라이선스가 사용자에게 할당되지 않은 경우를 참조하세요.
해결 방법
구성 스크립트를 실행하지 않은 경우
이 섹션에서는 구성 스크립트의 nonexecution으로 인해 오류/경고 메시지가 발생하는 경우의 문제 해결 측정값에 대해 설명합니다. 스크립트에는 macOS 패키지의 엔드포인트용 Microsoft Defender 설치 및 배포될 때 라이선스 설정이 포함됩니다.
사용되는 배포 관리 도구에 따라 다음 표에 설명된 대로 도구별 지침에 따라 패키지를 온보딩(라이선스 등록)합니다.
관리 | 라이선스 배포 지침(온보딩 지침) |
---|---|
Intune | 디바이스 및 구성 상태 확인 |
JamF | 엔드포인트용 Microsoft Defender 온보딩 패키지 가져오기 |
기타 MDM | 라이선스 설정 |
수동 설치 | 설치 및 온보딩 패키지를 다운로드합니다. 및 온보딩 패키지 |
참고
온보딩 패키지가 올바르게 실행되면 라이선스 정보는 에 있습니다 /Library/Application Support/Microsoft/Defender/com.microsoft.wdav.atp.plist
.
macOS에서 엔드포인트용 Microsoft Defender 최신이 아닌 경우
macOS의 엔드포인트용 Microsoft Defender 최신이 아닌 시나리오의 경우 에이전트를 업데이트해야 합니다.
macOS의 엔드포인트용 Microsoft Defender 오프보딩된 경우
오프보딩 스크립트가 macOS에서 실행되면 파일을 /Library/Application Support/Microsoft/Defender/
에 저장하고 이름이 com.microsoft.wdav.atp.offboarding.plist
입니다.
파일이 있으면 macOS가 다시 온보딩되지 않습니다. 온보딩 스크립트를 실행하는 com.microsoft.wdav.atp.offboarding.plist 를 다시 삭제합니다.
라이선스가 사용자에게 할당되지 않은 경우
Microsoft Defender 포털(security.microsoft.com)에서 설정을 선택한 다음 엔드포인트를 선택합니다.
라이선스를 선택합니다.
Microsoft 365 관리 센터 라이선스 보기 및 구매를 선택합니다. Microsoft 365 관리 센터 포털의 다음 화면이 나타납니다.
Microsoft에서 구입하려는 라이선스의 확인란을 선택하고 선택합니다. 선택한 라이선스의 세부 정보를 표시하는 화면이 나타납니다.
라이선스 할당 링크를 선택합니다.
다음 화면이 나타납니다.
+ 라이선스 할당을 선택합니다.
이 라이선스를 할당하려는 사용자의 이름 또는 전자 메일 주소를 입력합니다. 선택한 라이선스 담당자의 세부 정보와 옵션 목록을 표시하는 다음 화면이 나타납니다.
Microsoft 365 고급 감사, Microsoft Defender XDR 및 엔드포인트용 Microsoft Defender 확인란을 선택합니다. 그런 다음 저장을 선택합니다.
이러한 솔루션 옵션(둘 중 하나)을 구현할 때 라이선스 문제가 해결된 후 mdatp 상태를 실행하면 다음 결과가 표시됩니다.
Microsoft 계정으로 로그인
메시지
Microsoft 계정으로 로그인하여 시작합니다.
새 계정을 만들거나 엔터프라이즈 앱으로 전환합니다.
원인
이전에 설치한 엔드포인트용 Microsoft Defender 위에 macOS의 개인용 Microsoft Defender 다운로드하고 설치했습니다.
해결 방법
엔터프라이즈 앱으로 전환을 선택하여 엔터프라이즈 환경으로 전환합니다.
Defender 설정에 userInterface/consumerExperience 를 포함하여 MDM 등록 컴퓨터의 개인에 대한 환경으로 전환하지 않을 수도 있습니다.
<key>userInterface</key>
<dict>
<key>consumerExperience</key>
<string>disabled</string>
</dict>
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팁
더 자세히 알아보고 싶으신가요? 기술 커뮤니티: 엔드포인트용 Microsoft Defender Tech Community의 Microsoft 보안 커뮤니티와 Engage.