다음을 통해 공유


Dynamics 365와 LinkedIn 세일즈 내비게이터 통합과 관련된 문제 해결

이 문서는 Dynamics 365 Sales의 LinkedIn 통합과 관련된 문제를 해결하는 데 도움이 됩니다.

LinkedIn 업데이트 활성화 오류

원인

세일즈 내비게이터 통합 설정 대화 상자에서 데이터 유효성 검사 옵션(LinkedIn 업데이트 활성화)을 활성화하면 데이터 유효성 검사가 실패했다는 상태가 표시될 수 있습니다. 가능한 오류는 다음과 같습니다.

  • LinkedIn 세일즈 내비게이터에서 CRM Sync가 비활성화되어 데이터 유효성 검사에 실패했습니다.
  • 다른 오류로 인해 데이터 유효성 검사에 실패했습니다(예: "예기치 않은 오류").

LinkedIn 업데이트 활성화 오류.

LinkedIn 세일즈 내비게이터의 데이터 유효성 검사 기능에 대한 자세한 내용은 데이터 유효성 검사을 참조하세요.

해결

  • CRM 동기화가 비활성화되어 데이터 유효성 검사에 실패하면 다음을 확인하십시오.

    • LinkedIn 세일즈 내비게이터에서 CRM Sync가 활성화되었습니다.

    • 데이터 유효성 검사 설정이 LinkedIn 세일즈 내비게이터에서 활성화되었습니다. 이 설정을 사용하지 않으면 CRM 동기화를 사용하더라도 CRM 동기화 사용 안함 상태가 표시됩니다. LinkedIn 세일즈 내비게이터에서 데이터 유효성 검사 설정을 볼 수 없는 경우 적절한 세일즈 내비게이터 라이선스가 있는지 확인하십시오. 추가 정보: 세일즈 내비게이터 데이터 유효성 검사 - 개요

    • 두 설정을 모두 켠 경우 LinkedIn 업데이트 활성화 설정을 적어도 한 번 설정했는지 확인하십시오.

  • CRM Sync 이외의 다른 오류로 인해 오류가 발생한 경우 먼저 세일즈 내비게이터 통합 설정 대화 상자에서 데이터 유효성 검사를 비활성화한 다음 다시 활성화하여 데이터 유효성 검사를 다시 시작할 수 있습니다.

LinkedInSalesNavigatorForUnifiedClient 솔루션을 업그레이드할 수 없음

원인

LinkedInSalesNavigatorForUnifiedClient 솔루션을 1.x에서 3.x로 업그레이드할 수 없습니다. 이 문제는 솔루션에 존재하는 종속성으로 인해 발생합니다. 연결된 종속성이 있는 솔루션을 업데이트할 수 없습니다.

해결

이 문제를 해결하려면 LinkedInSalesNavigatorForUnifiedClient 솔루션에 대한 기존 종속성을 제거해야 합니다. 다음 단계를 수행하세요.

  1. 현재 LinkedInSalesNavigatorForUnifiedClient 솔루션에 대해 종속성을 제거하고 솔루션을 제거하십시오. 자세한 정보는 LinkedIn 세일즈 내비게이터 제거의 4단계를 참조하십시오.

  2. msdyn_LinkedInSalesNavigatorAnchor 솔루션을 제거합니다.

  3. 솔루션이 성공적으로 삭제되면 다시 설치하십시오. 추가 정보: LinkedIn 세일즈 내비게이터 설치 및 활성화

LinkedIn 세일즈 내비게이터 표시 위젯이 다른 웹 브라우저에 제대로 로드되지 않습니다

원인

LinkedIn 세일즈 내비게이터에 로그인을 시도하면 오류가 표시됩니다. 이러한 오류는 브라우저에서 추적 보호가 사용 설정되었기 때문에 발생합니다. 다음은 오류의 예입니다.

  • 디스플레이 위젯에 LinkedIn 세일즈 내비게이터 구독을 찾을 수 없습니다. 액세스하려면 LinkedIn 세일즈 내비게이터 팀 계약이 필요합니다라는 오류가 표시됩니다.

    디스플레이 위젯에 구독을 찾을 수 없음 오류가 표시됨.

-또는-

  • 표시 위젯이 다른 브라우저에서 로드되지 않습니다. 다음 샘플 이미지에 표시된 오류가 나타납니다.

    디스플레이 위젯이 로드되지 않음.

해결

이 문제를 해결하려면 브라우저에서 추적 보호를 사용하지 않음으로 설정해야 합니다(Microsoft Edge, Mozilla FireFox, Google Chrome, Apple Safari).

Microsoft Edge:

  1. Microsoft Edge 브라우저를 엽니다.
  2. 오른쪽 상단에서 더 많은 옵션 아이콘을 선택하고 설정으로 이동합니다.
  3. 사이트 맵에서 개인 정보 보호, 검색 및 서비스로 이동합니다.
  4. 추적 방지 섹션에서 균형 있음을 선택하고 InPrivate을 검색할 때 항상 "엄격한" 추적 방지 사용 옵션을 사용하지 않음으로 설정합니다.

    Edge에서 추적 방지 섹션 구성.

Mozilla FireFox:

  1. Mozilla FireFox를 열고 조직을 찾은 다음 엽니다.
  2. 주소 표시줄 앞에 방패 아이콘을 선택하면 향상된 추적 보호 세부 정보가 나타납니다.
  3. 사이트에 대해 향상된 추적 보호가 켜져 있음 옵션을 사용하지 않음으로 설정하고 브라우저를 새로 고칩니다.

    FireFox에서 추적 방지 섹션 구성.

  4. 페이지를 새로 고치면 표시 위젯이 예상대로 로드되기 시작합니다.

Google Chrome:
Chrome 브라우저에서는 Incognito/Private 모드에서 표시 위젯의 로드 문제가 발생할 수 있습니다.
Incognito/Private 모드에서 조직을 탐색하는 동안 타사 쿠키 차단 옵션을 사용하지 않음으로 설정합니다. 표시 위젯이 로드될 것입니다.

Chrome에서 추적 방지 섹션 구성.

Apple Safari:

  1. Apple Safari를 열고 조직을 찾은 다음 엽니다.
  2. 선호 설정으로 이동하여 다음 옵션을 구성합니다.
    • LinkedIn 및 Dynamics 365 조직이 콘텐츠 차단기의 차단 목록에 없습니다.
    • Dynamics 365 조직이 팝업 창을 허용합니다.
    • 개인 정보 탭에서 사이트 간 추적 방지모든 쿠키 차단 옵션이 선택되지 않았습니다.

통합 인터페이스에서 사용자 지정 연락처 및 잠재 고객 양식의 사진을 볼 수 없음

원인
기본값으로 LinkedIn의 사진은 기본 연락처 및 잠재 고객 양식에 표시됩니다. 사용자 정의 양식의 경우 기본적으로 사진을 표시할 수 없습니다.

해결
이 문제를 해결하려면 msdyn_linkedintegrationcommon.js 라이브러리와 LinkedInIntegration.LinkedInIntegrationCommon.Instance.Form_OnLoad 함수 처리기를 사용자 지정 양식에 추가하세요. 다음 단계를 수행하세요.

  1. Dynamics 365 앱에 로그인합니다.
  2. 고급 설정>사용자 지정>시스템 사용자 지정으로 이동합니다.
  3. 엔티티 사이트 맵에서 엔터티를 선택한 다음 사진을 표시하려는 사용자 지정 양식을 선택합니다.

    노트

    이 절차에서는 연락처 사용자 지정 양식을 사용합니다.

  4. 양식 속성 옵션을 선택합니다.
    양식 속성 대화 상자가 열립니다.

    양식 속성 대화 상자.

  5. 양식 라이브러리 섹션에서 msdyn_linkedintegrationcommon.js 라이브러리를 양식에 추가합니다.
  6. 이벤트 처리기 섹션에서 LinkedInIntegration.LinkedInIntegrationCommon.Instance.Form_OnLoad 함수를 양식에 추가합니다.

    양식에 추가된 LinkedIn 라이브러리 및 함수.

  7. 양식을 저장 및 게시합니다.

LinkedInSalesNavigatorControlsForUnifiedClient 솔루션은 LinkedIn 세일즈 내비게이터를 구성하기 위해 조직에서 사용할 수 없습니다

원인
LinkedInSalesNavigatorControlsForUnifiedClient 솔루션은 LinkedIn 세일즈 내비게이터 솔루션 버전 2.2.0.1 이상을 가진 조직에서만 사용할 수 있습니다. LinkedIn 솔루션 버전이 2.2.0.1 미만인 경우 LinkedInSalesNavigatorControlsForUnifiedClient 솔루션을 수동으로 설치하세요.

해결
이 문제를 해결하려면 솔루션을 삭제하고 다시 설치하십시오.

노트

솔루션을 삭제하고 설치하면 li_inmails, li_message, li_pointdrivepresentationviewed 엔티티에 대한 데이터가 손실될 수 있습니다. 이러한 엔티티에서 데이터를 내보내고 설치시 복구합니다.

다음 단계를 수행하세요.

  1. LinkedIn 세일즈 내비게이터 솔루션을 삭제합니다. 솔루션을 삭제하기 전에 종속성을 확인합니다. (존재하는 경우), 시스템 관리자에게 문의하여 솔루션을 제거하십시오. 종속성을 제거하려면 다음 단계를 수행합니다.
    1. 고급 설정>사용자 지정>솔루션으로 이동합니다.
    2. LinkedIn 솔루션을 선택한 다음 종속성 표시를 선택합니다.

      LinkedIn 솔루션 종속성.

    3. 필수 엔티티 이름을 선택하면 종속 엔티티가 페이지에서 열립니다.
    4. 양식 속성을 선택하고 이벤트 탭 아래에서 이벤트 처리기 섹션으로 이동합니다.
    5. 이벤트를 선택하고 제거하십시오.
    6. 사용자 지정을 저장하고 게시합니다.
  2. msdyn_LinkedInSalesNavigatorAnchor 솔루션을 삭제합니다.
  3. LinkedIn 세일즈 내비게이터 솔루션을 다시 설치하고 엔터티에 대한 데이터를 복구합니다.

참조 항목

Dynamics 365 Sales 문제 해결 가이드