온-프레미스 Exchange에서 온라인으로 마이그레이션할 때 원격 서버 오류에 연결할 수 없습니다.

원래 KB 번호: 2903050

증상

Outlook Anywhere(HTTP를 통한 RPC라고도 함)를 사용하여 Exchange Online 온-프레미스 Exchange organization 단독형 마이그레이션을 수행하려고 하면 마이그레이션 엔진이 마이그레이션 엔드포인트를 만들지 않습니다. 또한 다음과 유사한 오류 메시지가 표시됩니다.

Microsoft.Exchange.Data.Storage.Management.MigrationTransientException: 원격 서버에 연결할 수 없습니다. 마이그레이션 엔드포인트 설정이 올바르고 인증서가 유효한지 확인한 다음 다시 시도하세요. Exchange 원격 연결 분석기를 사용하여 연결 문제를 진단하는 것이 좋습니다. >--- Microsoft.Exchange.Rpc.ServerUnavailableException: cli_NspiBind 오류 0x6ba(RPC 서버를 사용할 수 없음)

원인

이 문제는 Outlook Anywhere에 대해 다음 조건 중 하나 또는 둘 다에 해당하는 경우 발생할 수 있습니다.

  • Outlook Anywhere에 대한 인증 설정이 잘못되었습니다.
  • Outlook Anywhere에 대한 RPC 프록시 구성 설정이 잘못되었습니다.

해결 방법

이 문제를 resolve 다음 단계를 수행합니다.

  1. 온-프레미스 Outlook Anywhere 클라이언트 인증 방법이 기본 인증으로 설정되어 있는지 확인합니다. 자세한 내용은 실행 중인 Exchange Server 버전에 따라 다음 문서 중 하나를 참조하세요.

  2. 특정 포트를 사용하여 Outlook Anywhere와 통신하고 온-프레미스 도메인 컨트롤러가 포트 6004에서 수신 대기하도록 RPC 프록시 서버가 올바르게 설정되어 있는지 확인합니다. 자세한 내용은 Outlook Anywhere 작동 방식(작동하지 않음)을 참조하세요.

  3. 온-프레미스 Exchange 서버에 대한 Outlook Anywhere 연결을 확인합니다. 이렇게 하려면 다음과 같이 하십시오.

    1. 원격 PowerShell을 사용하여 Exchange Online에 연결합니다. 이 작업을 수행하는 방법에 대한 자세한 내용은 Exchange Online PowerShell에 연결을 참조하세요.

    2. 다음 PowerShell 명령을 실행합니다.

      $pscred=Get-Credential
      
      Test-MigrationServerAvailability -Credentials $pscred -ExchangeOutlookAnywhere -ExchangeServer <Internal FQDN of the Exchange server> -RPCProxyServer <FQDN of the proxyserver> -Authentication Basic -EmailAddress <AdminEmail>
      

      확인에 성공하면 Microsoft 365에서 마이그레이션 엔드포인트를 만들 수 있습니다.

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