다음을 통해 공유


온-프레미스 공용 폴더에 액세스할 때 자격 증명 프롬프트

증상

다음과 같은 경우를 생각해볼 수 있습니다.

  • 온-프레미스 및 Microsoft Exchange Online Microsoft Exchange Server 하이브리드 환경이 있습니다.
  • Exchange Server 온-프레미스에서 공용 폴더를 만듭니다.

이 시나리오에서는 Exchange Online 사용자가 온-프레미스 공용 폴더에 액세스하려고 할 때 자격 증명을 묻는 메시지가 반복적으로 표시됩니다.

또한 Exchange Server 로그(ExchangeInstallDirectory\Logging\MAPI 클라이언트 액세스)에는 다음 오류 항목이 포함됩니다.

MailUser 개체의 소유자 역할을 할 수 없습니다.

오류 메시지 세부 정보의 예는 다음과 같습니다.

"RpcDispatch: [LoginPermException] 'User SID: <SID number>'는 MailUser 개체 '/o=ExchangeLabs/ou=Exchange 관리 그룹(<그룹 이름>)/cn=Recipients/cn=<User identity-OnPrem>'의 소유자 역할을 <> 할 수 없습니다. 및 MasterAccountSid(StoreError=LoginPerm) at M.E.R.Server.UserManager.User.CorrelateIdentityWithLegacyDN(ClientSecurityContext clientSecurityContext) at M.E.R.Server.RpcDispatch.<>c__DisplayClassc.<M.E.R.Server.RpcDispatch.ExecuteWrapper(Func'1 getExecuteParameters, Func'1 executeDelegate, Action'1"에서 b__8() 연결>

원인

하이브리드 환경에서 Exchange Online 사용자 사서함은 소유자의 온-프레미스 메일 사용자 계정과 연결됩니다. 이 문제는 온-프레미스 메일 사용자 계정의 암호가 만료된 경우에 발생합니다.

해결 방법

이 문제를 resolve Exchange Online 사서함과 연결된 온-프레미스 사용자 계정의 암호를 다시 설정합니다.