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Windows Defender 또는 Endpoint Protection 클라이언트 문제 해결

적용 대상: Configuration Manager(현재 분기)

Windows Defender 또는 Endpoint Protection에 문제가 있는 경우 이 문서를 사용하여 다음 문제를 해결합니다.

Windows Defender 또는 Endpoint Protection 업데이트

증상

Windows Defender 또는 Endpoint Protection은 Microsoft 업데이트에서 자동으로 작동하여 바이러스 및 스파이웨어 정의가 최신 상태로 유지되도록 합니다.

이 섹션에서는 다음 상황을 포함하여 자동 업데이트와 관련된 일반적인 문제를 해결합니다.

  • 업데이트가 실패했음을 나타내는 오류 메시지가 표시됩니다.

  • 업데이트를 검사 바이러스 및 스파이웨어 정의 업데이트를 확인, 다운로드 또는 설치할 수 없다는 오류 메시지가 표시됩니다.

  • 디바이스가 인터넷에 연결되어 있더라도 업데이트가 실패합니다.

  • 업데이트 예약된 대로 자동으로 설치되지 않습니다.

원인

업데이트 문제의 가장 일반적인 원인은 인터넷 연결 문제입니다. 다른 웹 사이트를 탐색할 수 있으므로 디바이스가 인터넷에 연결되어 있다는 것을 알고 있는 경우 Windows의 인터넷 설정과 충돌하여 문제가 발생할 수 있습니다.

resolve 옵션

1단계: 인터넷 설정 다시 설정

  1. 웹 브라우저를 포함하여 열려 있는 모든 프로그램을 종료합니다.

    참고

    이러한 인터넷 설정을 다시 설정하면 브라우저 임시 파일, 쿠키, 검색 기록 및 온라인 암호를 삭제할 수 있습니다. 즐겨찾기를 삭제하지 않습니다.

  2. 시작 메뉴로 이동하여 을 엽니다inetcpl.cpl.

  3. 고급 탭으로 전환합니다.

  4. 인터넷 Explorer 설정 재설정 섹션에서 다시 설정을 선택한 다음 다시 설정을 선택하여 확인합니다.

  5. 설정이 다시 설정되면 확인을 선택합니다.

  6. Windows Defender 다시 업데이트해 보세요.

문제가 지속되면 다음 단계를 계속 진행합니다.

2단계: 컴퓨터에서 날짜와 시간이 올바르게 설정되었는지 확인

오류 메시지에 코드 0x80072f8f 포함된 경우 컴퓨터의 잘못된 날짜 또는 시간 설정으로 인해 문제가 발생할 가능성이 큽니다. 시작 메뉴로 이동하여 설정을 선택하고 시간 & 언어를 선택한 다음 날짜 & 시간을 선택합니다.

3단계: 컴퓨터의 소프트웨어 배포 폴더 이름 바꾸기

  1. Windows 업데이트 서비스를 중지합니다.

    1. 시작으로 이동하여 services.msc를 엽니다.

    2. Windows 업데이트 서비스를 선택합니다. 작업 메뉴로 이동하여 중지를 선택합니다.

  2. SoftwareDistribution 디렉터리의 이름을 바꿉니다.

    1. 명령 프롬프트를 관리자 권한으로 엽니다.

    2. 다음 명령을 입력합니다.

      cd %windir%
      ren SoftwareDistribution SDTemp
      exit
      
  3. Windows 업데이트 서비스를 다시 시작합니다.

    1. 서비스 창으로 다시 전환 합니다 .

    2. Windows 업데이트 서비스를 선택합니다. 작업 메뉴로 이동하여 시작을 선택합니다.

    3. 서비스 창을 닫습니다.

4단계: 컴퓨터에서 Microsoft 바이러스 백신 업데이트 엔진 다시 설정

  1. 명령 프롬프트를 관리자 권한으로 엽니다.

  2. 다음 명령을 입력합니다.

    cd \
    
    cd program files\windows defender
    
    MpCmdRun -RemoveDefinitions -all
    
    exit
    
  3. 컴퓨터를 다시 시작합니다.

  4. Windows Defender 다시 업데이트해 보세요.

문제가 지속되면 다음 단계를 계속 진행합니다.

5단계: 정의 업데이트 수동 설치

최신 업데이트를 수동으로 다운로드합니다.

6단계: Microsoft 지원에 문의

이러한 단계를 수행해도 문제가 resolve 경우 Microsoft 지원에 문의하세요. 자세한 내용은 지원 옵션 및 커뮤니티 리소스를 참조하세요.

Windows Defender 또는 Endpoint Protection 서비스 시작

증상

프로그램의 서비스가 중지되었기 때문에 Windows Defender 또는 Endpoint Protection이 컴퓨터를 모니터링하지 않는다는 메시지를 받습니다. 지금 다시 시작해야 합니다.

해결 방법

1단계: 컴퓨터 다시 시작

모든 애플리케이션을 닫고 컴퓨터를 다시 시작합니다.

2단계: Windows 서비스 확인

  1. 시작으로 이동하여 services.msc를 엽니다.

  2. Windows Defender 바이러스 백신 서비스를 선택합니다.

  3. 시작 유형자동으로 설정되어 있는지 확인합니다.

  4. 작업 메뉴로 이동하여 시작을 선택합니다.

    1. 이 작업을 사용할 수 없는 경우 중지를 선택합니다. 서비스가 중지되기를 기다린 다음 시작 작업을 선택하여 서비스를 다시 시작합니다.

이 프로세스 중에 나타날 수 있는 오류를 기록해 둡다. Microsoft 지원 문의하고 오류 정보를 제공합니다.

3단계: 타사 보안 프로그램 제거

참고

일부 보안 애플리케이션은 완전히 제거되지 않습니다. 이전 보안 애플리케이션을 완전히 제거하려면 정리 유틸리티를 다운로드하고 실행해야 할 수 있습니다.

  1. 시작으로 이동하여 appwiz.cpl엽니다.

  2. 설치된 프로그램 목록에서 타사 보안 프로그램을 제거합니다.

  3. Restart your computer.

주의

보안 프로그램을 제거하면 컴퓨터가 보호되지 않을 수 있습니다. 기존 보안 프로그램을 제거한 후 Windows Defender 설치하는 데 문제가 있는 경우 Microsoft 지원 문의하세요. 보안 제품 제품군을 선택한 다음, Windows Defender 제품을 선택합니다.

인터넷 연결 문제

컴퓨터가 Windows 업데이트 최신 업데이트를 받으려면 인터넷에 연결합니다.

  1. 시작으로 이동하여 ncpa.cpl엽니다.

  2. 연결 이름을 열어 연결 상태를 확인합니다.

  3. 컴퓨터가 연결된 경우 IPv4 연결 및/또는 IPv6 연결 상태 인터넷입니다.

  4. 컴퓨터가 연결되어 있지 않은 경우 연결 이름을 선택하고 이 연결 진단을 선택합니다.

열려 있는 프로그램을 닫고 컴퓨터를 다시 시작합니다.

검색된 위협을 수정할 수 없습니다.

Windows Defender 또는 Endpoint Protection이 잠재적 위협을 감지하면 위협을 격리하거나 제거하여 위협을 완화하려고 합니다. 이러한 위협은 압축된 보관 파일(.zip) 내부 또는 네트워크 공유에서 숨길 수 있습니다.

파일 제거 또는 검사

  • 검색된 위협이 압축된 보관 파일에 있는 경우 파일을 찾습니다. 파일을 삭제하거나 수동으로 검색합니다. 파일을 마우스 오른쪽 단추로 클릭하고 Windows Defender 사용하여 검사를 선택합니다. Windows Defender 파일에서 추가 위협을 감지하면 이를 알 수 있습니다. 그런 다음 적절한 작업을 선택할 수 있습니다.

  • 검색된 위협이 네트워크 공유에 있는 경우 공유를 열고 수동으로 검색합니다. 파일을 마우스 오른쪽 단추로 클릭하고 Windows Defender 사용하여 검사를 선택합니다. Windows Defender 네트워크 공유에서 추가 위협을 감지하면 사용자에게 알 수 있습니다. 그런 다음 적절한 작업을 선택할 수 있습니다.

  • 파일의 원본을 잘 모르는 경우 컴퓨터에서 전체 검사를 실행합니다. 전체 검사를 완료하는 데 다소 시간이 걸릴 수 있습니다.

참고 항목

Endpoint Protection 클라이언트의 질문과 대답

Endpoint Protection 클라이언트 도움말