Microsoft 365에 연결하려고 할 때 Outlook에서 암호를 계속 묻습니다.

증상

Outlook 프로필을 만들거나 Microsoft 365 사서함에 연결하려고 하면 클라이언트가 "연결 중..." 메시지를 나타내는 동안 계속해서 자격 증명에 대한 프롬프트가 나타납니다. 자격 증명 프롬프트를 취소하면 다음과 같은 오류 메시지가 나타납니다.

Microsoft Exchange에 대한 연결을 사용할 수 없습니다. 이 작업을 완료하려면 Outlook이 온라인이거나 연결되어 있어야 합니다.

원인

이 문제는 Microsoft Exchange 대화 상자의 보안 탭의 로그온 네트워크 보안 설정이 익명 인증이 아닌 값으로 설정된 경우 발생할 수 있습니다.

Microsoft Exchange 대화 상자의 보안 탭에서 로그온 네트워크 보안 설정이 익명 인증으로 설정되어 있는지 확인하는 스크린샷.

해결 방법

참고

Microsoft Outlook 2016 및 Outlook 2013의 최신 빌드는 이 문제의 영향을 받지 않습니다. 해당 버전은 "증상" 섹션에서 설명한 문제를 방지하기 위해 업데이트 되었습니다. 이러한 버전에서는 로그온 네트워크 보안 설정이 비활성화되거나 Microsoft Exchange 이메일 계정 설정에서 제거됩니다.

Outlook의 최신 버전용

셀프 진단 도구 실행

Exchange Online 사서함에 연결하려고 할 때 "증상" 섹션에 설명된 오류가 발생하는 Microsoft 365 고객일 수 있습니다. 이미 최신 버전의 Outlook 2013 또는 Outlook 2016을 실행하고 있을 수도 있습니다. 두 조건이 모두 참이면 진단을 실행하여 오류를 일으킬 수 있는 문제를 확인할 수 있습니다. 진단은 자동 검사를 수행하고 감지된 문제를 해결하기 위한 가능한 솔루션을 제공합니다. 진단을 시작하려면 진단: Outlook에서 계속 내 암호를 묻습니다를 선택하세요.

Exchange 온-프레미스 사서함에 연결하는 경우 추가 문제 해결을 위해 다음 문서를 참조하세요.

또한 일반적인 원인에 대한 다음 포럼 스레드를 볼 수 있습니다.

영향을 받는 버전의 Outlook

이전 버전의 Outlook이 있는 경우로그온 네트워크 보안 설정을 익명 인증으로 변경하여 이 문제를 해결합니다. 이렇게 하려면 다음과 같이 하십시오.

  1. Outlook을 끝냅니다.

  2. 제어판을 열고 다음 중 하나를 수행합니다.

    • Windows 10, Windows 8.1, 또는 Windows 7에서 시작을 클릭하고 검색 상자에 제어판을 입력한 다음 Enter 키를 누릅니다.
    • Windows 8에서 오른쪽에서 스와이프하여 참을 열고 검색을 누르거나 클릭한 다음 검색 상자에 제어판을 입력합니다. 또는 시작 화면에서 제어판을 입력한 다음 검색 결과에서 제어판을 누르거나 클릭합니다.
  3. 제어판에서 메일을 찾아 두 번 클릭합니다.

  4. 프로필 표시를 클릭하고 Outlook 프로필을 선택한 다음 속성을 클릭합니다.

  5. 이메일 계정을 클릭합니다.

  6. 이메일 계정을 클릭한 다음 변경을 클릭합니다.

  7. 계정 변경 대화 상자에서 더 많은 설정을 클릭합니다.

  8. Microsoft Exchange 대화 상자에서 보안 탭을 선택합니다.

  9. 로그인 네트워크 보안 목록에서 익명 인증을 선택한 다음 확인을 클릭합니다.

  10. 다음을 클릭한 다음 완료를 클릭하고 계정 설정 대화 상자에서 닫기를 클릭합니다.

  11. 메일 설정 대화 상자에서 닫기를 클릭한 다음 확인을 클릭하여 메일 제어판을 닫습니다.

추가 정보

Outlook 프로필에서 익명 인증에 대한 레지스트리 설정을 찾아 보려면 다음 단계를 따르세요.

중요

"프로필" 레지스트리 경로를 사용하여 Outlook 프로필을 수정하는 것은 지원되지 않으며 Outlook 프로필이 지원되지 않는 상태가 될 수 있습니다. 주의를 기울여 이 절의 단계를 수행하십시오. 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 액세스하기 전에, 오류 발생에 대비하여 복원을 위해 레지스트리를 백업하세요.

  1. 레지스트리 편집기를 엽니다.

    • Windows 10, Windows 8.1, 또는 Windows 8에서는 Windows 로고 키 + R을 눌러 실행 대화 상자를 열고, regedit.exe를 입력한 다음 확인을 클릭합니다.
    • Windows 7에서는 시작을 클릭하고 검색 시작 상자에 regedit를 입력한 다음 Enter 키를 누릅니다. 관리자 암호나 확인을 요청하는 메시지가 나타나면 암호를 입력하거나 허용을 클릭합니다.
  2. Outlook 버전에 적합한 레지스트리 경로를 찾습니다.

    • Outlook 2013

      HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\Profiles

    • Outlook 2010 및 2007의 경우

      HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles

  3. 이 하위 키에서 Outlook 프로필의 이름을 찾아 확장합니다.

  4. 프로필 아래에서 9375CFF0413111d3B88A00104B2A6676 키를 찾아 확장합니다.

  5. 9375CFF0413111d3B88A00104B2A6676 키 아래에 프로필의 각 계정에 대한 하위 키가 표시됩니다. 첫 번째 하위 폴더(00000001)를 선택한 다음 값을 두 번 클릭하여계정 이름 이진 값의 데이터를 검사합니다. SMTP 주소가 포함된 계정 이름 값을 찾을 때까지 이 프로세스를 반복합니다. 예를 들어 계정 이름 값은 \00000003 하위 키 아래의 guidopica@contoso.com을(를) 가리킵니다.

  6. \0000000x 하위 키 아래에서 서비스 UID 이진 값을 찾습니다. GUID(예를 들어, c3 d1 9a 7b 80 1b c4 4a 96 0a e5 b6 3b f9 7c 7e)를 나타냅니다.

  7. 6단계에서 식별된 GUID 값과 일치하는 프로필의 하위 폴더를 찾습니다(예: \c3d19a7b801bc44a960ae5b63bf97c7e).

  8. 7단계에서 찾은 하위 폴더 아래에서 01023d0d 이진 값을 검사합니다. GUID(예를 들어, 5f cf d5 f1 ba 5c 6f 45 b3 57 cc 5e 0d 16 94 58)를 나타냅니다.

  9. 8단계에서 식별된 GUID 값과 일치하는 프로필의 하위 폴더를 찾습니다(예: \5fcfd5f1ba5c6f45b357cc5e0d169458).

  10. 9단계에서 발견된 하위 키 아래에서 00036619 이진 값의 값을 검사합니다. 이 값은 Outlook에서 익명 인증을 사용하고 있는지 여부를 결정합니다.

    이진: 00036619

    데이터: 01 f0 00 80 == 익명 인증

    다른 값은 익명 이외의 인증 방법을 나타냅니다.

    Microsoft Exchange 대화 상자의 보안 탭에서 00036619 바이너리 값을 확인하는 스크린샷.