Outlook이 암호를 묻는 메시지를 표시하고 최신 인증을 사용하여 Microsoft 365에 연결하지 않음

원본 KB 번호: 3126599

증상

다음 시나리오를 고려하세요.

시나리오 1:

Microsoft Outlook이 RPC를 사용하여 온-프레미스 Exchange 서버의 기본 사서함에 연결하고 Microsoft 365에 있는 다른 사서함에도 연결합니다.

시나리오 2:

Outlook이 RPC를 사용하여 연결하는 Exchange 서버에서 Microsoft 365로 사서함을 마이그레이션합니다.

이러한 시나리오에서는 자격 증명을 묻는 메시지가 표시되고 Outlook이 최신 인증을 사용하여 Microsoft 365에 연결하지 않습니다. 자격 증명을 입력하면 토큰 대신 Microsoft 365로 전송됩니다.

원인

Outlook이 인증 체계 선택을 RPC에서 지원하는 체계로 제한합니다. 그러나 인증 체계에는 최신 인증이 포함되지 않습니다.

해결 방법

중요

주의를 기울여 이 절의 단계를 수행하십시오. 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 레지스트리를 수정하기 전에 문제가 발생할 경우에 대비하여 레지스트리를 복원 가능하도록 백업하세요.

다음 레지스트리 키를 만들어 Outlook이 EWS 및 자동 검색과 같은 웹 서비스에 최신 인증 방법을 사용하도록 강제합니다. 사용자가 Outlook 최신 인증을 사용하도록 강제하는 것이 좋습니다.

  1. Outlook을 끝냅니다.

  2. Windows 버전에 따라 다음 절차 중 하나를 사용하여 레지스트리 편집기를 시작합니다.

    • Windows 10, Windows 8.1, Windows 8: Windows 키+R을 눌러 실행 대화 상자를 엽니다. regedit.exe을 입력한 다음 Enter 키를 누릅니다.
    • Windows 7: 시작을 클릭하고 검색 상자에 regedit.exe를 입력한 후 Enter 키를 누릅니다.
  3. 레지스트리 편집기에서 다음 레지스트리 하위 키를 찾아 클릭합니다.

    HKEY_CURRENT_USER\Software\Microsoft\Exchange
    
  4. 편집 메뉴에서 새로 만들기를 가리킨 다음 DWORD 값을 클릭합니다.

  5. AlwaysUseMSOAuthForAutoDiscover를 입력한 다음 Enter 키를 누릅니다.

  6. AlwaysUseMSOAuthForAutoDiscover를 마우스 오른쪽 단추로 클릭한 다음 수정을 클릭합니다.

  7. 값 데이터 상자에 1을 입력한 다음 확인을 클릭합니다.

  8. 레지스트리 편집기를 종료하십시오.

추가 정보

Office 2013을 실행하는 경우 이 레지스트리 키를 사용하기 전에 Outlook 및 MSO가 2015년 12월 12일 업데이트 또는 이후 업데이트 릴리스로 업데이트되었는지 확인합니다.

3114349 2015년 12월 8일, Office 2013용 업데이트(KB3114349)

3114333 2015년 12월 8일, Office 2013용 업데이트(KB3114333)

참고

Office 2016에서는 이 레지스트리 키를 업데이트할 필요가 없습니다.

RPC에 대한 자세한 내용은 2017년 10월 31일 Microsoft 365에서 RPC over HTTP 지원 종료를 참조하세요.