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암호화된 메시지를 보낼 때 "충돌하거나 지원되지 않는 암호화" 경고

원래 KB 번호: 9067236

증상

사용자가 Microsoft Outlook 에서 암호화된 전자 메일 메시지를 보내려고 하면 암호화 문제 대화 상자가 나타납니다. 대화 상자에는 다음과 같은 경고 메시지가 표시됩니다.

다음 받는 사람에게 인증서가 없거나 잘못되었거나 충돌하거나 지원되지 않는 기능이 있었기 때문에 Microsoft Outlook에서 이 메시지를 암호화하는 데 문제가 있었습니다.

이 대화 상자는 다음 스크린샷과 같이 암호화되지 않았거나 암호화된 전자 메일 메시지를 보내거나 보내기를 취소하는 옵션을 제공합니다.

Microsoft Outlook의 암호화 문제 대화 상자 스크린샷

원인

다음 조건이 모두 true이면 경고는 가양성이며 안전하게 무시할 수 있습니다.

  • 메시지 암호화는 S/MIME(Secure/Multipurpose Internet Mail Extensions)입니다.

  • 보낸 사람의 S/MIME 인증서는 RSA 공개 키 암호화 알고리즘을 사용합니다.

  • 받는 사람의 S/MIME 인증서는 ECC 공개 키 암호화 알고리즘을 사용합니다.

S/MIME 인증서가 RSA 또는 ECC를 사용하는지 여부를 확인하려면 인증서의 공개 키 특성을 검사합니다. 특성 값 중 하나 RSA 또는 ECC.입니다. Microsoft 인증서 관리자 도구(certmrg.msc)에서 인증서 특성을 볼 수 있습니다.

해결 방법

"가양성" 경고를 해결하려면 암호화 문제 대화 상자에서 계속을 선택하여 S/MIME 암호화 메시지를 보냅니다.

참고 항목

암호화가 필요한 경우 암호화되지 않은 보내기를 선택하지 않는 것이 좋습니다.

해결

Microsoft 365용 Outlook 버전 16.0.18227.20000 이상 버전에서는 관리자가 이 문제에 대한 "가양성" 경고를 영구적으로 표시하지 않을 수 있습니다. 이렇게 하려면 다음 방법 중 하나를 선택합니다.

참고: 이 해결은 누락되거나 잘못된 받는 사람 인증서와 같은 다른 문제에 대해 암호화 문제 대화 상자가 나타나지 않도록 방지하지 않습니다.

Important

이 절, 방법 또는 작업에는 레지스트리를 수정하는 방법에 대한 단계가 포함되어 있습니다. 그러나 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 따라서 다음 단계를 신중하게 수행해야 합니다. 보호하기 위해 레지스트리를 수정하기 전에 백업하여 문제가 발생할 경우 레지스트리를 복원할 수 있도록 합니다. 레지스트리를 백업하고 복원하는 방법에 대한 자세한 내용은 Windows에서 레지스트리를 백업 및 복원하는 방법을 참조하십시오.

방법 A: 도메인에 가입된 사용자에 대한 경고 표시 안 함

도메인 컨트롤러에서 레지스트리 편집기(Regedit)를 실행하여 그룹 정책을 업데이트합니다.

  1. HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\Outlook\Security으로 이동합니다.

  2. 이름이 SkipProblemsDialogForDhCertMismatch지정된 DWORD 항목을 추가합니다. DWORD 값을 .로 1설정합니다.

방법 B: 개별 사용자에 대한 경고 표시 안 함

사용자의 컴퓨터에서 Regedit를 실행합니다.

  1. HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Security으로 이동합니다.

  2. 이름이 SkipProblemsDialogForDhCertMismatch지정된 DWORD 항목을 추가합니다. DWORD 값을 .로 1설정합니다.

  3. Outlook을 다시 시작하십시오.