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애플리케이션은 로컬 관리자 계정에 속하는 웹 캐시 콘텐츠에 액세스하려고 합니다.

경고

사용과 지원이 중단된 Internet Explorer 11 데스크톱 애플리케이션이 Microsoft Edge 업데이트를 통해 특정 버전의 Windows 10에서 영구적으로 비활성화될 예정입니다. 자세한 내용은 Internet Explorer 11 데스크톱 앱 사용 중지 FAQ를 참조하세요.

이 문서에서는 브라우저 모듈을 사용하는 브라우저 또는 애플리케이션이 현재 사용자 프로필에 속한 파일 외에도 컴퓨터의 관리자 프로필에 속한 파일에 액세스하려고 하는 문제를 해결하는 방법을 설명합니다.

원래 제품 버전: Internet Explorer, Windows 10; Microsoft Edge, Windows 10

증상

Internet Explorer, Microsoft Edge 또는 두 브라우저의 모듈을 사용하는 애플리케이션의 엔터프라이즈 사용자는 다음과 같은 증상을 보고합니다.

  • 사용자가 Windows 데스크톱에 로그인할 때 긴 지연이 발생합니다.
  • 애플리케이션은 브라우저 캐시에 콘텐츠를 저장할 수 없습니다.
  • 애플리케이션은 브라우저 캐시의 콘텐츠에 액세스할 수 없습니다.

이 시나리오에서 영향을 받는 사용자는 문제가 발생하는 동안 프로세스 모니터 로그를 기록합니다. 로그를 분석할 때 브라우저 또는 애플리케이션이 사용자의 프로필 폴더에 있는 파일 및 폴더 외에도 C:\Users\Administrator 폴더에 있는 파일 및 폴더에 액세스하려고 합니다.

관리자 폴더에 액세스하려는 시도를 보여 주는 프로세스 모니터 로그입니다.

원인

사용자가 Windows에 처음 로그인할 때 시스템은 기본 사용자 프로필의 정보를 사용하여 새 사용자 프로필을 구성합니다. 또한 Windows는 브라우저 및 기타 애플리케이션을 사용할 수 있도록 사용자 프로필의 일부로 캐시 컨테이너를 만듭니다.

이 액세스 문제는 새 사용자 프로필에 대한 사용자 지정 설정을 만들기 위해 기본 사용자 프로필이 변경된 경우에 발생할 수 있습니다. 이는 특히 수정 프로세스에 관리자 프로필의 프로필 정보 복사가 포함된 경우에 해당합니다. 특히 일부 이미징 또는 배포 도구는 관리자 프로필 콘텐츠의 일부 또는 전부를 기본 사용자 프로필에 복사합니다.

관리자 프로필에는 자체 캐시 컨테이너가 있습니다. 관리자 프로필의 이 부분이 기본 사용자 프로필에 복사되면 새 사용자는 새 캐시 컨테이너 대신 관리자 캐시 컨테이너의 복사본을 받습니다. 관리자 계정은 캐시 컨테이너를 소유합니다. 사용자 계정은 그렇지 않습니다. 따라서 사용자에게 캐시 컨테이너에 대한 모든 액세스 권한이 없습니다.

해결

영향을 받는 컴퓨터에서 영향을 받는 사용자 프로필 및 기본 사용자 프로필을 별도로 수정해야 합니다.

주의

수정하기 전에 프로필 폴더 위치 또는 레지스트리 항목을 백업하는 것이 좋습니다.

참고

기본적으로 이러한 프로필 파일 및 폴더는 보기에서 숨겨집니다. 표시하려면 C:\Users\Default 폴더의 폴더 보기 옵션과 C:\Users\<user name 폴더(>< 이렇게 하려면 다음 단계를 수행하세요.

  1. Windows 파일 탐색기 열고 적절한 프로필 폴더 위치를 찾습니다.
  2. 보기>> 선택합니다.
  3. 고급 설정 목록에서 숨겨진 파일, 폴더 및 드라이브 표시를 선택합니다.
  4. 동일한 목록에서 보호된 운영 체제 파일 숨기기(권장) 확인란의 선택을 취소한 다음, 예를 선택합니다. 보호된 파일을 숨기는 옵션을 선택 취소하면 경고가 나타납니다.
  5. 확인>을 선택합니다.

1단계: 기본 사용자 프로필 복구

새 사용자 프로필이 기본 사용자 프로필에서 캐시 컨테이너의 복사본을 받지 못하도록 하려면 다음 파일 및 폴더(있는 경우)를 삭제합니다.

  • C:\Users\Default\AppData\Local\Microsoft\Windows\WebCacheLock.dat
  • C:\Users\Default\AppData\Local\Microsoft\Windows\WebCache
  • C:\Users\Default\AppData\Local\Microsoft\Windows\INetCache
  • C:\Users\Default\AppData\Local\Microsoft\Windows\INetCookies

기본 사용자 프로필을 복구하기 위해 삭제할 파일 및 폴더입니다.

2단계: 영향을 받는 각 사용자 프로필 복구

사용자가 Windows에 로그인하는 동안에는 사용자 프로필의 일부인 여러 파일 및 폴더를 삭제할 수 없습니다. 이 제한으로 인해 사용자는 Windows에서 로그아웃한 다음 관리자가 로그인하여 프로필을 수정할 수 있습니다. 프로필을 수정하려면 다음 파일 및 폴더(있는 경우)를 삭제합니다.

  • C:\Users\<user name>\AppData\Local\Microsoft\Windows\WebCacheLock.dat

  • C:\Users\<user name>\AppData\Local\Microsoft\Windows\WebCache

  • C:\Users\<user name>\AppData\Local\Microsoft\Windows\INetCache

  • C:\Users\<user name>\AppData\Local\Microsoft\Windows\INetCookies

    참고

    이러한 파일 경로 < 에서 사용자 이름은> 영향을 받는 사용자 프로필의 이름입니다.

이러한 항목을 삭제한 후 다음 단계를 수행합니다.

  • 폴더 보기 옵션을 이전 값으로 복원합니다.
  • 컴퓨터를 다시 시작한 다음 영향을 받는 사용자가 로그인하도록 합니다(또는 새 사용자 계정을 사용하여 로그인할 수 있습니다).

자세한 정보

이 문서에 나열된 파일 및 폴더는 Internet Explorer 및 Microsoft Edge 브라우저 캐시의 일부를 구성합니다. 이러한 콘텐츠 위치는 각 사용자에 대해 개별적으로 생성되도록 설계되었습니다. 따라서 사용자 지정, 변경 또는 재배치를 시도하지 않는 것이 좋습니다. 우리는이 작업을 지원하지 않습니다.