이 문서에서는 Microsoft Dynamics 365 사서함 경고에서 발생하는 오류에 대한 솔루션을 제공합니다.
적용 대상: Microsoft Dynamics 365 Customer Engagement Online
원래 KB 번호: 4533252
증상
다음 예제와 같은 경고는 Dynamics 365 사서함 레코드에 기록됩니다.
"전자 메일 서버에 대한 보안 연결을 설정하는 동안 오류가 발생하여 사서함 [사서함 이름]에 대한 전자 메일을 받을 수 없습니다. 사서함이 동기화되지 않았습니다. 이에 대한 알림은 전자 메일 서버 프로필 [이메일 서버 프로필 이름]의 소유자에 대한 경고 벽에 게시됩니다."
이메일 서버 오류 코드: 웹 서버에서 SecureChannelFailure 예외를 반환했습니다."
세부 정보를 선택하면 다음과 같은 추가 정보가 표시됩니다.
활동 ID: [GUID]
>오류: System.Net.WebException: 요청이 중단되었습니다. SSL/TLS 보안 채널을 만들 수 없습니다.
System.Web.Services.Protocols.WebClientAsyncResult.WaitForResponse()에서
at System.Web.Services.Protocols.WebClientProtocol.EndSend(IAsyncResult asyncResult, Object&internalAsyncState, Stream&responseStream)
System.Web.Services.Protocols.SoapHttpClientProtocol의 EndInvoke(IAsyncResult asyncResult)에서
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindFolder(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.FindSearchFolderStep.EndCall()
Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()에서
원인
일반적으로 SSL 또는 TLS 구성 문제를 나타냅니다. 한 가지 잠재적인 원인은 Dynamics 365 Online을 F5(BIG-IP) 시스템 뒤에 있는 Exchange 온-프레미스 환경에 연결할 때 발생할 수 있는 알려진 문제입니다.
해결
구성이 F5(BIG-IP) 시스템을 통과하는 경우 K40424522 참조하세요 . 클라이언트 애플리케이션에서 Microsoft Schannel TLS 라이브러리를 사용하는 경우 BIG-IP 시스템이 SSL/TLS 핸드셰이크를 올바르게 처리하지 못할 수 있습니다.