다음을 통해 공유


사용자 지정 크리스탈 보고서 보고서를 실행할 때 "크리스탈 인쇄 엔진 오류 709 테이블을 찾을 수 없습니다." 오류

이 문서에서는 Microsoft Dynamics SL 2011에서 사용자 지정 크리스탈 리포트를 실행할 때 '테이블을 찾을 수 없음' 오류가 발생할 수 있는 문제에 대한 해결 방법을 제공합니다.

적용 대상: Microsoft Dynamics SL 2011
원래 KB 번호: 939712

증상

다음 시나리오를 살펴 보십시오.

  • Microsoft Dynamics SL 2011을 실행하고 있습니다.
  • 사용자 지정 크리스탈 리포트를 사용합니다.
  • Windows 인증을 사용하여 로그온합니다.

이 시나리오에서는 다음과 같은 오류 메시지가 나타납니다.

솔로몬 IV에 대한 크리스탈 보고서 도우미 애플리케이션
SQL 쿼리 실패 보고서 가져오기: C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET. RPT
크리스탈 인쇄 엔진 오류: 709 - 파일 C:\Program Files\Microsoft Dynamics SL\Usr_Rpts\03730DET의 오류입니다. RPT:

테이블을 찾을 수 없습니다.

원인 1

이 오류는 다음 조건이 true이므로 발생합니다.

  • 크리스탈 보고서 보고서는 하나 이상의 사용자 지정 테이블 또는 사용자 지정 보기를 사용합니다.
  • E7F575915A2E4897A517779C0DD7CE Microsoft SQL Server 사용자 또는 MSDSL SQL Server 애플리케이션 역할에는 사용자 지정 테이블 또는 사용자 지정 보기에 필요한 권한이 없습니다. 결의안 섹션의 결의안 1을 참조하세요.

원인 2

SQL Server 인증 대신 Windows 인증을 사용하도록 ODBC(Open Database Connectivity) 연결이 잘못 설정되었습니다. 새 워크스테이션에서 Crystal Reports 보고서를 처음 실행하면 Microsoft Dynamics SL 시스템 데이터베이스 및 Microsoft Dynamics SL 애플리케이션 데이터베이스에 대한 ODBC 연결이 만들어집니다. Windows 인증을 사용하여 Microsoft Dynamics SL에 로그인하는 경우에도 SQL Server 인증을 사용하도록 이 연결을 설정해야 합니다. 결의안 섹션에서 결의안 2를 참조하세요.

결의안 1

사용자 지정 테이블 또는 사용자 지정 보기에 적절한 권한을 할당합니다. 이렇게 하려면 다음 단계를 수행하세요.

  1. Microsoft SQL Server Management Studio를 시작합니다.
  2. 데이터베이스를 확장하고 Microsoft Dynamics SL 데이터베이스를 확장한 다음 테이블 또는 를 확장합니다.
  3. 목록에서 사용자 지정 테이블 또는 사용자 지정 보기를 찾습니다.
  4. 사용자 지정 테이블 또는 사용자 지정 보기를 마우스 오른쪽 단추로 클릭합니다. 그런 다음, 속성을 선택합니다.
  5. 페이지 선택 창에서 사용 권한을 선택합니다.
  6. ADD를 선택하고 MSDSL을 입력한 다음 확인을 선택합니다.
  7. 선택 권한에 대해 권한 부여 확인란을 선택합니다.
  8. ADD를 선택합니다.
  9. 찾아보기를 선택합니다. 그런 다음, E7F575915A2E4897A517779C0DD7CE 사용자 옆에 있는 확인란을 선택합니다.
  10. 확인을 두 번 선택합니다.
  11. 제어 권한대해 권한 부여 확인란을 선택합니다.

결의안 2

이 문제를 해결하려면 ODBC 연결을 삭제하고 Microsoft Dynamics SL에서 연결을 다시 만들도록 합니다. 이렇게 하려면 다음 단계를 수행하세요.

  1. 시작을 선택하고 설정을 선택한 다음 제어판 선택합니다.
  2. 관리 도구를 선택합니다.
  3. 데이터 원본(ODBC)을 선택합니다.
  4. 사용자 DSN 탭에서 Microsoft Dynamics SL 시스템 데이터베이스 및 Microsoft Dynamics SL 애플리케이션 데이터베이스에 대한 항목을 제거합니다.
  5. 시스템 DSN 탭에서 Microsoft Dynamics SL 시스템 데이터베이스 및 Microsoft Dynamics SL 애플리케이션 데이터베이스에 대한 항목을 제거합니다.
  6. Microsoft Dynamics SL에 다시 로그인한 다음 보고서를 다시 사용하십시오. 사용자 DSN 항목을 자동으로 다시 만들어야 합니다.