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"PublicIPCountLimitReached" 오류 코드 문제 해결

이 문서에서는 AKS(Azure Kubernetes Service) 클러스터를 업그레이드하려고 할 때 발생하는 "PublicIPCountLimitReached" 오류를 식별하고 resolve 방법에 대해 설명합니다.

필수 구성 요소

이 문서에는 Azure CLI 버전 2.0.65 이상이 필요합니다. 버전 번호를 찾으려면 를 실행합니다 az --version. Azure CLI를 설치하거나 업그레이드해야 하는 경우 Azure CLI를 설치하는 방법을 참조하세요.

업그레이드 프로세스에 대한 자세한 내용은 AKS(Azure Kubernetes Service) 클러스터 업그레이드의 "AKS 클러스터 업그레이드" 섹션을 참조하세요.

증상

AKS 클러스터 업그레이드가 실패하고 "PublicIPCountLimitReached" 오류 메시지가 표시됩니다.

원인

구독에 허용되는 최대 공용 IP 주소 수에 도달하면 오류가 발생합니다.

해결 방법

구독에 대한 한도 또는 할당량을 높이려면 Azure Portal 이동하여 서비스 및 구독 제한(할당량) 지원 티켓을 제출하고 할당량 유형을 네트워킹으로 설정합니다.

할당량 변경이 적용된 후 이전에 업그레이드하려고 했던 것과 동일한 버전으로 클러스터를 업그레이드해 봅니다. 이 프로세스는 조정을 트리거합니다.

az aks upgrade --resource-group <ResourceGroupName> --name <AKSClusterName> --kubernetes-version <KUBERNETES_VERSION>

도움을 요청하십시오.

질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.