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Microsoft Entra ID 디렉터리 동기화가 중지되거나 동기화가 하루 이상 등록되지 않았다는 경고가 표시됩니다.

이 문서에서는 Azure Active Directory 동기화 도구의 성능 문제에 대해 설명합니다. 도구는 동기화를 중지하거나 동기화가 24시간 이상 실행되지 않았음을 보고합니다.

원래 제품 버전: Microsoft Entra ID, Microsoft Intune, Azure Backup, Office 365 ID 관리
원래 KB 번호: 2882421

참고

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증상

다음 증상 중 하나가 발생합니다.

  • Microsoft Azure Active Directory 동기화 도구 동기화를 중지합니다.
  • Microsoft Entra ID 지난 24시간 동안 동기화 시도를 등록하지 않았다는 전자 메일 메시지를 받습니다.
  • MIISClient.exe 도구에서 "Stopped-Server-Down" 메시지 또는 "Stopped-Extension-DLL-Exception" 메시지가 표시됩니다.
  • 하나 이상의 디렉터리 동기화 서비스를 시작할 수 없습니다.

참고

기본적으로 디렉터리 동기화는 3시간마다 실행됩니다.

원인

다음 조건 중 하나 이상이 true인 경우 이 문제가 발생할 수 있습니다.

  • 구성 마법사에서 디렉터리 동기화를 설정하는 데 사용된 회사 또는 학교 계정에는 다음 문제 중 하나가 있습니다.

    • 계정이 삭제되었습니다.
    • 계정이 비활성화되었습니다.
    • 계정 암호가 만료되었습니다.
  • 하나 이상의 디렉터리 동기화 서비스에 대한 로그온 계정에는 다음 문제 중 하나가 있습니다.

    • 계정이 삭제되었습니다.
    • 계정이 비활성화되었습니다.
    • 계정 암호가 만료되었습니다.

    참고

    디렉터리 동기화 서비스의 로그온 계정은 자동으로 구성되며 수정해서는 안 됩니다.

  • 디렉터리 동기화에 사용되는 관리자 계정이 변경되었습니다.

  • 네트워크 연결 문제가 있습니다.

  • 디렉터리 동기화 서비스가 중지됩니다.

해결 방법

방법 1: 서비스가 시작되었고 관리자 계정이 로그인할 수 있는지 수동으로 확인

  1. 시작을 선택하고 실행을 선택하고 Services.msc를 입력한 다음 확인을 선택합니다.

  2. Microsoft Entra 동기화 어플라이언스 서비스를 찾은 다음 서비스 시작 여부를 검사. 서비스가 시작되지 않은 경우 마우스 오른쪽 단추로 클릭한 다음 시작을 선택합니다.

    • Azure Active Directory 동기화 도구를 사용하는 경우 Azure Active Directory 동기화 서비스를 찾습니다.
    • Microsoft Entra Connect를 사용하는 경우 Microsoft Azure AD 동기화를 찾습니다.
  3. 디렉터리 동기화에 사용되는 관리자 계정이 여전히 있는지 확인합니다. 그리고 계정이 로그인할 수 있는지 확인합니다. 계정이 계속 있는 경우 암호를 재설정한 다음 로그인할 수 있는지 확인합니다. 메시지가 표시되면 암호를 변경합니다.

    디렉터리 동기화를 구성하는 데 사용되는 전역 관리자 계정을 모르는 경우 디렉터리 동기화 어플라이언스 설치한 서버에서 다음 단계를 수행합니다.

    1. 로 이동한 %ProgramFiles%\Microsoft Azure AD Sync\UIShell\다음 Miisclient.exe 실행합니다.

      참고

      Microsoft Entra Connect 또는 Azure Active Directory Sync Service를 사용하는 경우 시작을 선택한 다음 동기화 서비스를 검색하여 엽니다.

    2. 커넥터를 선택한 다음 Microsoft Entra 커넥터를 두 번 클릭합니다.

    3. 연결을 선택합니다.

    4. UserName 값을 기록해 둡니다. 디렉터리 동기화를 구성하는 데 사용되는 전역 관리자 계정입니다.

  4. 디렉터리 동기화 서버에서 Microsoft Entra 동기화 어플라이언스 구성 마법사를 실행합니다. 디렉터리 동기화에 사용되는 관리자 계정의 새 암호를 입력한 다음 마법사의 나머지 단계를 수행합니다.

  5. 메시지가 표시되면 디렉터리 동기화 검사 강제 적용 상자를 선택합니다.

방법 2: 디렉터리 동기화 서비스에 대한 로그온 계정 문제 해결

  1. 시작을 선택하고 실행을 선택하고 Services.msc를 입력한 다음 확인을 선택합니다.

  2. Microsoft Entra 동기화 어플라이언스 서비스를 찾습니다.

    • Azure Active Directory 동기화 도구를 사용하는 경우 Azure Active Directory 동기화 서비스를 찾습니다.
    • Microsoft Entra Connect를 사용하는 경우 Microsoft Azure AD 동기화를 찾습니다. 서비스를 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다. 로그온 탭에서 나열된 계정 이름을 확인합니다.

    참고

    로컬 시스템 계정으로 로그온하도록 디렉터리 동기화 서비스를 다시 구성하는 것은 지원되지 않으며 문제가 발생할 수 있습니다.

  3. 관리 도구가 설치된 도메인 컨트롤러 또는 컴퓨터에서 Active Directory 사용자 및 컴퓨터(Dsa.msc)을 열고 도메인 이름을 마우스 오른쪽 단추로 클릭한 다음 찾기를 선택합니다. 2단계에서 기록한 계정의 이름을 입력한 다음, 지금 찾기를 선택합니다.

    • 계정을 찾으면 4단계로 이동합니다.
    • 계정을 찾을 수 없는 경우 계정이 삭제되었을 수 있습니다. 이 계정을 복원하는 방법에 대한 자세한 내용은 Active Directory 휴지통 단계별 가이드를 참조하세요. 계정을 복원할 수 없는 경우 디렉터리 동기화 클라이언트를 제거한 다음 다시 설치해야 합니다.
  4. 계정을 마우스 오른쪽 단추로 클릭한 다음 속성을 선택합니다. 계정 탭의 계정 옵션에서 다음 단계를 수행합니다.

    1. 암호가 만료되지 검사 확인란이 선택되어 있는지 확인합니다.
    2. 계정이 비활성화되었는지 검사 확인란이 선택 취소되어 있는지 확인합니다. 그런 다음, 다음 작업 중 하나를 수행합니다.
    • 계정이 비활성화된 경우 검사 상자를 선택 취소하여 계정을 사용하도록 설정합니다. 그런 다음, Microsoft Entra 동기화 어플라이언스 서비스를 다시 시작합니다. 이렇게 하려면 시작을선택하고 실행을 선택하고 Services.msc를 입력한 다음 확인을 선택합니다. 서비스를 찾아 마우스 오른쪽 단추로 클릭한 다음 다시 시작을 선택합니다.
      • Azure Active Directory 동기화 도구를 사용하는 경우 Azure Active Directory 동기화 서비스를 찾습니다.
      • Microsoft Entra Connect를 사용하는 경우 Microsoft Azure AD 동기화를 찾습니다.
    • 계정이 비활성화된 검사 상자가 이미 지워진 경우 5단계로 이동합니다.
  5. 계정이 비활성화된 검사 상자가 이미 지워진 경우 계정의 암호가 수동으로 변경되었을 수 있습니다. 새 암호를 설정하려면 Active Directory 사용자 및 컴퓨터 열고 계정을 찾아 마우스 오른쪽 단추로 클릭한 다음 암호 재설정을 선택하여 암호를 다시 설정합니다. 다음 단계에서 사용해야 하므로 설정한 암호를 확인합니다.

  6. 디렉터리 동기화 서비스에 대한 로그온 계정의 암호를 설정합니다.

    1. 시작을 선택하고 실행을 선택하고 Services.msc를 입력한 다음 확인을 선택합니다.

    2. 사용 중인 클라이언트에 따라 다음 서비스에 대한 암호를 설정합니다. 이렇게 하려면 적절한 서비스를 마우스 오른쪽 단추로 클릭하고 속성을 선택하고 로그온 탭을 선택한 다음 암호를 입력합니다.

      Microsoft Entra 동기화 클라이언트 Microsoft Entra 연결

      Forefront Identity Manager 동기화 서비스
      SQL Server(MOSONLINE)(있는 경우)
      Azure Active Directory 동기화 서비스

      Azure AD Sync
    3. 새 암호를 설정한 서비스 또는 서비스를 시작합니다.

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