다음을 통해 공유


InsufficientSubnetSize 오류 코드

이 문서에서는 고급 네트워킹을 사용하는 AKS(Microsoft Azure Kubernetes Service) 클러스터를 배포하려고 할 때 발생하는 오류를 해결하는 InsufficientSubnetSize 방법을 설명합니다. 이 문서는 Kubernetes 클러스터와 Azure CNI(Container Networking Interface) 클러스터 모두에 적용됩니다.

증상

이 오류는 InsufficientSubnetSize 다음 작업 중에 발생합니다. 이 오류는 서브넷 크기 부족과 같은 문제를 사전에 검색하는 AKS 진단에서도 발생합니다.

작업 1: AKS 클러스터 또는 AKS 노드 풀 크기 조정

클러스터 유형 증상:
서브넷 의 무료 IP 주소 수는...보다 작습니다.
Kubenet 요청된 새 노드의 수입니다.
Azure CNI 매개 입니다.
Azure CNI 오버레이 요청된 새 노드의 수입니다.
(자동 크기 조정기를 사용하는 노드 풀에서 노드 수는 매개 변수의 값 --max-count 입니다.)

작업 2: AKS 클러스터 또는 AKS 노드 풀 업그레이드

클러스터 유형 증상:
서브넷 의 무료 IP 주소 수는...보다 작습니다.
Kubenet 업그레이드해야 하는 버퍼 노드 수입니다.
Azure CNI 매개 변수의 노드 풀 값에 비해 업그레이드해야 하는 버퍼 노드의 --max-pod 수입니다.
Azure CNI 오버레이 업그레이드해야 하는 버퍼 노드 수입니다.
(자동 크기 조정기를 사용하는 노드 풀에서 노드 수는 매개 변수의 값 --max-count 입니다.)

기본적으로 AKS 클러스터는 최대 서지(업그레이드 버퍼) 값을 1로 설정합니다. 그러나 노드 풀의 최대 서지 값을 설정하여 이 업그레이드 동작을 사용자 지정할 수 있습니다. 이 작업을 수행하면 업그레이드를 완료하는 데 필요한 사용 가능한 IP 주소 수가 증가합니다.

작업 3: AKS 클러스터 만들기 또는 AKS 노드 풀 추가

클러스터 유형 증상:
서브넷 의 무료 IP 주소 수는...보다 작습니다.
Kubenet 요청된 노드 수입니다.
Azure CNI 매개 변수의 노드 풀 값에서 요청 된 노드 수 --max-pod 입니다.
Azure CNI 오버레이 요청된 노드 수입니다.
(자동 크기 조정기를 사용하는 노드 풀에서 노드 수는 매개 변수의 값 --max-count 입니다.)

원인

클러스터에 사용 중인 서브넷에는 성공적인 리소스 할당을 위해 클래스리스 CIDR(도메인 간 라우팅) 주소 공간 내에서 더 이상 사용 가능한 IP 주소가 없습니다.

클러스터 유형 요건
Kubenet 클러스터의 각 노드 에 대한 충분한 IP 공간
Azure CNI 클러스터의 각 노드 및 Pod 에 대한 충분한 IP 공간
Azure CNI 오버레이 클러스터의 각 노드 에 대한 충분한 IP 공간

Pod에 IP 주소를 할당하는 Azure CNI의 디자인에 대해 자세히 알아봅니다.

솔루션

기존 노드 풀에서 서브넷의 CIDR 주소 공간을 업데이트하려는 시도는 현재 지원되지 않습니다. 워크로드를 더 큰 서브넷의 새 노드 풀로 마이그레이션하려면 다음 단계를 수행합니다.

  1. 기존 서브넷보다 더 큰 CIDR 주소 범위를 포함하는 클러스터 가상 네트워크에 서브넷을 만듭니다. 클러스터에 맞게 서브넷 크기를 적절하게 조정하는 방법에 대한 자세한 내용은 클러스터에 대한 IP 주소 지정 계획을 참조하세요.

  2. az aks nodepool add 명령을 매개 변수와 함께 실행하여 새 서브넷에 노드 풀을 --vnet-subnet-id 만듭니다.

  3. 이전 노드 풀의 노드를 드레이닝하여 워크로드를 새 노드 풀로 마이그레이션합니다. AKS 작업자 노드를 안전하게 드레이닝하는 방법에 대한 자세한 내용은 노드 드레이닝 안전을 참조하세요.

  4. az aks nodepool delete 명령을 실행 하여 원래 노드 풀을 삭제 합니다.

타사 연락처 고지

이 문서에 포함된 타사의 연락처 정보는 이 항목에 대한 추가 정보를 찾는 데 도움을 주기 위한 것입니다. 이 연락처 정보는 공지 없이 변경될 수 있습니다. Microsoft는 타사 연락처 정보의 정확성을 보증하지 않습니다.

도움을 요청하십시오.

질문이 있는 경우 Azure 커뮤니티 지원을 요청할 수 있습니다. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.