클러스터 노드 이미지 업그레이드 중 Windows Server nodepools가 Gen2로 업그레이드되지 않음
이 문서에서는 AKS(Microsoft Azure Kubernetes Service)에서 클러스터 노드 이미지가 업그레이드될 때 Windows Server nodepools가 Gen1에서 Gen2 VM(가상 머신)으로 자동으로 업그레이드되지 않는 시나리오를 해결하는 방법을 설명합니다.
참고
이 시나리오는 Linux 노드 풀의 Gen2 VM에는 적용되지 않습니다.
필수 구성 요소
증상
Azure CLI에서 다음 방법 중 하나를 사용하여 노드 이미지를 업그레이드 할 때 기존 Windows Server nodepools는 Gen1에서 Gen2로 업그레이드되지 않습니다.
전체 클러스터 업그레이드( az aks upgrade 명령을 사용하여)
특정 nodepool 업그레이드( az aks nodepool upgrade 명령을 사용하여)
원인
원인 1: 기존 노드 풀이 Gen2 VM으로 자동으로 업그레이드되지 않음
기본적으로 노드 이미지 업그레이드는 기존 노드 풀 업데이트 또는 업그레이드를 지원하지 않습니다.
az aks upgrade
및 az aks nodepool upgrade
명령은 노드 이미지만 업그레이드합니다(이후 노드 이미지 버전으로). 이러한 명령은 해당 VM 생성을 업그레이드하지 않습니다.
원인 2: Kubernetes 버전 1.25 이상으로 클러스터 업그레이드는 OS만 업그레이드합니다.
클러스터를 Kubernetes 버전 1.25 이상으로 업그레이드하면 OS(운영 체제)만 업그레이드됩니다(Windows Server 2022로). 기존 노드 풀은 영향을 받지 않습니다. 연결된 VM 확장 집합에는 Gen1 VM이 동일한 VM이 포함됩니다.
원인 3: 유효한 VM 크기를 지정하지 않고 Windows Server 2022를 사용하여 클러스터 업그레이드 및 새 nodepool 생성
클러스터를 Kubernetes 버전 1.25 이상으로 업그레이드한 후 노드 풀의 VM에서 사용할 OS로 Windows Server 2022를 지정합니다. 그러나 VM은 다음 이유 중 하나로 인해 Gen2 노드 이미지 참조를 사용하지 않습니다.
VM 크기를 지정하지 않으며 지역의 기본 VM 크기는 Gen2 VM을 지원하지 않습니다.
Gen1 전용 VM 크기를 지정합니다.
기본 OS를 Windows Server 2019(Windows2019
)에서 Windows Server 2022()로Windows2022
업그레이드하는 경우 기존 노드 풀은 다른 VM 생성으로 자동으로 업그레이드되지 않습니다.
해결 방법
클러스터를 업그레이드한 다음, 다음 지침에 따라 해당 클러스터에서 Gen2 VM 크기를 지원하는 새 Windows Server nodepool을 만듭니다.
Kubernetes 클러스터 업그레이드 버전 | 클러스터 만들기 지침 |
---|---|
1.25 이상 버전 |
az aks create 명령을 실행하여 클러스터를 만들면 매개 변수를 --node-vm-size Gen2 VM 크기로 설정합니다. |
1.25 이전 버전 |
az aks create 명령을 실행하여 클러스터를 만들 때 매개 변수 값을 Windows2022 로 설정하고 --os-sku 매개 변수 값을 Gen2 VM 크기로 설정합니다--node-vm-size . |
참고
Gen2 VM 크기 및 운영 체제를 Windows Server 2019 ErrorCode_Windows2019NotSupportedWithGen2VM
로 지정하면 다음 오류 메시지와 함께 오류 코드가 표시됩니다.
<가상 머신 크기> 는 Gen 2 전용 VM입니다. Windows2019는 Gen 2 VM을 지원하지 않습니다. 그러나 Gen 1 VM 크기를 선택하거나 os_sku 2022로 설정할 수 있습니다.
이 문제를 방지하려면 클러스터를 만들 때 다음 옵션 중 하나를 선택합니다.
Windows Server 2019와 함께 사용할 Gen1 VM 크기를 선택합니다.
Gen2 VM과 함께 사용하도록 운영 체제 SKU를 Windows Server 2022 로 설정합니다.
도움을 요청하십시오.
질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.