Azure에서 VM을 만들거나 크기를 조정할 때 할당 오류 문제 해결

VM(가상 머신)을 만들거나, 중지된(할당 취소된) VM을 시작하거나, VM의 크기를 조정하면 Microsoft Azure는 구독에 컴퓨팅 리소스를 할당합니다. Microsoft는 고객 수요를 지원하기 위해 항상 모든 VM 유형을 사용할 수 있도록 추가 인프라 및 기능에 지속적으로 투자하고 있습니다. 그러나 특정 지역의 Azure 서비스에 대한 수요가 전례 없는 증가로 인해 리소스 할당 오류가 발생할 수 있습니다. 이 문제는 VM이 다음 오류 코드와 메시지를 표시하는 동안 지역에서 VM을 만들거나 시작하려고 할 때 발생할 수 있습니다.

오류 코드: AllocationFailed 또는 ZonalAllocationFailed

오류 메시지: "할당이 실패했습니다. 이 지역에서 요청된 VM 크기에 대한 용량이 충분하지 않습니다. 에서 할당 성공 가능성을 높이는 방법에 대해 자세히 알아보세요.https://aka.ms/allocation-guidance"

참고

VMSS(가상 머신 확장 집합) 문제를 해결하는 경우 프로세스는 표준 VM과 동일합니다. 이 문제를 resolve 이 문서의 지침을 따라야 합니다.

오류 메시지: "할당이 실패했습니다. 단일 배치 그룹을 사용하여 Virtual Machine Scale Set에 새 VM을 추가하거나 단일 배치 그룹을 사용하여 Virtual Machine Scale Set의 기존 VM을 업데이트/크기 조정하려는 경우 이러한 할당의 범위가 단일 클러스터로 지정될 수 있으며 클러스터의 용량이 부족할 수 있습니다. 에서 할당 성공 가능성을 높이는 방법에 대해 자세히 읽어보세요.http://aka.ms/allocation-guidance."

이 문서에서는 몇 가지 일반적인 할당 실패의 원인을 설명하고 가능한 해결을 제안합니다.

이 문서에서 Azure 문제가 해결되지 않으면 Q&A 및 Stack Overflow의 Azure 포럼을 방문하세요. 이러한 포럼 또는 Twitter에 문제를 게시할 @AzureSupport 수 있습니다. 또한 Azure 지원 사이트에서 지원 받기를 선택하여 Azure 지원 요청을 제출할 수 있습니다.

기본 설정 지역에서 원하는 VM 유형을 사용할 수 있을 때까지 배포 문제가 발생하는 고객에게 다음 표의 지침을 임시 해결 방법으로 고려하는 것이 좋습니다.

사례와 가장 일치하는 시나리오를 식별한 다음, 해당 제안된 해결 방법을 사용하여 할당 요청을 다시 시도하여 할당 성공 가능성을 높입니다. 또는 나중에 언제든지 다시 시도할 수 있습니다. 요청을 수용하기 위해 클러스터, 지역 또는 영역에서 충분한 리소스가 해제되었을 수 있기 때문입니다.

VM 크기 조정 또는 기존 가용성 집합에 VM 추가

원인

기존 가용성 집합을 호스트하는 원래 클러스터에서 VM 크기를 조정하거나 기존 가용성 집합에 VM을 추가하는 요청을 시도해야 합니다. 요청된 VM 크기는 클러스터에서 지원되지만 클러스터에 현재 충분한 용량이 없을 수 있습니다.

해결 방법

VM이 다른 가용성 집합의 일부가 될 수 있는 경우 동일한 지역에 있는 다른 가용성 집합에 VM을 만듭니다. 그런 다음 이 새 VM을 동일한 가상 네트워크에 추가할 수 있습니다.

동일한 가용성 집합의 모든 VM을 중지(할당 취소)한 다음, 적용 가능한 모든 VM을 일괄 처리로 시작합니다. 중지하려면 [ 리소스 그룹 > ] 리소스 > [가용성 집합] >> Virtual Machines > [가상 머신] > 중지를 클릭합니다. 모든 VM이 중지된 후 >가상 머신으로 이동하여 가용성 집합 필터를 추가한 다음, 가용성 집합별로 그룹을 선택합니다. 적용 가능한 모든 VM을 선택하고 시작을 클릭합니다. 이 단계에서는 새 할당 시도가 실행되고 충분한 용량을 가진 새 클러스터를 선택할 수 있는지 확인합니다.

부분적으로 중지된(할당 취소된) VM 시작

원인

부분 할당 취소는 가용성 집합에서 하나 이상의 VM을 중지(할당 취소)했음을 의미합니다. VM의 할당을 취소하면 연결된 리소스가 해제됩니다. 부분적으로 할당 취소된 가용성 집합에서 VM을 시작하는 것은 기존 가용성 집합에 VM을 추가하는 것과 동일합니다. 따라서 용량이 충분하지 않을 수 있는 기존 가용성 집합을 호스트하는 원래 클러스터에서 할당 요청을 시도해야 합니다.

해결 방법

동일한 가용성 집합의 모든 VM을 중지(할당 취소)한 다음, 적용 가능한 모든 VM을 일괄 처리로 시작합니다. 중지하려면 [ 리소스 그룹 > ] 리소스 > [가용성 집합] >> Virtual Machines > [가상 머신] > 중지를 클릭합니다. 모든 VM이 중지된 후 >가상 머신으로 이동하여 가용성 집합 필터를 추가한 다음, 가용성 집합별로 그룹을 선택합니다. 적용 가능한 모든 VM을 선택하고 시작을 클릭합니다. 이렇게 하면 새 할당 시도가 실행되고 충분한 용량을 가진 새 클러스터를 선택할 수 있습니다.

완전히 중지된(할당 취소된) VM 시작

원인

전체 할당 취소는 가용성 집합의 모든 VM을 중지(할당 취소)했음을 의미합니다. 이러한 VM을 시작하는 할당 요청은 지역 또는 영역 내에서 원하는 크기를 지원하는 모든 클러스터를 대상으로 합니다. 이 문서의 제안 사항에 따라 할당 요청을 변경하고 요청을 다시 시도하여 할당 성공 가능성을 높입니다.

해결 방법

이전 VM 시리즈 또는 크기(예: Dv1, DSv1, Av1, D15v2 또는 DS15v2)를 사용하는 경우 최신 버전으로 이동하는 것이 좋습니다. 특정 VM 크기에 대한 권장 사항을 참조하세요. 다른 VM 크기를 사용할 수 있는 옵션이 없는 경우 동일한 지역 내의 다른 지역에 배포해 보세요. 각 지역의 사용 가능한 VM 크기에 대한 자세한 내용은 https://aka.ms/azure-regions

가용성 영역을 사용하는 경우 요청된 VM 크기에 사용할 수 있는 용량이 있을 수 있는 지역 내의 다른 영역을 사용해 보세요.

할당 요청이 큰 경우(코어가 500개 이상) 다음 섹션의 지침을 참조하여 요청을 더 작은 배포로 분할합니다.

이전 VM 크기(Av1, Dv1, DSv1, D15v2, DS15v2 등)에 대한 할당 실패

Azure 인프라를 확장하면서 최신 가상 머신 유형을 지원하도록 설계된 최신 세대 하드웨어를 배포합니다. 일부 이전 시리즈 VM은 최신 세대 인프라에서 실행되지 않습니다. 이러한 이유로 고객은 이러한 레거시 SKU에 대한 할당 오류가 발생할 수 있습니다. 이 문제를 방지하기 위해 레거시 시리즈 가상 머신을 사용하는 고객은 다음 권장 사항에 따라 해당 최신 VM으로 이동하는 것을 고려하는 것이 좋습니다. 이러한 VM은 최신 하드웨어에 최적화되어 있으며 더 나은 가격 책정 및 성능을 활용할 수 있습니다.

레거시 VM 시리즈/크기 권장되는 최신 VM 시리즈/크기 추가 정보
Av1 시리즈 Av2 시리즈 https://azure.microsoft.com/blog/new-av2-series-vm-sizes/
Dv1 또는 DSv1 시리즈(D1~D5) Dv3 또는 DSv3 시리즈 https://azure.microsoft.com/blog/introducing-the-new-dv3-and-ev3-vm-sizes/
Dv1 또는 DSv1 시리즈(D11~D14) Ev3 또는 ESv3 시리즈
D15v2 또는 DS15v2 더 큰 VM 크기를 활용하기 위해Resource Manager 배포 모델을 사용하는 경우 D16v3/DS16v3 또는 D32v3/DS32v3으로 이동하는 것이 좋습니다. 최신 세대 하드웨어에서 실행되도록 설계되었습니다. Resource Manager 배포 모델을 사용하여 VM instance 단일 고객 전용 하드웨어로 격리되도록 하는 경우 최신 세대 하드웨어에서 실행되도록 설계된 새로운 격리된 VM 크기, E64i_v3 또는 E64is_v3 이동하는 것이 좋습니다. https://azure.microsoft.com/blog/new-isolated-vm-sizes-now-available/

대규모 배포에 대한 할당 오류(500개 이상의 코어)

요청된 VM 크기의 인스턴스 수를 줄인 다음 배포 작업을 다시 시도합니다. 또한 대규모 배포의 경우 여러 배치 그룹이 있는 Azure 가상 머신 확장 집합 을 평가할 수 있습니다. VM 인스턴스 수는 수요 또는 정의된 일정에 따라 자동으로 증가하거나 감소할 수 있으며, 다중 배치 그룹으로 배포할 때 배포가 여러 클러스터에 분산될 수 있으므로 할당 성공 가능성이 높아질 수 있습니다. 대규모 가상 머신 확장 집합 작업 및 기존 확장 집합을 여러 배치 그룹에 걸쳐 변환하는 방법에 대해 자세히 알아봅니다. 확장 집합을 단일 배치 그룹 지원에서 여러 배치 그룹 지원으로 변경할 수 있지만 다른 방향으로 변환을 수행할 수는 없습니다.

배경 정보

할당 작동 방식

Azure 데이터 센터의 서버는 클러스터로 분할됩니다. 일반적으로 할당 요청은 여러 클러스터에서 시도되지만 할당 요청의 특정 제약 조건으로 인해 Azure 플랫폼이 하나의 클러스터에서만 요청을 시도할 수 있습니다. 이 문서에서는 이를 "클러스터에 고정됨"이라고 합니다. 아래 다이어그램 1은 여러 클러스터에서 시도되는 일반 할당의 사례를 보여 줍니다. 다이어그램 2는 기존 클라우드 서비스 CS_1 또는 가용성 집합이 호스트되기 때문에 클러스터 2에 고정된 할당의 경우를 보여 줍니다. 다이어그램 1은 여러 클러스터에서 시도된 할당을 보여 줍니다. 다이어그램 2는 한 클러스터에 고정된 할당을 보여줍니다.

할당 오류가 발생하는 이유

할당 요청이 클러스터에 고정되면 사용 가능한 리소스 풀이 더 작기 때문에 무료 리소스를 찾지 못할 가능성이 높아집니다. 또한 할당 요청이 클러스터에 고정되어 있지만 요청한 리소스 유형이 해당 클러스터에서 지원되지 않는 경우 클러스터에 무료 리소스가 있더라도 요청이 실패합니다. 다음 다이어그램 3은 유일한 후보 클러스터에 무료 리소스가 없기 때문에 고정된 할당이 실패하는 경우를 보여 줍니다. 다이어그램 4는 클러스터에 무료 리소스가 있더라도 유일한 후보 클러스터가 요청된 VM 크기를 지원하지 않기 때문에 고정된 할당이 실패하는 경우를 보여 줍니다.

다이어그램 3은 고정된 클러스터에서 할당 실패를 보여줍니다. 사용 가능한 무료 리소스가 없으며 다이어그램 4는 고정된 클러스터에서 할당 실패를 표시합니다. 크기는 지원되지 않습니다.

도움을 요청하십시오.

질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.