적용 대상: ✔️ Windows VM
이 문서에서는 Azure VM(가상 머신)을 부팅하는 동안 로컬 세션 관리자가 처리를 완료할 때까지 게스트 운영 체제(게스트 OS)가 중단되는 문제를 해결하는 단계를 제공합니다.
증상
부팅 진단을 사용하여 VM 출력의 스크린샷을 보는 경우 스크린샷에 "로컬 세션 관리자를 기다리세요" 메시지가 표시된 프롬프트가 표시됩니다.
원인
로컬 세션 관리자를 기다리는 동안 VM이 중단되는 여러 가지 이유가 있을 수 있습니다. 이 문제가 지속되면 분석을 위해 메모리 덤프를 수집해야 합니다.
솔루션
팁
VM의 최근 백업이 있는 경우 백업에서 VM을 복원하여 부팅 문제를 해결할 수 있습니다.
경우에 따라 프로세스가 완료될 때까지 기다리면 문제가 해결됩니다. VM이 응답하지 않고 대기 화면에 1시간 넘게 남아 있는 경우 메모리 덤프를 수집한 다음 Microsoft 지원에 문의해야 합니다.
OS 디스크를 새 복구 VM에 연결
- 복구 VM을 준비하려면 VM 복구 명령의 1-3단계를 수행합니다.
- 원격 데스크톱 연결을 사용하여 복구 VM에 연결합니다.
덤프 파일 찾기 및 지원 티켓 제출
- 복구 VM에서 연결된 OS 디스크의 Windows 폴더로 이동합니다. 예를 들어 연결된 OS 디스크에 할당된 드라이브 문자에 F라는 레이블이 지정된 경우 .
F:\Windows
- memory.dmp 파일을 찾은 다음 메모리 덤프 파일이 연결된 지원 티켓을 제출합니다.
- memory.dmp 파일을 찾는 데 문제가 있는 경우 가이드에 따라 NMI(마스킹할 수 없는 인터럽트) 호출을 사용하여 크래시 덤프 파일을 생성합니다.
NMI 호출에 대한 자세한 내용은 Azure 직렬 콘솔 사용자 가이드의 NMI 호출을 참조하세요.
다음 단계
도움을 요청하십시오.
질문이 있거나 도움이 필요한 경우 지원 요청을 생성하거나Azure 커뮤니티 지원에 문의하세요. Azure 피드백 커뮤니티에 제품 피드백을 제출할 수도 있습니다.