적용 대상: Visual Studio 2022
증상
최소 레이아웃을 만들고 시스템에서 테스트한 후에는 다음과 같은 오류 메시지가 표시됩니다.
로그의 코드 조각:
[3004:0006][<DateTime>] Unable to select suitable download engine.
[3004:0006][<DateTime>] Unable to get download engine: Can not download. No suitable download engine found.
[3004:0006][<DateTime>] Error 0x80131500: Unable to download the channel manifest from https://aka.ms/vs/17/release/channel. at Microsoft.VisualStudio.Setup.ChannelManager.<AddAsync>d__43.MoveNext()
[3004:0006][<DateTime>] Error 0x80131500: Failed to initialize the app in AppInitializerService.InitializeChannelsAsync: Microsoft.VisualStudio.Setup.ChannelManifestDownloadException
원인
새 프로필에서 업그레이드를 수행하거나 %localappdata%\Microsoft\VisualStudio 폴더의 콘텐츠가 누락되거나 손상된 경우 이 문제가 발생할 수 있습니다. 이 폴더는 제품 및 해당 업그레이드에 대한 세부 정보가 포함된 채널 매니페스트 파일을 호스팅합니다.
동일한 사용자 계정을 사용하여 Visual Studio를 설치하고 업데이트할 때는 이 동작이 발생하지 않아야 합니다. Visual Studio는 C:\ProgramData\Microsoft\VisualStudio\Packages 및 %localappdata%\Microsoft\VisualStudio\Packages에서 초기 설치 중에 _channels 폴더를 만듭니 다. 업데이트 프로세스 중에 Visual Studio는 이러한 위치의 카탈로그 및 채널 매니페스트 파일을 비교하여 원활한 업데이트를 보장합니다.
해결
이 문제를 해결하려면 다음 단계를 따릅니다.
- C:\ProgramData\Microsoft\VisualStudio\Packages 아래에 있는 _channels 폴더를 복사합니다.
- %localappdata%\Microsoft\VisualStudio 디렉터리 아래에 Packages라는 새 폴더를 만듭니다.
- _channels 폴더를 새로 만든 패키지 폴더에 붙여넣습니다.
- 업데이트 프로세스를 다시 실행해 보세요.