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사용자가 채팅을 종료한 후 power Virtual Agents 봇 대화가 dashboard 활성으로 표시됩니다.

이 문서에서는 사용자가 채팅을 종료한 경우에도 Power Virtual Agents 봇 대화가 옴니채널 for Customer Service dashboard 활성으로 표시되는 문제에 대한 해결을 제공합니다.

증상

대화가 종료된 후에도 Power Virtual Agents 봇 대화는 여전히 dashboard 활성으로 표시됩니다.

원인

Power Virtual Agents 봇에 대한 대화는 고객 서비스용 Omnichannel에서 종료할 수 없습니다. 따라서 닫힌 후에도 감독자 dashboard 활성으로 표시됩니다.

해결 방법

사용자가 채팅 창을 닫은 후 고객 서비스용 Omnichannel에서 봇 대화를 명시적으로 종료하는 컨텍스트 변수를 구성할 수 있습니다. Power Virtual Agents에서 변수 속성이 로 설정된 컨텍스트 변수에 대한 CloseOmnichannelConversation 독립 실행형 토픽을 global만듭니다. 봇에 대해 구성한 다른 항목에서 토픽을 호출합니다.

대화는 고객 서비스용 Omnichannel에서 닫혀 있지만 Power Virtual Agents에서 닫혀 있지 않으며 Power Virtual Agents 분석 dashboard 에스컬레이션 속도 드라이버 KPI에 표시됩니다.

중요

고객 서비스용 Omnichannel의 봇 대화를 종료할 수 있도록 흐름을 구성하기 위해 Power Automate에 액세스할 수 있는지 확인합니다.

봇 대화 종료를 구성하려면 다음 단계를 수행합니다.

  1. Power Virtual Agents에서 선택한 봇에 대해 새 항목을 구성합니다.

  2. 작성 캔버스로 이동을 선택하고 노드 추가에서 작업 호출을 선택한 다음, 흐름 만들기를 선택합니다.

  3. 새 탭에서 열리는 Power Automate 창에서 다음 단계를 수행합니다.

    1. Power Virtual Agents에 값 반환 상자에서 입력 추가를 선택한 다음 예/아니요를 선택합니다.
    2. 제목 입력 상자에 Customer Service용 Omnichannel 컨텍스트 변수 이름인 CloseOmnichannelConversation을 입력합니다.
    3. 응답할 값 입력 상자에서 탭을 선택한 다음 bool(true)을 입력하여 식을 빌드하고 확인을 선택합니다.
    4. 변경 내용을 저장한 다음 Power Automate를 종료합니다.
  4. 편집 중인 항목에서 작업 호출을 다시 선택한 다음 목록에서 만든 흐름을 선택합니다.

  5. 노드 추가에서 에이전트에 대한 대화>전송 종료를 선택합니다.

    최종 대화 토픽을 구성하는 방법을 보여 주는 스크린샷

  6. Customer Service용 Omnichannel에서 봇 대화를 종료하기 위해 토픽을 호출해야 하는 항목으로 이동하고 노드 추가에서 다른 항목으로 이동 옵션을 사용합니다.

  7. 봇 대화를 끝내기 위해 만든 항목을 선택합니다.

  8. 변경 내용을 저장하고 게시합니다.

또한 옴니채널 for Customer Service에서 대화가 종료된 후 사용자에게 표시되는 자동화된 메시지를 구성할 수 있습니다.