앱 내 마케팅 문제 해결
이 문서는 앱 내 마케팅과 관련된 문제를 해결하고 resolve 데 도움이 됩니다.
문제 1 - 마케팅 목록 양식을 열 때 멤버 보기를 사용할 수 없음
원인
마케팅 목록 양식의 각 하위 그리드에 대한 보기를 사용자 지정하여 멤버 목록이 비어 있는 것처럼 보이면서 문제가 발생했습니다.
해결 방법
고급 설정 설정>>사용자 지정>시스템 사용자 지정으로 이동합니다.
사이트 맵에서 엔터티>마케팅 목록>양식을 엽니다.
양식 목록에서 마케팅 목록 양식을 선택합니다.
마케팅 목록 양식의 마케팅 목록 사이트 맵에서 구성원을 선택합니다.
연락처를 선택한 다음 속성 변경을 선택합니다. 속성 설정 창이 열립니다.
추가 옵션 섹션의 보기 선택기 드롭다운 목록에서 선택한 보기 표시를 선택합니다.
추가 옵션 목록이 나타납니다.
내 활성 연락처 보기를 선택하고 선택기 보기 드롭다운 목록에서 끄기를 선택합니다.
이름 섹션에서 양식에서 레이블 표시 확인란의 선택을 취소합니다.
확인을 선택합니다.
계정 및 잠재 고객에 대해 5~9단계를 반복합니다.
양식을 저장하고 게시합니다.
문제 2 - 마케팅 목록 양식에서 만든 캠페인을 통합 인터페이스의 마케팅 목록 레코드와 연결할 수 없습니다.
원인
TmpRegardingObjectId 특성이 캠페인 양식에서 제거되었기 때문에 문제가 발생합니다.
해결 방법
고급 설정 설정>>사용자 지정>시스템 사용자 지정으로 이동합니다.
사이트 맵에서 엔터티>캠페인>양식을 엽니다.
양식 목록에서 캠페인 양식을 선택합니다.
페이지 오른쪽에 표시된 필드 Explorer 창에서 TmpRegardingObjectId 필드를 양식에 추가합니다.
TmpRegardingObjectId 필드를 선택한 다음 속성 변경을 선택합니다.
속성 창 설정이 열립니다.
레이블 섹션에서 양식에서 레이블 표시 확인란의 선택을 취소하고 표시 유형 섹션에서 기본적으로 표시 확인란의 선택을 취소합니다.
양식을 저장하고 게시합니다.
문제 3 - 통합 인터페이스에서 고급 찾기를 사용하여 멤버 계정에 대한 관련 계정 필드를 찾을 수 없습니다.
원인
애플리케이션에서 연락처 또는 계정 표시 이름이 변경되고 회사 이름(RELATED_TYPE) 이 변경된 표시 이름에서 관련 형식을 선택하기 때문에 문제가 발생합니다.
해결 방법
통합 인터페이스에서 회사 이름 엔터티는 회사 이름(계정)으로 사용할 수 있습니다. 예를 들어 계정 이름을 조직으로 바꾸면 엔터티의 이름이 회사 이름(조직)으로 바뀝니다.
문제: 전자 메일 빠른 캠페인 배포 목록을 사용하여 전자 메일을 보낼 수 없습니다.
원인
이 문제는 다음 이유 중 하나로 인해 발생합니다.
- 사용자에게는 다른 사용자를 대신하여 전자 메일을 보낼 수 있는 권한이 없습니다.
- 레코드 소유자(마케팅 목록 구성원)는 다른 Dynamics 365 사용자가 소유자를 대신하여 이메일을 보내는 것을 허용하지 않았습니다.
해결 방법
이 문제를 해결하려면 다음 중 하나를 수행하세요.
빠른 캠페인을 만드는 사용자의 경우 다른 사용자 권한으로 Email 보내기 권한을 사용자에게 할당된 하나 이상의 역할에 할당해야 합니다. 자세한 내용은 팀 구성원의 권한 상속을 사용하여 보안 역할 만들기를 참조하세요.
레코드 소유자의 경우 개인 옵션 설정 대화 상자에서 다른 Microsoft Dynamics 365 사용자가 사용자를 대신하여 전자 메일을 보낼수 있도록 허용 확인란을 선택해야 합니다.
문제 4 - 빠른 캠페인 마법사 내에서 전자 메일의 양식 필드를 변경할 수 없습니다.
원인
이 문제는 역할에 대한 다른 사용자로 Email 보내기 옵션에 대한 권한이 부족하여 발생합니다.
해결 방법
역할 중 하나에 다른 사용자로 Email 보내기 옵션에 대한 충분한 권한을 제공합니다.
문제 5 - 배포 대화 상자에서 전자 메일 템플릿을 볼 수 없습니다.
원인
통합 인터페이스의 전자 메일 템플릿 선택기는 다른 엔터티에 대한 특정 액세스 수준을 사용합니다.
해결 방법
이 문제를 resolve 위해 사용자는 시스템 사용자 레코드에 액세스해야 합니다. Dynamics 365 organization 보안 역할을 할당하여 시스템 사용자에게 액세스를 제공합니다. 자세한 내용은 환경의 리소스에 대한 사용자 보안 구성을 참조하세요.
문제 6 - 캠페인 배포 프로세스가 보류 중 또는 실패 상태 중단됨
원인
캠페인 배포 프로세스에서는 백그라운드에서 워크플로를 실행해야 합니다. 워크플로를 사용하지 않도록 설정하면 캠페인 배포가 완료되지 않으며 보류 중 또는 실패 상태로 중단됩니다.
해결 방법
이 문제를 resolve 워크플로 백그라운드 프로세스를 사용하도록 설정한 다음 ActivityPropagation 프로세스를 활성화합니다.
워크플로 백그라운드 프로세스 사용
고급 설정 설정>>시스템 시스템>작업으로 이동합니다.
ActivityPropagation 작업으로 이동하고 세션 처리에서 빠른 캠페인이 실행된 날짜 및 시간과 일치하거나 일치하는 작업을 선택합니다.
조직에서 백그라운드 처리 사용 안 함 모드에 있으므로 비동기 작업을 건너뛰었다는 오류 메시지가 세부 정보 섹션 아래에 표시되는지 확인합니다. 다음을 수행하여 환경에 대한 설정을 업데이트합니다.
Dynamics 365 관리 센터로 이동하여 instance 선택한 다음 관리 설정을 선택합니다.
백그라운드 작업 사용 안 함 확인란의 선택을 취소합니다.
설정을 저장하고 종료합니다.
ActivityPropagation 프로세스 활성화
고급 설정 설정>>사용자 지정>시스템 사용자 지정으로 이동합니다.
사이트 맵에서 프로세스로 이동합니다.
보기 선택기에서 모두를 선택합니다.
사용 가능한 모든 프로세스가 표시됩니다.
ActivityPropagation프로세스를 선택한 다음 활성화를 선택합니다.
문제 7 - 빠른 캠페인이 실패하고 중단됨으로 설정됨
원인
이 문제는 워크플로 프로세스의 사용자 지정 플러그 인과 관련된 스택 추적 실패로 인해 발생합니다.
해결 방법
- 고급 설정 설정>>시스템 시스템>작업으로 이동합니다.
- ActivityPropagation 작업으로 이동하고 세션 처리에서 빠른 캠페인이 실행된 날짜 및 시간과 일치하거나 일치하는 작업을 선택합니다.
시스템 작업에는 오류가 있는 스택 추적이 포함된 정보가 포함됩니다. 스택 추적 실패 설명서에 설명된 대로 오류를 해결합니다.
문제 8 - 빠른 캠페인이 멈출 수 없는 루프를 실행하고 수천 개의 실패 레코드를 생성합니다.
원인
알 수 없는 조건으로 인해 워크플로가 캠페인 활동을 만들지 못하면 멈출 수 없는 루프로 전환되고 캠페인 활동을 계속 만들며 모두 실패합니다. 대상 마케팅 목록의 멤버 수를 초과할 때까지 오류 수가 계속 증가하는 것을 확인할 수 있습니다.
해결 방법
ActivityPropagation 워크플로를 비활성화한 다음 다시 활성화합니다.
고급 설정 설정>>사용자 지정>시스템 사용자 지정으로 이동합니다.
사이트 맵에서 프로세스로 이동합니다.
보기 선택기에서 모두를 선택합니다.
사용 가능한 모든 프로세스가 표시됩니다.
ActivityPropagation 워크플로를 선택한 다음 비활성화를 선택합니다.
24시간을 기다린 다음 ActivityPropagation 워크플로를 다시 활성화합니다.
문제 9 - 캠페인 배포가 대상 엔터티에 대한 활동을 만들지 않음
대상 레코드(계정, 연락처 및 잠재 고객)는 캠페인 배포를 통해 마케팅 자료를 받기 위한 기본 설정을 식별할 수 있습니다. 여기에는 이메일, 전화, 팩스 및 대량 메일이 포함됩니다.
캠페인 활동은 해당 기본 설정이 허용 또는 보내기로 설정된 경우에만 마케팅 목록의 구성원을 위해 만들어집니다.
문제 10 - 일부 구성원에 대한 캠페인 배포 실패
원인
캠페인 배포는 마케팅 목록의 구성원을 기반으로 합니다. 구성원은 계정, 연락처 또는 잠재 고객일 수 있습니다. 다음 이유 중 하나로 인해 구성원에 대해 캠페인 배포가 실패할 수 있습니다.
- 구성원과 연결된 이메일 주소가 없습니다.
- 멤버와 연결된 전자 메일 주소가 잘못되었습니다.
- 멤버가 멤버 레코드에서 마케팅 자료 보내기 필드를 보내지 않음으로 구성했습니다.
해결 방법
제외된 멤버 그리드에서 오류에 대한 자세한 이유를 검토하고 필요한 작업을 수행합니다.
문제 11 - 통합 인터페이스의 계정, 연락처 또는 잠재 고객 양식에서 캠페인 탭을 사용할 수 없습니다.
원인
캠페인 테이블과 계정, 연락처 또는 잠재 고객 간에 직접적인 관계가 없으므로 해당 양식에서 캠페인 탭을 사용할 수 없습니다. 분산 캠페인 활동은 대상 엔터티가 캠페인에 사용되고 있음을 나타내는 진정한 표시이기 때문에 캠페인 목록을 볼 수 있는 유일한 방법은 분산 캠페인 활동을 사용하는 것입니다.
해결 방법
이 문제를 resolve 양식에 캠페인 활동 탭을 추가합니다.
참고
이 예제에서는 계정 엔터티를 사용합니다.
고급 설정 설정>>사용자 지정>시스템 사용자 지정으로 이동합니다.
구성 요소에서 엔터티>계정>양식을 선택합니다.
subgrid를 추가할 양식을 엽니다.
양식 페이지에서 삽입 탭을 선택한 다음, 하나의 열을 선택합니다.
새 열이 탭으로 추가됩니다.
탭을 선택한 다음 속성 변경을 선택합니다. 탭 속성 대화 상자가 열립니다.
이름 및 레이블 값을 캠페인 활동으로 입력한 다음 확인을 선택합니다. 그런 다음 탭의 이름이 캠페인 활동으로 바뀝니다.
캠페인 활동 탭을 선택하고 삽입 탭으로 이동한 다음 하위 그리드를 선택합니다.
하위 그리드에 대한 속성 설정 대화 상자가 열립니다.
표시 탭에서 다음 정보를 입력합니다.
- 이름 섹션에서 고유한 이름으로 Campaign_Activities 입력합니다.
- 이름 섹션의 레이블에 캠페인 활동을 입력합니다.
-
데이터 원본 섹션에서 다음을 수행합니다.
- 엔터티에 대해 캠페인 활동을 선택합니다.
- 기본 보기에서 모든 캠페인 활동을 선택합니다.
변경 내용을 저장하고 양식을 게시합니다.
문제가 해결되었는지 확인하려면 캠페인에 사용되었으며 일부 분산 캠페인 활동이 있는 계정을 엽니다. 캠페인 활동 탭을 선택하여 관련 캠페인 활동이 표시되는지 확인합니다.
문제 12 - 정적 마케팅 목록을 삭제하려고 할 때 시간이 초과되었습니다.
원인
많은 수의 멤버(50,000명 이상)가 있는 정적 마케팅 목록을 삭제하는 데는 많은 시간이 걸리고 그 결과는 시간 초과가 발생합니다.
해결 방법
먼저 고급 찾기를 사용하여 제거를 사용하여 마케팅 목록에서 모든 멤버를 제거한 다음 마케팅 목록을 삭제하는 것이 좋습니다. 애플리케이션의 성능을 향상시키고 시간 초과를 방지하려면 마케팅 목록의 구성원을 한 번에 10,000명의 그룹으로 제거합니다. 예를 들어 마케팅 목록에 20,000명의 멤버가 있고 멤버를 제거하려는 경우입니다. 먼저 10,000명의 멤버를 제거한 다음 다른 10,000명을 제거합니다.