다음을 통해 공유


Dynamics 365 App for Outlook에 액세스할 때 "로그인하는 동안 문제가 발생했습니다." 오류

적용 대상: Dynamics 365 App for Outlook
원래 KB 번호: 3064194, 4035750

이 문서에서는 Outlook용 Microsoft Dynamics 365 앱에 액세스할 때 발생할 수 있는 다음 로그인 오류에 대한 솔루션을 제공합니다.

오류 1

데스크톱, 웹 또는 모바일에서 Outlook을 사용하는 동안 Outlook용 Dynamics 365 앱을 열려고 하면 다음과 같은 오류 메시지가 표시될 수 있습니다.

로그인하는 동안 문제가 발생했습니다. 다시 시도하세요. 문제가 지속되면 시스템 관리자에게 문의하십시오.

원인 1

Outlook용 Dynamics 365 앱은 권한 부여 서비스에 연결하여 이 앱을 사용할 권한이 있는지 확인할 수 없습니다.

해결 방법

이 문제를 해결하려면 먼저 앱을 닫고 다시 열어 볼 수 있습니다. 문제가 지속되면 인터넷 브라우저를 닫았다가 다시 열어 보세요. 문제가 계속되면 다음 옵션을 사용하여 Dynamics 365에서 사용하는 URL과 인증 URL이 동일한 무결성 수준을 사용하도록 합니다.

옵션 1 - Internet Explorer의 동일한 보안 영역에 Dynamics 365 URL 및 인증 URL 각각 추가
  1. Internet Explorer에서 도구>인터넷 옵션을 선택합니다.

  2. 보안 탭을 선택하고 신뢰할 수 있는 사이트 영역을 선택한 다음 사이트를 선택합니다.

  3. 영역에 이 웹 사이트 추가에서 한 번에 하나씩 다음 URL을 입력합니다.

    *.dynamics.com
    *.microsoftonline.com
    https://login.windows.net

    Important

    페더레이션 인증을 사용하여 회사 자격 증명을 사용하여 Dynamics 365에 액세스하는 경우 회사에서 사용하는 인증 URL도 추가해야 합니다. 예를 들어 회사에서 인증 URL이 있는 AD FS(Active Directory Federation Services)https://adfs.contoso.com/...경우 이 URL을 동일한 영역에 추가하거나 두 영역이 동일한 보호 모드 설정을 가지고 있는지 확인합니다.

  4. 추가를 선택한 다음 확인을 선택하여 사이트를 저장합니다.

옵션 2 - 각 Internet Explorer 보안 영역에서 보호 모드 사용

각 Internet Explorer 보안 영역에서 보호 모드를 사용하도록 설정하면 각 URL이 동일한 무결성 수준으로 로드됩니다.

  1. Internet Explorer에서 도구>인터넷 옵션을 선택합니다.
  2. 보안 탭을 선택합니다.
  3. 각 영역(인터넷, 로컬 인트라넷신뢰할 수 있는 사이트)을 선택합니다.
  4. 각 영역을 선택하는 동안 보호 모드 사용 확인란이 선택되어 있는지 확인합니다.
  5. 확인을 선택하여 인터넷 옵션 대화 상자를 닫습니다.

주의

보안 영역에 대해 보호 모드를 사용하도록 설정하면 URL이 낮은 무결성 수준(가장 안전한)으로 로드됩니다. 보안 영역에 대해 보호 모드를 사용하지 않도록 설정하면 URL이 중간 무결성 수준에서 로드됩니다. URL이 신뢰할 수 있는 사이트 또는 로컬 인트라넷 영역에 추가되지 않은 경우 기본적으로 보호 모드가 사용하도록 설정된 인터넷 영역에서 로드됩니다.

원인 2

이 문제는 Dynamics 365 앱 for Outlook이 설치된 후 Dynamics 365(온라인) URL이 변경된 경우에 발생할 수 있습니다. 예를 들어 Dynamics 365 URL이 앱을 배포할 때인 https://contosocorp.crm.dynamics.com 경우 URL을 나중에 변경합니다 https://contoso.crm.dynamics.com .

오류 메시지에서 이 문제 해결 도움말 링크를 마우스 오른쪽 단추로 클릭하고 URL을 확인하여 문제의 원인인지 확인할 수 있습니다. URL이 현재 Dynamics 365 URL 대신 이전 URL인 경우 오류가 발생할 수 있습니다.

해결 방법

Outlook용 Dynamics 365 앱이 설치된 후 Dynamics 365(온라인) URL을 변경하는 경우 앱을 다시 배포해야 합니다.

  1. 시스템 관리자 역할이 있는 사용자는 Dynamics 365 웹 애플리케이션을 열고 설정 내에서 Dynamics 365 앱 for Outlook 영역으로 이동하여 사용자에게 앱을 다시 배포할 수 있습니다.

  2. 앱을 다시 배포해야 하는 사용자를 선택하고 앱 추가 단추 중 하나를 사용하여 앱을 다시 배포합니다.

  3. 상태가 Outlook추가됨으로써 변경되면 문제가 해결되었는지 확인할 수 있습니다. 앱이 이미 열려 있는 경우 닫고 다시 엽니다.

오류 2

데스크톱에서 Outlook을 사용하는 동안 Outlook용 Dynamics 365 앱을 열려고 하면 다음 오류 메시지가 표시될 수 있습니다.

로그인하는 데 문제가 있나요?
로그인하는 동안 문제가 발생했습니다. 신뢰할 수 있는 사이트에 다음 URL을 추가해 보세요.
https://*.dynamics.com
https://login.microsoftonline.com
문제가 지속되면 시스템 관리자에게 문의하십시오.

원인

Dynamics 365 App for Outlook을 사용하는 데 필요한 URL 중 일부는 다른 Internet Explorer 보안 영역 (예: 로컬 인트라넷 영역, 신뢰할 수 있는 사이트 영역 또는 인터넷 영역)에 있습니다.

데스크톱의 Outlook에서 Dynamics 365 앱 for Outlook을 사용하는 경우 Internet Explorer를 사용하여 콘텐츠를 표시하고 필요에 따라 인증하도록 리디렉션합니다. 다른 보안 영역은 영역에 대해 보호 모드를 사용할 수 있는지 여부에 따라 서로 다른 무결성 수준을 사용할 수 있습니다. 다른 URL이 서로 다른 무결성 수준으로 로드되는 경우 인증 URL에서 Dynamics 365로 인증이 성공적으로 전달되지 않습니다.

해결 방법

이 문제를 해결하려면 다음 옵션 중 하나를 사용하여 Dynamics 365에서 사용하는 URL과 인증 URL이 동일한 무결성 수준을 사용하도록 합니다.