다음을 통해 공유


UI 요소가 강조 표시되지 않거나 UI 또는 웹 요소 위로 마우스를 가져가면 오류가 발생합니다.

이 문서는 Citrix 또는 MICROSOFT RDP(원격 데스크톱 프로토콜) 환경과 같은 가상 데스크톱에서 UI 요소 선택기를 사용할 때 발생할 수 있는 문제를 해결하는 데 도움이 됩니다.

증상

UI 요소 선택 기를 사용하도록 설정된 Citrix 또는 RDP 창 내에서 애플리케이션 또는 웹 페이지의 UI 또는 웹 요소 위에 마우스 커서를 가져가면 다음이 표시될 수 있습니다.

  1. 요소가 강조 표시되지 않습니다.

  2. 가상 데스크톱에 대해 Power Automate 에이전트를 사용하도록 설정하는 방법에 대한 오류 메시지입니다.

    가상 데스크톱에서 UI 자동화 사용
    가상 데스크톱에서 UI 요소 사용을 자동화하려면 가상 데스크톱용 Power Automate 에이전트가 원격 머신에 설치되고 실행되고 있는지 확인합니다.

    가상 데스크톱에서 UI 자동화 사용 오류의 스크린샷

원인

원격 에이전트 구성 요소와의 통신이 작동하지 않습니다.

해결 방법

  1. Power Automate Citrix 또는 RDP 플러그 인이 등록되어 있는지 확인합니다.

    1. 가상 데스크톱 플랫폼(Citrix Desktop, Citrix Virtual Apps, 원격 데스크톱 앱 또는 Windows RDP 통신을 사용하는 원격 데스크톱)이 활성화되어 있는 동안 Power Automate의 도움말>문제 해결사로 이동하여 문제 해결사를 실행합니다.

      문제 해결사를 콘솔 및 흐름 디자이너를 통해 도움말>문제 해결사 아래의 전용 메뉴를 통해 수동으로 열 수 있습니다. 데스크톱용 Power Automate의 설치 폴더에서 찾을 수 있는 프로세스 파일 PAD.Troubleshooter.exe통해 열 수도 있습니다.

    2. UI/웹 자동화 문제 해결을 실행하여 통신에 대한 진단을 확인합니다. Citrix 또는 RDP 섹션에 오류가 표시되면 자세한 내용과 해결 방법은 확장합니다.

    3. 오류 세부 정보에 "액세스가 거부됨"이 표시되면 원격 컴퓨터의 정책은 사용자 프로필 폴더에서 특정 에이전트 구성 요소를 실행하는 것을 금지합니다. 이러한 디렉터리에서 실행 파일을 실행할 수 있도록 하려면 관리자에게 문의하세요.

      액세스가 거부된 오류 세부 정보를 보여 주는 Power Automate 문제 해결사 스크린샷

  2. 문제 해결사가 원격 에이전트가 실행되고 있지 않음을 나타내는 경우 에이전트가 Citrix 또는 RDP 세션에서 실행 중인지 확인합니다.

    가상 데스크톱 플랫폼이 활성화된 경우 에이전트 아이콘에 대한 트레이 아이콘을 확인합니다. 아이콘이 있는 경우 아이콘을 마우스로 가리키면 계속 실행 중인지 확인합니다. 이 경우 트레이 아이콘을 마우스 오른쪽 단추로 클릭하여 메뉴를 열고 상태를 선택합니다. 에이전트의 상태 및 오류 이유가 표시됩니다.

    가상 데스크톱용 Power Automate 에이전트의 연결이 끊어진 에이전트 아이콘의 스크린샷

  3. 에이전트가 실행되고 있지 않은 것으로 확인되고 Citrix가 사용 중인 경우 에이전트가 모든 Citrix 서버에 설치되어 있는지 확인합니다.

  4. 에이전트가 실행 중인 경우 에이전트의 트레이 아이콘 상태에 따라 다음 조건을 확인합니다.

    • 시스템의 디바이스가 작동하지 않습니다. Citrix 플러그 인이 호스트 시스템에 로드되지 않습니다.

      이 문제를 해결하려면 가상 데스크톱 플랫폼이 활성화되어 있는 동안 문제 해결사를 실행하고 UI 자동화 섹션에서 오류를 확인합니다.

    • Citrix 가상 채널 정책 사용: Citrix의 가상 채널 허용 목록 정책이 사용 또는 기본값으로 설정됩니다.

      이 정책의 기본 설정은 사용 또는 기본값입니다. 그러나 이 정책을 사용하지 않도록 설정하지 않으면 Power Automate 에이전트가 데스크톱용 Power Automate 통신할 수 없습니다. 통신 문제를 해결하려면 Citrix 관리자와 협력하여 정책을 사용 안 함으로 설정하고 정책을 적용한 후 Citrix 컴퓨터가 다시 시작되도록 합니다.

    • Citrix VDA 버전 < 2407: Citrix의 가상 채널 허용 목록 정책이 사용 또는 기본값으로 설정됩니다.

      이 정책의 기본 설정은 사용 또는 기본값입니다. 그러나 이 정책을 사용하지 않도록 설정하지 않으면 Power Automate 에이전트가 데스크톱용 Power Automate 통신할 수 없습니다. 통신 문제를 해결하려면 Citrix 관리자와 협력하여 정책을 사용 안 함으로 설정하고 정책을 적용한 후 Citrix 컴퓨터가 다시 시작되도록 합니다.

    • Citrix VDA 버전 >= 2407: 이전 가상 채널 허용 목록 정책은 기본값으로 유지될 수 있지만 다른 정책을 설정해야 합니다.

      다음 값을 사용하여 DVC 정책에 대한 가상 채널 허용 목록을 설정합니다.

      • C:\Program Files (x86)\Power Automate agent for virtual desktops\PAD.RDP.ControlAgent.exe,Microsoft.Flow.RPA.Desktop.UIAutomation.RDP.DVC.Plugin,PAD\CONTROL

      • C:\Users\*\AppData\Local\Microsoft\Power Automate Desktop\RDP Automation Agents\*\PAD.RDP.AutomationAgent.exe,Microsoft.Flow.RPA.Desktop.UIAutomation.RDP.DVC.Plugin,PAD\UIA

      정책을 적용한 후 Citrix 컴퓨터가 다시 시작되는지 확인합니다.

자세한 정보

가상 데스크톱에서 자동화

타사 정보 고지 사항

이 문서에서 설명하는 타사 제품은 Microsoft와 독립적인 회사에서 제조합니다. Microsoft는 이들 제품의 성능이나 안정성에 관하여 명시적이든 묵시적이든 어떠한 보증도 하지 않습니다.