다음을 통해 공유


사용자 프로필 또는 ProgramData 디렉터리가 기본 위치에서 이동되면 Microsoft Store 앱이 시작되지 않습니다.

이 문서에서는 사용자 디렉터리, 사용자 프로필 또는 ProgramData 디렉터리가 기본 위치에서 이동된 후 Microsoft Store Apps를 시작할 수 없는 문제에 대한 솔루션을 제공합니다.

적용 대상: Windows 10 - 모든 버전
원래 KB 번호: 2787623

증상

사용자 디렉터리, 개별 사용자 프로필 또는 ProgramData 디렉터리를 기본 위치에서 이동한 후에는 Microsoft Store 앱이 더 이상 시작되지 않습니다. 다양한 증상이 나타날 수 있습니다. 다음과 같은 증상이 나타날 수 있습니다.

  • Microsoft Store 앱 또는 Microsoft Store의 타일을 클릭하면 앱이 시작되지만 시작 화면으로 돌아갑니다. 오류가 표시되지 않습니다.

  • Microsoft Store의 타일을 클릭하면 저장소를 열지 못하고 오류가 반환됩니다.

    스토어에 연결할 수 없습니다. 서버 문제 또는 네트워크 연결 시간이 초과되어 이 문제가 발생했을 수 있습니다. 몇 분 정도 기다렸다가 다시 시도하세요. "다시 시도"를 클릭하면 스토어에 연결하는 데 성공할 수도 있고 그렇지 않을 수도 있습니다.

  • Microsoft Store의 타일을 클릭하면 스토어가 열리지만 앱을 구입하려고 하면 오류가 반환됩니다.

    구매를 완료할 수 없습니다.

  • 최신 PC 설정 앱은 열리지 않으며 여기에서 액세스하는 앱도 열리지 않습니다.

  • 최신 Windows 업데이트 열리지 않습니다 그러나 제어판 통해 액세스 된 레거시 Windows 업데이트 것입니다.

원인

사용자 디렉터리, 개별 사용자 프로필 또는 ProgramData 디렉터리가 기본 위치 이외의 다른 위치로 이동되면 Microsoft Store 앱은 더 이상 지원되거나 작동하지 않습니다.

해결

사용자 디렉터리(기본적으로 c:\users) 또는 개별 사용자 프로필의 기본 위치를 변경하지 마세요. ProgramData 디렉터리의 기본 위치를 변경하지 마세요(기본적으로 c:\ProgramData).

자세한 정보

사용자 및 ProgramData 디렉터리를 재배치하는 방법에 대한 자세한 내용은 아래 링크에 있습니다. 이러한 메서드는 있는 그대로 제공되며 테스트 환경에만 사용됩니다. 이러한 메서드는 Microsoft Store 및 Microsoft Store 앱이 사용되는 경우 지원되지 않는다는 것을 명확하게 나타냅니다.