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시스템 관리 서버 2003 클라이언트 컴퓨터를 다시 시작한 후 SMS 에이전트 호스트 서비스가 시작되지 않습니다.

이 문서에서는 Systems Management Server 2003 클라이언트 컴퓨터를 다시 시작한 후 SMS 에이전트 호스트 서비스가 시작되지 않는 문제에 대한 해결을 제공합니다.

적용 대상: Windows 10 - 모든 버전
원래 KB 번호: 922362

Important

이 문서는 레지스트리 수정 방법에 대한 정보를 담고 있습니다. 수정하기 전에 해당 레지스트리를 백업하세요. 문제가 발생하는 경우 레지스트리를 복원하는 방법을 알고 있어야 합니다. 레지스트리를 백업, 복원 및 수정하는 방법에 대한 자세한 내용은 다음 문서 번호를 클릭하여 Microsoft 기술 자료에서 문서를 확인합니다.
microsoft Windows 레지스트리에 대한 256986 설명

증상

SMS(Microsoft Systems Management Server) 2003 클라이언트 컴퓨터를 다시 시작하면 SMS 에이전트 호스트 서비스(Ccmexec.exe)가 시작되지 않습니다. 이 문제가 발생하면 SMS 클라이언트 컴퓨터의 CCMExec.log 파일에 다음과 유사한 오류 항목이 나타날 수 있습니다.

CCMExec.log 파일 항목 1
CCMEXEC 서비스 시작... $$<CcmExec><Fri 2월 13일 8:13:13.819 2004 중부 표준시><스레드=1216(0x4C0)>
컴퓨터 ComputerName 에서 사용자 SYSTEM으로 실행.
$$<CcmExec><Fri 2월 13일 8:13:13.859 2004 중부 표준시><스레드=1216 (0x4C0)>
오류!! 시스템 경로에서 WBEM을 찾을 수 없습니다. $$<CcmExec><Fri 2월 13일 8:13:13.859 2004 중부 표준시><스레드=1216 (0x4C0)>
프로세스 환경 변수 PATH에 WBEM을 추가했습니다. $$<CcmExec><Fri 2월 13일 8:13:13.859 2004 중부 표준시><스레드=1216 (0x4C0)>
COM 초기화 $$<CcmExec><Fri 2월 13일 8:13:13.859 2004 중부 표준시><스레드=1216 (0x4C0)>
로깅 변경 알림 등록 $$<CcmExec><Fri 2월 13일 8:13:13.869 2004 중부 표준시><스레드=1216 (0x4C0)>
프로세스에 대한 기본 로깅 구성 요소 설정 $$<CcmExec><Fri 2월 13일 8:13:13.869 2004 중부 표준시><스레드=1216 (0x4C0)>
서비스 상태를 RUNNING으로 설정합니다. $$<CcmExec><Fri 2월 13일 8:13:13.869 2004 중부 표준시><스레드=1216 (0x4C0)>
복구가 필요한지 확인합니다. $$<CcmExec><Fri 2월 13일 8:13:13.889 2004 중부 표준시><스레드=1216 (0x4C0)>
WMI 네임스페이스 '\\.\root\ccm'(80004002) $$<CcmExec><Fri 2월 13일 8:13:17.224 2004 Central Standard Time><thread=1216(0x4C0)을 열지 못했습니다.>
CCMExec.log 파일 항목 2
1/25/2006 9:16:35 PMFailed to open to WMI namespace '\\.\root\ccm' (8004100a)
1/25/2006 9:16:35 PMCCMDoCertificateMaintenance 실패(0x8004100a).
1/25/2006 9:16:35 PMFailed to open to WMI namespace '\\.\root\CCM\Events' (8004100a)
2006년 1월 25일 9:16:35 PMCCMDoCertificateMaintenance()가 CCM_ServiceHost_CertificateOperationsFailure 상태 이벤트를 발생시켰습니다.
2006년 1월 25일 오후 9:16:35 서비스 설정 로드.
1/25/2006 9:16:35 PMFailed to open to WMI namespace '\\.\root\ccm\Policy\Machine' (8004100a)
2006년 1월 25일 9:16:35 PMError 로드 서비스 설정. 코드 0x8004100a
2006년 1월 25일 9:16:35 PMPhase 0 초기화에 실패했습니다(0x8004100a).
2006년 1월 25일 9:16:35 PMService 초기화에 실패했습니다(0x8004100a).
1/25/2006 9:16:35 PMShutting down AdditonallyCCMEXEC...
또한 Wbemcore.log 파일에 다음과 유사한 오류 항목이 포함될 수 있습니다.
(2월 13일 금요일 08:13:13 2004.69289) : 레지스트리 항목이 설치 프로그램을 실행 중임을 나타냅니다.
(2월 13일 금요일 08:14:13 2004.129856) : CFactory 구문
(2월 13일 금요일 08:14:13 2004.129886) : CFactory 소멸
(2월 13일 금요일 08:14:13 2004.129896) : WINMGMT_ACTIVE 뮤텍스 생성됨
(2월 13일 금요일 08:14:13 2004.129946) : 레지스트리에서 구성 정보 읽기
(2월 13일 금요일 08:14:16 2004.132800) : 활성 네임스페이스 //./ROOT/ccm/policy에 대한 네임스페이스 초기화 요청 준비
(2월 13일 금요일 08:14:16 2004.132901) : 활성 네임스페이스 //./root/CIMV2에 대한 네임스페이스 초기화 요청 준비
(2월 13일 금요일 08:14:16 2004.132961) : 활성 네임스페이스 //./root/subscription에 대한 네임스페이스 초기화 요청 준비
(2월 13일 금요일 08:14:16 2004.133021) : 네임스페이스 //./ROOT/ccm/policy 초기화
(2월 13일 금요일 08:14:16 2004.133041) : 네임스페이스 //./root 초기화

원인

이 문제는 다음 조건 중 하나 또는 둘 다에 해당하는 경우에 발생합니다.

  • %SystemRoot%\System32\Wbem 경로 변수가 클라이언트 컴퓨터의 시스템 경로에 나열되지 않습니다.
  • SMS 클라이언트 컴퓨터에서 경로 레지스트리 항목의 형식이 잘못되었습니다.

WMI(Windows Management Instrumentation) 서비스가 적시에 시작되지 않는 경우에도 문제가 발생할 수 있습니다.

해결

이 문제를 해결하려면 다음 방법 중 하나를 사용하세요.

방법 1: %SystemRoot%\System32\Wbem 변수가 클라이언트 컴퓨터의 시스템 경로에 나열되어 있는지 확인합니다.

  1. 시작을 클릭하고 실행을 클릭하고 sysdm.cpl 입력한 다음 확인을 클릭합니다.

  2. 고급 탭을 클릭한 다음 환경 변수를 클릭합니다.

  3. 시스템 변수에서 경로를 클릭한 다음 편집을 클릭합니다.

  4. %SystemRoot%\System32\Wbem이 변수 값 상자에 나열되어 있는지 확인합니다. 이 값이 나열되지 않으면 추가해야 합니다. 이렇게 하려면 다음 단계를 따르세요.

    1. 시스템 변수 편집 대화 상자의 변수 상자에서 텍스트 끝 부분을 클릭한 다음 다음을 입력합니다.
      ;%SystemRoot%\System32\Wbem

    2. 확인을 세 번 클릭하여 변경 내용을 저장합니다.

방법 2: 경로 레지스트리 항목의 형식을 REG_EXPAND_SZ

Warning

레지스트리 편집기나 다른 방법을 사용하여 레지스트리를 잘못 수정하면 심각한 문제가 발생할 수 있습니다. 이러한 문제가 발생하면 운영 체제를 다시 설치해야 할 수도 있습니다. Microsoft에서는 이 문제의 해결을 보장하지 않습니다. 레지스트리 수정에 따른 책임은 사용자에게 있습니다.

  1. 시작, 실행을 차례로 클릭하고 regedit를 입력한 다음 확인을 클릭합니다.

  2. 레지스트리 편집기에서 다음 레지스트리 하위 키를 찾아 클릭합니다. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment

  3. 경로 항목의 형식이 REG_SZ 아니라 REG_EXPAND_SZ 있는지 확인합니다. 이 항목의 형식이 REG_SZ 경우 경로 정보를 복사하고 기존 경로 항목을 삭제한 다음 REG_EXPAND_SZ 형식의 새 항목을 만들어야 합니다. 이렇게 하려면 다음 단계를 따르세요.

    1. 레지스트리 편집기에서 경로 값을 두 번 클릭합니다.
    2. 값 데이터 상자에서 텍스트를 마우스 오른쪽 단추로 클릭하고 복사를 클릭한 다음 취소를 클릭합니다.
    3. 텍스트를 메모장 문서에 붙여넣습니다.
    4. 레지스트리 편집기에서 경로를 마우스 오른쪽 단추로 클릭한 다음 삭제를 클릭합니다.
    5. 메뉴 모음에서 편집을 클릭하고 새로 만들기가리킨 다음 확장 가능한 문자열 값을 클릭합니다.
    6. 경로를 입력한 다음 Enter 키를 누릅니다.
    7. 경로를 두 번 클릭합니다.
    8. 값 데이터 상자를 마우스 오른쪽 단추로 클릭하고 붙여넣기를 클릭한 다음 확인을 클릭합니다.
    9. 레지스트리 편집기를 종료하십시오.

추가 정보

고급 클라이언트 푸시 설치 문제 해결에 대한 자세한 내용은 Microsoft 기술 자료의 다음 문서를 참조하세요.

928282 Systems Management Server 2003 및 System Center Configuration Manager 2007에서 고급 클라이언트 푸시 설치 문제를 해결하는 방법