이 문서에서는 인쇄 중에 발생할 수 있는 새로운 일반적인 문제에 대해 설명하고 이러한 문제에 대한 가능한 해결 방법을 제공합니다.
이러한 디바이스에서 스마트 카드 인증을 사용하는 경우 인쇄 및 스캔이 실패할 수 있습니다.
환경의 도메인 컨트롤러에 KB5004237 설치한 후에는 PIV(스마트 카드) 인증을 사용할 때 일부 프린터, 스캐너 및 다기능 디바이스가 인쇄되지 않을 수 있습니다.
해결
이 문제에 대한 자세한 내용은 KB5005408 - 스마트 카드 인증으로 인해 인쇄 및 스캔 실패가 발생할 수 있습니다.
특정 프린터는 USB를 통해 인쇄할 수 없습니다.
KB5003690 이상 업데이트(대역 외 업데이트 KB5004760 및 KB5004945 포함)를 설치한 후 특정 프린터에 인쇄하려고 할 때 문제가 발생할 수 있습니다. 다양한 브랜드와 모델은 주로 USB를 통해 연결되는 영수증 또는 레이블 프린터에 영향을 받습니다.
해결
이 문제는 KIR(알려진 문제 롤백)에서 해결 됩니다. 이 문제는 CVE-2021-34527 또는 CVE-2021-1675와 관련이 없습니다.
Windows Print Spooler 원격 코드 실행 취약성
2021년 7월 6일 - KB5004945(OS 빌드 19041.1083, 19042.1083 및 19043.1083) 대역 외 업데이트 및 이후 Windows 업데이트를 설치한 후 관리자가 아닌 사용자는 서명된 인쇄 드라이버만 인쇄 서버에 설치할 수 있습니다. 기본적으로 관리자는 서명된 프린터 드라이버와 서명되지 않은 프린터 드라이버를 모두 인쇄 서버에 설치할 수 있습니다. 시스템의 신뢰할 수 있는 루트 인증 기관에 설치된 루트 인증서는 서명된 드라이버를 신뢰합니다.
해결
자세한 내용은 KB5005010: 2021년 7월 6일 업데이트를 적용한 후 새 프린터 드라이버의 설치 제한을 참조 하세요.
컴퓨터에 연결된 프린터가 인쇄되지 않음
원인
물리적 프린터, 인쇄 드라이버, 인쇄 서버 또는 인쇄하려는 응용 프로그램에 문제가 있을 수 있습니다.
해결
다음 단계를 수행하여 문제를 식별하고 해결합니다.
- 실제 프린터가 준비 상태이고 올바른 기본 프린터가 설정되어 있는지 확인합니다.
- 테스트 페이지를 인쇄해 봅니다.
- 명령줄에서 인쇄해 봅니다(PostScript가 아닌 프린터에만 해당). 명령 프롬프트에 입력
Dir > LPT1
합니다. - 메모장과 같은 텍스트 편집기에서 인쇄해 봅니다. 인쇄에 성공하면 프린터 드라이버가 올바르고 응용 프로그램에서 문제가 발생했음을 확인합니다. 메모장에서 인쇄할 수 없는 경우 프린터 드라이버로 인해 문제가 발생합니다.
- 시스템 드라이브에서 사용 가능한 디스크 공간을 확인합니다. 작업을 스풀링할 공간이 충분하지 않으면 더 작은 작업이 실패하더라도 더 큰 작업이 실패할 수 있습니다.
네트워크에 연결된 프린터가 인쇄되지 않음
원인
물리적 프린터, 클라이언트 컴퓨터의 논리적 프린터 설정, 인쇄하려는 애플리케이션, 네트워크 프로토콜 또는 하드웨어에 문제가 있을 수 있습니다.
해결
다음 메서드를 사용하여 문제를 격리하고 해결합니다.
- 기본 네트워크 연결을 확인합니다. 사용자 권한, 프로토콜, 공유 이름 등을 확인하여 서버를 볼 수 있는지 여부를 확인합니다. 서버에 파일을 복사해 봅니다. 서버에 액세스할 수 없는 경우 프린터에 액세스하지 못할 수 있습니다.
- 고급 탭에서 프린터 사용 가능 시간이 올바른지 확인합니다.
- 로컬 프린터를 만들고 포트를 네트워크 서버로 리디렉션합니다. 프린터 추가 마법사를 사용하여 로컬을 선택한 다음 프린터의 서버 및 프린터 이름(\\<servername\<printername>)을 입력합니다>. 그러면 인쇄 서버에서 파일을 복사할 수 있는지 여부가 결정됩니다.
- 인쇄 서버에서 사용 가능한 디스크 공간을 확인합니다. 작업을 스풀링할 공간이 충분하지 않으면 더 작은 작업이 실패하더라도 더 큰 작업이 실패할 수 있습니다.
애플리케이션 내에서 프린터를 구성하려고 할 때 거부된 메시지에 액세스
원인
프린터 구성을 변경할 수 있는 적절한 권한이 없습니다.
해결
프린터 설정을 변경하려면 프린터 관리 권한이 있어야 합니다.
문서가 완전히 인쇄되지 않거나 왜곡된 것처럼 보입니다.
원인
프린터 드라이버가 손상되었거나 잘못되었습니다.
해결
클라이언트 컴퓨터에 올바른 프린터 드라이버를 확인하거나 다시 설치합니다.
하드 디스크 문제가 발생하고 문서가 인쇄 서버에 도달하지 않습니다.
원인
하드 디스크에 문서를 스풀할 공간이 부족할 수 있습니다.
해결
하드 디스크에 충분한 디스크 공간이 있는지 확인하거나 스풀 폴더를 다른 볼륨으로 재배치합니다.
인쇄 서버의 문서가 인쇄되지 않으며 삭제할 수 없음
원인
인쇄 스풀러가 중단되었을 수 있습니다.
해결
인쇄 서버에서 인쇄 스풀러 서비스를 중지하고 다시 시작합니다.
드라이버가 나열되지 않음
해결
Windows 프린터 드라이버는 Microsoft와 인쇄 장치를 제조하는 독립 하드웨어 공급업체 간의 협력을 통해 개발됩니다. 신규 및 업데이트된 인쇄 드라이버의 경우 최신 프린터 드라이버를 다운로드 및 설치하는 방법에서 Microsoft 인쇄 지원을 참조하고 Windows 업데이트 확인하세요.
인터넷에서 다운로드한 새 인쇄 드라이버를 설치해야 합니다.
원인
프린터 추가 마법사 목록에는 인쇄 드라이버가 나열되지 않지만 인터넷에서 다운로드되었습니다.
해결
- 프린터 드라이버를 빈 폴더에 다운로드합니다.
- 실행 파일의 이름을 입력한 다음 스위치를 입력하여 파일을 확장합니다
-d
. 예를 들어 파일 이름이 Nt4prn.exe 경우 명령 프롬프트nt4prn -d
에 다음 명령을 입력합니다. - Readme.txt 및 License.txt 파일을 읽습니다.
- 시작 단추를 선택한 다음, 디바이스>프린터 및 스캐너 설정을>선택합니다.
- 오른쪽의 관련 설정에서 인쇄 서버 속성을 선택합니다.
- 드라이버 탭에서 프린터가 나열되어 있는지 확인합니다. 이 경우 모두 설정됩니다.
- 프린터가 나열되지 않으면 [추가]를 선택한 다음[프린터 드라이버 추가] 마법사에서 [시작]을 선택합니다.
- 프로세서 선택 대화 상자에서 디바이스의 아키텍처를 선택한 다음, 다음을 선택합니다.
- 프린터 드라이버 선택 대화 상자에서 디스크를 선택한 다음 찾아보기 단추를 선택합니다.
- 1단계에서 드라이버를 다운로드한 폴더를 가리킨 다음 지침에 따라 드라이버를 추가합니다.
프린터 위치 추적을 사용하는 경우에도 일부 프린터를 배치할 수 없습니다.
원인
프린터 위치 추적을 사용하도록 설정한 후 기본 동작은 위치 특성이 명명 규칙과 일치하는 프린터만 찾는 것입니다.
해결
이 프린터의 위치 문자열을 다시 설정합니다. 이 작업을 수행하는 방법을 알아보려면 프린터 위치 추적 사용을 참조하세요.
회사가 조직을 변경했기 때문에 명명 체계를 변경해야 합니다.
해결
Active Directory 사이트 및 서비스를 사용하여 사이트 및 서브넷을 업데이트합니다. 그런 다음 조직의 영향을 받는 프린터에 대한 모든 프린터 위치 필드를 업데이트해야 합니다. 업데이트를 신속하게 처리할 ADSI(Active Directory Service Interfaces) 스크립트를 만들 수 있습니다.
조직에는 서브넷이 없는 작은 네트워크가 있습니다.
해결
Active Directory는 연결된 서브넷이 없으면 디렉터리 트리에서 노드를 찾을 수 없습니다. 조직이 충분히 작은 경우 사용자가 조직의 프린터를 검색할 수 있으므로 이 상황은 문제가 되지 않습니다. 그러나 프린터가 많은 대규모 조직이나 조직의 경우 사용자가 프린터를 찾는 데 도움이 되도록 위치 계층 구조를 찾아볼 수 있습니다. 이렇게 하려면 만들려는 계층 구조에 해당하는 인조 서브넷을 Active Directory에 만들어야 합니다.
데이터 수집
Microsoft 지원의 지원이 필요한 경우 사용자 환경 문제에 대해 TSS를 사용하여 정보 수집에 설명된 단계에 따라 정보를 수집하는 것이 좋습니다.