다음을 통해 공유


원격 액세스 서버 작업 문제 식별 및 해결

참고: Windows Server 2012 DirectAccess 및 라우팅 및 원격 액세스 서비스 (RRAS)를 단일 원격 액세스 역할로 결합 합니다.

다음 절차를 사용하여 원격 액세스 서버 운영 문제를 식별하고, 문제의 근본 원인을 파악하며, 이를 해결하기 위한 방법을 찾을 수 있습니다.

참고

이 항목에 설명 된 작업을 완료 하려면 Domain Admins 그룹의 구성원 또는 각 컴퓨터에서 Administrators 그룹의 구성원으로 로그인 해야 합니다. Administrators 그룹의 구성원 인 계정으로 로그인 하는 동안에 작업을 완료할 수 없는 경우에 Domain Admins 그룹의 구성원 인 계정으로 로그인 하는 동안 작업을 수행해 봅니다.

이 항목에는 다음 작업을 수행 하는 방법에 대 한 정보가 포함 됩니다.

  • 작업 문제를 시뮬레이션 합니다.

  • 작업 문제를 식별 하 고 수정 작업을 수행

  • IP 도우미 서비스를 복원 합니다.

작업 문제를 시뮬레이션 합니다.

주의

구성이 올바르게 되어 있고 문제가 없습니다. 이 절차를 통해 운영 문제를 시뮬레이션할 수 있습니다. 현재 서버가 프로덕션 환경에서 클라이언트를 서비스하고 있다면, 지금 당장 이러한 작업을 수행하지 않는 것이 좋습니다. 대신, 나중에 원격 액세스 서버에서 문제가 발생할 수 있는 문제를 해결 하는 방법을 이해 하는 단계를 읽을 수 있습니다.

IP 도우미 서비스(IPHlpSvc)는 IP-HTTPS, 6to4, Teredo와 같은 IPv6 전환 기술을 호스팅하며, DirectAccess 서버의 올바른 작동을 위해 필요합니다. 원격 액세스 서버에서 시뮬레이션 된 작업 문제를 보여 주기 위해 (IPHlpSvc) 네트워크 서비스를 중지 해야 합니다.

IP 도우미 서비스를 중지 하려면
  1. 원격 액세스 서버의 시작 화면에서 관리 도구를 클릭한 다음, 서비스를 두 번 클릭합니다.

  2. 목록에서 서비스, 아래로 스크롤하여 마우스 오른쪽 단추로 클릭 IP 도우미, 를 클릭 하 고 중지합니다.

작업 문제를 식별 하 고 수정 작업을 수행

IP 도우미 서비스를 해제 하면 원격 액세스 서버에서 심각한 오류가 발생 합니다. 모니터링 대시보드는 서버 작업 상태 및 문제에 대 한 세부 정보에 표시 됩니다.

세부 정보를 식별 하 고 수정 작업을 수행 하려면
  1. 서버 관리자에서 도구를 클릭하고, 원격 액세스 관리를 클릭합니다.

  2. 클릭 대시보드원격 액세스 관리 콘솔에서 원격 액세스 대시보드로 이동합니다.

  3. 왼쪽된 창에서 원격 액세스 서버가 선택 되어 있는지 확인 하 고 가운데 창에서 클릭 작동 상태합니다.

  4. 작업 상태를 나타내는 녹색 또는 빨간색 아이콘으로 구성 요소 목록이 표시 됩니다. 목록에서 IP-HTTPS 열을 클릭하십시오. 행을 선택하면 작업에 대한 세부 정보가 다음과 같이 세부 정보 창에 표시됩니다.

    오류

    (IPHlpSvc) IP 도우미 서비스가 중지 되었습니다. DirectAccess 예상과 다르게 동작할 수 있습니다. IP 도우미 서비스는 연결 플랫폼, IPv6 전환 기술 및 IP-HTTPS를 사용하여 터널 연결을 제공합니다.

    원인

    1. IP 도우미 서비스가 중지 되었습니다.

    2. IP 도우미 서비스가 응답 하지 않습니다.

    해결 방법

    1. 서비스가 실행 중인지 확인하려면 Windows PowerShell 프롬프트에서 Get-Service iphlpsvc를 입력합니다 .

    2. 서비스를 활성화하려면 관리자 권한의 Windows PowerShell 프롬프트에서 Start-Service iphlpsvc를 입력하십시오.

    3. 서비스를 다시 시작하려면 높은 권한의 Windows PowerShell 프롬프트에서 Restart-Service iphlpsvc를 입력하십시오.

IP 도우미 서비스를 복원 합니다.

원격 액세스 서버에 IP 도우미 서비스를 복원 하려면 위의 하거나 서비스를 다시 시작 하려면 해결 단계를 수행 하거나 IP 도우미 서비스 오류를 시뮬레이션 하는 데 사용 하는 프로시저를 되돌리려면 다음 절차를 사용할 수 있습니다.

원격 액세스 서버에 IP 도우미 서비스를 다시 시작
  1. 시작 화면에서 관리 도구를 클릭한 다음, 서비스를 두 번 클릭합니다.

  2. 목록에서 서비스, 아래로 스크롤하여 마우스 오른쪽 단추로 클릭 IP 도우미, 를 클릭 하 고 시작합니다.

Windows PowerShell Windows PowerShell 해당 명령

다음 Windows PowerShell cmdlet은 이전 절차와 같은 기능을 수행합니다. 서식 제약 조건으로 인해 각 cmdlet이 여러 줄로 보이더라도, 각 cmdlet을 한 줄에 입력하세요.

PS> Get-RemoteAccessHealth | Where-Object {$_.Component -eq "IP-HTTPS"} | Format-List -Property *