Share via


Feil når Outlook for iOS eller Android kobler til Exchange Server: Usikker tilkobling eller Sikker tilkobling ikke tilgjengelig

Opprinnelig KB-nummer: 4056392

Symptomer

Når du bruker Microsoft Outlook for iOS eller Outlook for Android til å logge på en forekomst av Exchange Server som bruker et SSL-sertifikat for sikre tilkoblinger, får du en av følgende feilmeldinger:

Usikker forbindelse. Vil du logge på likevel?

Sikker tilkobling er ikke tilgjengelig. Vil du logge på likevel?

Årsak

Dette problemet oppstår fordi SSL-sertifikatet anses som ikke støttet av én av følgende årsaker:

  • SSL-sertifikatet er ugyldig eller utløpt.
  • SSL-sertifikatet er ikke klarert.

Obs!

Outlook for iOS og Outlook for Android bruker standard java-klarerte sertifiseringsinstanser (CAer). Hvis organisasjonens sertifikat ikke er signert av en sertifiseringsinstans som er en del av standard java-klarerte sertifiseringsinstanser, oppstår denne feilen.

Løsning

Du kan trygt ignorere denne feilmeldingen og logge på Exchange Server. Denne feilmeldingen skal bare vises én gang.

Vi anbefaler at du bruker et SSL-sertifikat som offisielt støttes av Java CA-sertifikatlageret.

Slik bekrefter du at et sertifikat er klarert av Java-sertifiseringsinstansen

  1. Hent sertifiseringsinstansen for sertifikatet.

  2. Last ned den nyeste Java SE Development Kit (JDK). Denne pakken inkluderer Java-klarerte CAer.

  3. Åpne et ledetekstvindu på en Windows-basert datamaskin, eller åpne et Terminal-vindu på en macOS-basert datamaskin.

  4. Bruk keytool-verktøyet til å vise de klarerte CAene ved å kjøre følgende kommando:

     keytool -keystore "<keystore location>" -storepass changeit -list -v
    

    Obs!

    På en macOS-basert datamaskin kan nøkkellagerplasseringsparameteren <> være «$JAVA_HOME/jre/lib/security/cacerts».

  5. Kontroller at sertifiseringsinstansen for sertifikatet er i listen.

Hvis du vil ha mer informasjon om keytool-verktøyet, kan du se følgende artikler: