Share via


Numerisk tastatur mangler i Teams

Microsoft Teams-brukere kan ikke foreta utgående anrop fordi det numeriske tastaturet i Anrop-skjermen i Teams mangler.

Årsak

I Teams-klienten gir det numeriske tastaturet brukere tilgang til PSTN-funksjonalitet (Public Switched Telephone Network). Det numeriske tastaturet er tilgjengelig for brukere med en telefonsystemlisens, forutsatt at de er riktig konfigurert. Alle følgende betingelser må oppfylles for at det numeriske tastaturet skal vises:

  • Brukeren har tilordnet en Teams-lisens.
  • Brukeren har tilordnet en lisens for Teams Phone System (MCOEV).
  • Brukeren har Microsoft Anropsplan, Operatørtilkobling eller er aktivert for direkteruting.
  • Brukeren har VoIP for virksomheter aktivert.
  • Brukeren er oppkoblet hjemmefra og ikke i Skype for Business lokalt.
  • Brukeren har Teams anropspolicy aktivert med AllowPrivateCalling = sann.

Løsning

Se Konfigurasjonen av det numeriske tastaturet for å finne ut hvordan du konfigurerer brukere riktig for PSTN-anrop i Teams.

Bruk ett av følgende diagnoseverktøy:

  • Bruk Microsoft Remote Connectivity Analyzer

    Brukere av Microsoft 365-administratorer kan kjøre testen på det Numeriske tastaturet for PstN-anrop i Teams i konteksten til brukeren som opplever symptomet.

  • Microsoft 365 støtter selvdiagnoseverktøy

    Administratorbrukere i Microsoft 365 har tilgang til diagnostikk som kan kjøres i leietakeren for å bekrefte mulige problemer med numeriske tastaturet.

    Obs!

    Denne funksjonen er ikke tilgjengelig for Microsoft 365 Government, Microsoft 365 drevet av 21Vianet eller Microsoft 365 Tyskland.

    Velg Kjør tester-koblingen. Den vil fylle ut diagnostikken i Microsoft 365-administrasjonssenteret.

VoIP for virksomheter viser Deaktivert

Hvis diagnoseresultatet fra ett av verktøyene viser at brukeren ikke er aktivert for VoIP for virksomheter, men brukerkontoen viser at den er aktivert i Teams PowerShell, må leietakeradministratoren slå innstillingen av og på igjen for å fremtvinge en oppdatering til serverdelen som vist i eksemplet nedenfor:

Set-CsPhoneNumberAssignment -Identity "Ken Myer" -EnterpriseVoiceEnabled $False
Set-CsPhoneNumberAssignment -Identity "Ken Myer" -EnterpriseVoiceEnabled $True

Direkterutingsaktiverte brukere mangler numerisk tastatur

Hvis det diagnositiske resultatet fra ett av verktøyene viser at brukeren ikke er riktig konfigurert med en rutingspolicy, må leietakeradministratoren fjerne brukerens OnlineVoiceRoutingPolicy-verdi, og deretter angi den riktige verdien for policyen som vist i eksemplet nedenfor:

Grant-CsOnlineVoiceRoutingPolicy -Identity "Ken Myer" -PolicyName $Null
Grant-CsOnlineVoiceRoutingPolicy -Identity "Ken Myer" -PolicyName "RedmondOnlineVoiceRoutingPolicy"

Disse handlingene tvinger frem en oppdatering av policyen i serverdelmiljøet i Teams. Når denne endringen er gjort, skal brukeren se det numeriske tastaturet vist under Anrop innen en time.

Mer informasjon

Trenger du fremdeles hjelp? Gå til Microsoft Community.