Can't attach photos to applications on Android Enterprise work profile enrolled devices
This article fixes an issue in which you can't attach photos to applications on an Android Enterprise enrolled device.
Symptoms
On an Android Enterprise work profile enrolled device, when you try to attach a photo into the work profile's application (such as Word, Excel, Outlook, or OneDrive), you receive the following error message:
Unable to add attachment due to IO error
Cause
This occurs because Android requires an additional application in the workspace to open photos.
Solution
To resolve this issue, approve and assign a File Explorer application (such as File Explorer application by Google) from the managed Google Play store to your device.
Then navigate to the application, and click the Attach icon to attach photos.
Note
Each app has a different attaching process. For example, when configuring it through Outlook, select the three horizontal lines menu in the top left and then select more. Then, an option is provided for you to select photos to attach.
Third-party information disclaimer
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
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