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Solution checker enforcement in Managed Environments blocks or warns on import

Applies to:   Power Platform, Solutions

Background

Solution checker enforcement in Managed Environments allows admins to require valid solution checker results before a solution can be imported.

Symptoms

When you try to import a solution, you receive one of the following error or warning messages:

Error: Solution is blocked from importing due to critical violations. Fix these violations, then retry the import.

Warning: There are critical violations in this solution. You can block solutions with critical violations by enabling Solution Checker enforcement in Managed Environments settings page.

Cause

The error or warning message occurs because solution checker enforcement in Managed Environments is enabled in either Warn or Block mode, and critical violations are present in the results.

Resolution

The critical violations in the solution must be fixed before importing the solution.

If a results link is present in the message, you can use the link to download a SARIF file to see the results. The rules documentation lists each rule with a link for more information and how to fix.

If the results link isn't present in the message, you can run solution checker separately to see the results. Here are some special considerations:

  • Solution checker must be run with the solution checker ruleset. The easiest ways to do this are:
    • Run solution checker in Power Apps where the solution checker ruleset is used.
    • Use pac solution check where the solution checker ruleset is used by default.
    • If explicitly passing a ruleset ID, use 0AD12346-E108-40B8-A956-9A8F95EA18C9, which represents the solution checker ruleset.
  • When invoking solution checker, don't pass any file exclusions or rule overrides. These may be supported for solution checker enforcement in the future.