Veelvoorkomende configuratieproblemen met het automatisch maken en bijwerken van records oplossen
Dit artikel bevat oplossingen voor veelvoorkomende scenario's met configuratiefouten met regels voor het automatisch maken en bijwerken van records, waardoor het maken van records kan mislukken of worden overgeslagen.
Scenario 1
Voorbeeld: Configuratie van regel voor automatisch maken en bijwerken van records
- De optie Contactpersoon maken voor onbekende afzender moet zijn geselecteerd.
- Stel voorwaardecriteria in op Alle binnenkomende e-mail.
- Voeg actie toe om een case te maken, selecteer Eigenschappen weergeven en stel de casevelden per bedrijfsgebruikscase in.
Fout 1: 'De case ontbreekt klant'
In het veld Klant van de sectie CASEDETAILS wordt de waarde van Afzenders-account (Email) ingesteld zoals hieronder wordt weergegeven.
Deze instelling resulteert in de volgende fout in systeemtaken:
De klant ontbreekt in de zaak.
Oplossing voor fout 1
U kunt dit probleem oplossen door het veld Klant leeg te houden of in te stellen op {Sender(Email)}. Hierdoor kan het systeem automatisch een contactpersoon maken voor de onbekende afzender en deze koppelen aan de case.
Fout 2: 'Er is een fout opgetreden'
Het veld Klant is ingesteld als {Senders Account(Email)} en het veld Contactpersoon is ingesteld als {Sender(Email)}.
Deze instelling resulteert in de volgende fout in systeemtaken:
Er is een fout opgetreden. Probeer deze actie opnieuw. Als het probleem zich blijft voordoen, raadpleegt u de Microsoft Dynamics 365 Community voor oplossingen of neemt u contact op met de Microsoft Dynamics 365-beheerder van uw organisatie. Tot slot kunt u contact opnemen met Microsoft Ondersteuning.
Oplossing voor fout 2
U kunt dit probleem oplossen door het veld Klant leeg te houden of in te stellen op {Sender(Email)}. Hierdoor kan het systeem automatisch een contactpersoon maken voor de onbekende afzender en deze koppelen aan de case.
Fout 3: 'De opgegeven contactpersoon behoort niet tot de contactpersoon die is opgegeven in het veld klant'.
De velden Klant en Contactpersoon zijn ingesteld als {Afzender(Email)}.
Deze instelling resulteert in de volgende fout in systeemtaken:
De opgegeven contactpersoon behoort niet tot de contactpersoon die is opgegeven in het veld Klant. Verwijder de waarde uit het veld contactpersoon of selecteer een contactpersoon die is gekoppeld aan de geselecteerde klant en probeer het opnieuw.
Oplossing voor fout 3
U kunt dit probleem oplossen door het veld Contactpersoon leeg te laten en het veld Klant in te stellen op leeg of op {Sender(Email)}.
Validatiestappen
U moet de configuratie- en validatiestappen in de volgende tabel valideren om de hoofdoorzaak van het probleem te begrijpen en op te lossen.
Optie in Regel voor automatisch maken en bijwerken van records in Service Management | Indien geselecteerd als | Validatiestappen | Resultaat |
---|---|---|---|
Een case maken als er een geldig recht bestaat voor de klant | Ja | Controleer of er een actief recht bestaat voor de klant. Geldig actief recht wordt als volgt geëvalueerd: - Als de afzender van het e-mailbericht een contactpersoon is met een bovenliggend account, maakt Dynamics 365 klantenservice een case als het bovenliggende account van de contactpersoon een geldig recht heeft en de contactpersoon wordt vermeld in de sectie Contactpersonen van het recht Of, - Als de sectie Contactpersonen leeg is (wat betekent dat het recht van toepassing is op alle contactpersonen voor de klant) |
Er wordt een case gemaakt. |
Een case maken van een e-mailbericht dat is verzonden door onbekende afzenders | Ja | Voor binnenkomende e-mail van een onbekende afzender | - Er wordt een case gemaakt.
- Er wordt ook een contactpersoon gemaakt voor de onbekende afzender. |
Ja | Voor een binnenkomende e-mail met e-mailadres van een inactief account of contactpersoon | - Er wordt een case gemaakt.
- Een inactief account of contactpersoon wordt geactiveerd. |
|
Neen | Voor een binnenkomende e-mail met het e-mailadres van een actief account of contactpersoon | Er wordt een case gemaakt. | |
Neen | Voor een binnenkomende e-mail die is verzonden per ander recordtype dan account of contactpersoon | Er wordt geen case gemaakt. | |
Neen | Voor een binnenkomende e-mail met e-mailadres van een inactief account of contactpersoon | Er wordt geen case gemaakt. | |
Een case maken voor activiteiten die zijn gekoppeld aan een opgeloste case | Ja | Voor een binnenkomende e-mail met betrekking tot een opgeloste zaak | Er wordt een case gemaakt. |
Ja | Voor een binnenkomende e-mail met betrekking tot een actieve case | Er wordt geen case gemaakt. |
Scenario 2: het gebruik van {Regarding(Email)} in de verouderde ervaring geeft niet de juiste gegevens in de stroom
In verouderde items voor het maken en bijwerken van records in de klantenservice kunt u de entiteit (een contactpersoon of een account) zoeken die een e-mail verzendt, de polymorfe zoekopdracht Afzender (Email), waarmee automatisch de juiste entiteit wordt opgehaald en de naam van de entiteit wordt weergegeven. Polymorfe opzoekacties zijn opzoekacties waarbij het doel van de opzoekactie meer dan één soort entiteit is. Het kan bijvoorbeeld verwijzen naar een contactpersoon of een account. In moderne 'regels voor automatisch maken en bijwerken van records' wordt deze automatische weergave echter niet ondersteund, dus moet u het type entiteit opgeven dat u wilt ophalen, samen met de velden die uit die entiteit moeten worden weergegeven.
Oorzaak
Een stroom gebruikt de waarde {Regarding(Email)} niet zoals een verouderde werkstroom, omdat stroomexpressies verwijzen naar een gegevenswaarde uit een van de nettoladingen van de vorige stroomstap. Als de waarde {Regarding(Email)} bijvoorbeeld leeg is wanneer de stroom begint, blijft de waarde in de nettolading van de triggerstap voor {Regarding(Email)} leeg. Zelfs als de waarde {Regarding(Email)} wordt bijgewerkt nadat een case is gemaakt, worden de gegevens van de e-mailrecord bijgewerkt, maar de nettolading in de stroom niet. Dus wanneer in de volgende stroomstappen naar de waarde van de nettolading wordt verwezen, blijft deze leeg.
Oplossing
Als de waarde {Regarding(Email)} wordt gebruikt in verouderde regelitems, moet u de gemigreerde stroom handmatig bijwerken om de 'Incident-id' of 'OData-id' te gebruiken. Gebruik de OData-id voor velden waarvoor entiteitsreferenties of zoekopdrachten zijn vereist. Gebruik de unieke case-id voor velden waarvoor GUID is vereist.
Scenario 3- Problemen met het weergeven van polymorfe zoekacties op niet-opzoekvelden tijdens de migratie van verouderde naar moderne 'regels voor automatisch maken en bijwerken van records'
Een verouderd item voor het automatisch maken en bijwerken van records met polymorfe opzoekacties, zoals Afzender, resulteert in een ongeldige opzoekactie wanneer deze wordt toegewezen aan een tekstveld.
In verouderde items voor het maken en bijwerken van records in de klantenservice kunt u de entiteit (een contactpersoon of een account) opzoeken die een e-mailbericht heeft verzonden, de polymorfe zoekopdracht Afzender (Email), waarmee automatisch de juiste entiteit wordt opgehaald en de naam van de entiteit wordt weergegeven. Polymorfe opzoekacties zijn opzoekacties waarbij het doel van de opzoekactie meer dan één soort entiteit is. Het kan bijvoorbeeld verwijzen naar een contactpersoon of een account. In moderne 'regels voor automatisch maken en bijwerken van records' wordt deze automatische weergave echter niet ondersteund. U moet dus het type entiteit opgeven dat u wilt ophalen, samen met de velden die uit die entiteit moeten worden weergegeven.
Oorzaak
Het klassieke werkstroomgedrag dat wordt gebruikt door verouderde 'regels voor automatisch maken en bijwerken van records' heeft veel verborgen gedrag. Bijvoorbeeld: automatisch het type entiteit bepalen en een veld als weergavenaam ophalen als de parameter wordt gebruikt in een tekenreeks, maar de id retourneert als deze is toegewezen aan een opzoekveld. De platformmigratiecode die 'regels voor automatisch maken en bijwerken van records' gebruikt bij het converteren van verouderde naar moderne werkstromen, voegt niet de vereiste stappen en velden toe.
Oplossing
U kunt dit probleem oplossen door
- Werk de zoekopdracht bij naar een specifiek type.
- Gebruik een ander veld voor de binnenkomende entiteit die de gewenste tekst bevat.