Algemene configuratieproblemen oplossen met regels voor het automatisch maken en bijwerken van records
Dit artikel bevat oplossingen voor veelvoorkomende configuratiefoutscenario's met regels voor het automatisch maken en bijwerken van records, waardoor het maken van records kan mislukken of worden overgeslagen.
Scenario 1
Voorbeeld: Configuratie voor het automatisch maken en bijwerken van records
- De optie Contactpersoon maken voor onbekende afzender moet worden geselecteerd.
- Stel de criteria voor voorwaarden in op Alle binnenkomende e-mail.
- Voeg actie toe om een case te maken, selecteer Eigenschappen weergeven en stel de casevelden per zakelijke use-case in.
Fout 1: 'De case ontbreekt klant'
In het veld Klant van de sectie CASEDETAILS wordt de waarde van het Afzenders-account (e-mailadres) ingesteld zoals hieronder wordt weergegeven.
Deze instelling resulteert in de volgende fout in systeemtaken:
De case ontbreekt in de klant.
Oplossing voor fout 1
U kunt dit probleem oplossen door het veld Klant leeg te houden of in te stellen op {Sender(Email)}. Hierdoor kan het systeem automatisch een contactpersoon maken voor de onbekende afzender en deze koppelen aan de case.
Fout 2: 'Er is een fout opgetreden'
Het veld Klant wordt ingesteld als {Senders Account(Email)} en het veld Contactpersoon wordt ingesteld als {Sender(Email)}.
Deze instelling resulteert in de volgende fout in systeemtaken:
Er is een fout opgetreden. Probeer deze actie opnieuw. Als het probleem zich blijft voordoen, controleert u de Microsoft Dynamics 365-community op oplossingen of neemt u contact op met de Microsoft Dynamics 365-beheerder van uw organisatie. Ten slotte kunt u contact opnemen met Microsoft Ondersteuning.
Oplossing voor fout 2
U kunt dit probleem oplossen door het veld Klant leeg te houden of in te stellen op {Sender(Email)}. Hierdoor kan het systeem automatisch een contactpersoon maken voor de onbekende afzender en deze koppelen aan de case.
Fout 3: 'De opgegeven contactpersoon behoort niet tot de contactpersoon die is opgegeven in het veld Klant'.
De velden Klant en Contactpersoon worden ingesteld als {Sender(Email)}.
Deze instelling resulteert in de volgende fout in systeemtaken:
De opgegeven contactpersoon behoort niet tot de contactpersoon die is opgegeven in het veld Klant. Verwijder de waarde uit het veld met contactpersonen of selecteer een contactpersoon die is gekoppeld aan de geselecteerde klant en probeer het opnieuw.
Oplossing voor fout 3
Als u dit probleem wilt oplossen, laat u het veld Contactpersoon leeg en stelt u het veld Klant in op leeg of op {Sender(Email)}.
Validatiestappen
U moet de configuratie- en validatiestappen in de volgende tabel valideren om de belangrijkste oorzaak van het probleem te begrijpen en op te lossen.
Optie in Regel voor automatisch maken en bijwerken van records in Servicebeheer | Indien geselecteerd als | Validatiestappen | Resultaat |
---|---|---|---|
Een aanvraag maken als er een geldig recht voor de klant bestaat | Ja | Valideer of er een actief recht voor de klant bestaat. Geldig actief recht wordt als volgt geëvalueerd: - Als de afzender van het e-mailbericht een contactpersoon is met een bovenliggend account, maakt Dynamics 365 Customer Service een case als het bovenliggende account van de contactpersoon een geldig recht heeft en de contactpersoon wordt vermeld in de sectie Contactpersonen van het recht Of, als de sectie Contactpersonen leeg is (wat betekent dat het recht van toepassing is op alle contactpersonen voor de klant) |
Er wordt een case gemaakt. |
Een aanvraag maken op basis van een e-mail die is verzonden door onbekende afzenders | Ja | Voor elke binnenkomende e-mail van een onbekende afzender | - Er wordt een case gemaakt. - Er wordt ook een contactpersoon gemaakt voor de onbekende afzender. |
Ja | Voor een binnenkomende e-mail met het e-mailadres van een inactief account of een inactieve contactpersoon | - Er wordt een case gemaakt. - Er wordt een inactief account of contactpersoon geactiveerd. |
|
Nee | Voor een binnenkomende e-mail met het e-mailadres van een actief account of een actieve contactpersoon | Er wordt een case gemaakt. | |
Nee | Voor een binnenkomende e-mail die wordt verzonden door ander recordtype dan account of contactpersoon | Er wordt geen case gemaakt. | |
Nee | Voor een binnenkomende e-mail met het e-mailadres van een inactief account of een inactieve contactpersoon | Er wordt geen case gemaakt. | |
Een aanvraag maken voor activiteiten die zijn gekoppeld aan een afgesloten aanvraag | Ja | Voor een binnenkomende e-mail die is gerelateerd aan een afgesloten aanvraag | Er wordt een case gemaakt. |
Ja | Voor een binnenkomende e-mail die is gerelateerd aan een actieve aanvraag | Er wordt geen case gemaakt. |
Scenario 2: het gebruik van {Regarding(Email)} in de verouderde ervaring geeft niet de juiste gegevens in de stroom
In verouderde items voor het automatisch maken en bijwerken van records in de klantenservice kunt u de entiteit (een contactpersoon of een account) opzoeken die een e-mailbericht verzendt, kunt u de polymorfe zoekactie afzender (e-mail) gebruiken, waarmee automatisch de juiste entiteit wordt opgehaald en de naam van de entiteit wordt weergegeven. Polymorfe zoekopdrachten zijn zoekopdrachten waarbij het doel van de zoekopdracht meer dan één type entiteit is. Het kan bijvoorbeeld verwijzen naar een contactpersoon of een account. In moderne 'regels voor het automatisch maken en bijwerken van records' wordt deze automatische weergave echter niet ondersteund, dus u moet het type entiteit opgeven dat u wilt ophalen, samen met de velden die van die entiteit moeten worden weergegeven.
Oorzaak
Een stroom maakt geen gebruik van de waarde {Regarding(Email)} zoals een verouderde werkstroom, omdat stroomexpressies verwijzen naar een gegevenswaarde uit een van de nettolading van de vorige stroomstap. Als de waarde {Regarding(Email)} bijvoorbeeld leeg is wanneer de stroom begint, blijft de waarde in de payload voor de triggerstap voor {Regarding(Email)} leeg. Zelfs als de waarde {Regarding(Email)} wordt bijgewerkt nadat een case is gemaakt, worden de gegevens van de e-mailrecord bijgewerkt, maar de nettolading in de stroom niet. Dus wanneer naar de waarde van de payload wordt verwezen in de volgende stroomstappen, blijft deze leeg.
Oplossing
Als de waarde {Regarding(Email)} wordt gebruikt in verouderde regelitems, moet u de gemigreerde stroom handmatig bijwerken om de 'Incident-id' of 'OData-id' te gebruiken. Gebruik de OData-id voor velden waarvoor entiteitsreferenties of zoekacties zijn vereist. Gebruik de unieke id voor hoofdletters en kleine letters voor velden waarvoor GUID is vereist.
Scenario 3: problemen met het weergeven van polymorfe zoekacties op niet-opzoekvelden tijdens de migratie van verouderde naar moderne "regels voor automatisch maken en bijwerken van records"
Een verouderd item voor het automatisch maken en bijwerken van records met behulp van polymorfe zoekacties, zoals Afzender, resulteert in een ongeldige zoekopdracht wanneer deze is toegewezen aan een tekstveld.
In verouderde items voor het automatisch maken en bijwerken van records in de klantenservice kunt u de entiteit (een contactpersoon of een account) opzoeken die een e-mailbericht heeft verzonden, kunt u de polymorfe zoekactie afzender (e-mail) gebruiken, waarmee automatisch de juiste entiteit wordt opgehaald en de naam van de entiteit wordt weergegeven. Polymorfe zoekopdrachten zijn zoekopdrachten waarbij het doel van de zoekopdracht meer dan één type entiteit is. Het kan bijvoorbeeld verwijzen naar een contactpersoon of een account. In moderne 'regels voor het automatisch maken en bijwerken van records' wordt deze automatische weergave echter niet ondersteund. U moet dus het type entiteit opgeven dat u wilt ophalen, samen met de velden die van die entiteit moeten worden weergegeven.
Oorzaak
Het klassieke werkstroomgedrag dat wordt gebruikt door verouderde regels voor het automatisch maken en bijwerken van records, heeft veel verborgen gedragingen. Bijvoorbeeld, automatisch bepalen van het type entiteit en het ophalen van een veld als de weergavenaam als de parameter wordt gebruikt in een tekenreeks, maar retourneert de id als deze is toegewezen aan een opzoekveld. De platformmigratiecode die 'regels voor het automatisch maken en bijwerken van records' gebruikt bij het converteren van verouderde naar moderne werkstromen, voegt niet de vereiste stappen en velden toe.
Oplossing
Om dit probleem op te lossen,
- Werk de zoekopdracht bij naar een specifiek type.
- Gebruik een ander veld in de inkomende entiteit die de gewenste tekst bevat.