Tutorial: criar um aplicativo de console do .NET usando o Visual Studio Code

Este tutorial mostra como criar e executar um aplicativo de console do .NET usando o Visual Studio Code e a CLI do .NET. As tarefas do projeto, como criar, compilar e executar um projeto, são feitas usando a CLI do .NET. Você também pode seguir este tutorial com um editor de código diferente e os executar comandos em um terminal.

Pré-requisitos

Criar o aplicativo

Crie um projeto de aplicativo de console do .NET chamado "HelloWorld".

  1. Inicie o Visual Studio Code.

  2. Selecione Arquivo>Abrir Pasta (Arquivo>Abrir... no macOS) no menu principal.

  3. Na caixa de diálogo Abrir Pasta, crie uma pasta HelloWorld e selecione-a. Depois, clique em Selecionar Pasta (Abrir no macOS).

    O nome da pasta se torna o nome do projeto e o nome do namespace por padrão. Você adicionará o código mais tarde no tutorial, pressupondo que o namespace do projeto seja HelloWorld.

  4. Na caixa de diálogo Você confia nos autores dos arquivos nesta pasta?, selecione Sim, confio nos autores.

  5. Abra o Terminal no Visual Studio Code selecionando Exibir>Terminal no menu principal.

    O Terminal é aberto com o prompt de comando na pasta HelloWorld.

  6. No Terminal, digite o seguinte comando:

    dotnet new console --framework net7.0
    

    O modelo de projeto cria um aplicativo simples que exibe "Hello World" na janela do console chamando o método Console.WriteLine(String) em Program.cs.

    Console.WriteLine("Hello, World!");
    
  7. Substitua o conteúdo do Program.cs pelo seguinte código:

    namespace HelloWorld
    {
        class Program
        {
            static void Main(string[] args)
            {
                Console.WriteLine("Hello World!");
            }
        }
    }
    

    Na primeira vez que você editar um arquivo .cs, o Visual Studio Code solicitará que você adicione os ativos ausentes para compilar e depurar o aplicativo. Selecione Sim e o Visual Studio Code criará uma pasta .vscode com os arquivos launch.json e tasks.json.

    Observação

    Se o prompt não for exibido ou se você o ignorar sem selecionar Sim, execute as seguintes etapas para criar launch.json e tasks.json:

    • Selecione Executar>Adicionar Configuração no menu.
    • Selecione .NET 5 e posteriores e .NET Core no prompt Selecionar ambiente.

    O código define uma classe, Program, com um só método, Main, que usa uma matriz de String como um argumento. Main é o ponto de entrada do aplicativo, o método que é chamado automaticamente pelo runtime quando ele inicia o aplicativo. Quaisquer argumentos de linha de comando fornecidos quando o aplicativo for iniciado estão disponíveis na matriz args.

    Na versão mais recente do C#, um novo recurso chamado instruções de nível superior permite omitir a classe Program e o método Main. A maioria dos programas C# existentes não usa instruções de nível superior, portanto, este tutorial não usa esse novo recurso. Mas ele está disponível no C# 10 e se você usá-lo em seus programas é uma questão de preferência de estilo.

Executar o aplicativo

Execute o seguinte comando no Terminal:

dotnet run

O programa exibe "Hello World!" e é encerrado.

O comando de execução dotnet

Aprimorar o aplicativo

Aprimore o aplicativo para solicitar o nome do usuário e exibi-lo junto com a data e hora.

  1. Abra Program.cs.

  2. Substitua o conteúdo do método Main em Program.cs, que é a linha que chama Console.WriteLine, pelo seguinte código:

    Console.WriteLine("What is your name?");
    var name = Console.ReadLine();
    var currentDate = DateTime.Now;
    Console.WriteLine($"{Environment.NewLine}Hello, {name}, on {currentDate:d} at {currentDate:t}!");
    Console.Write($"{Environment.NewLine}Press any key to exit...");
    Console.ReadKey(true);
    

    Esse código mostra um prompt na janela do console e aguarda até que o usuário insira uma cadeia de caracteres seguida da tecla Enter. Ele armazena essa cadeia de caracteres em uma variável chamada name. Ele também recupera o valor da propriedade DateTime.Now, que contém a hora local atual e o atribui a uma variável chamada currentDate. E exibe esses valores na janela do console. Por fim, ele exibe um prompt na janela do console e chama o método Console.ReadKey(Boolean) para aguardar a entrada do usuário.

    NewLine é uma maneira independente de plataforma e de linguagem para representar uma quebra de linha. As alternativas são \n em C# e vbCrLf no Visual Basic.

    O sinal de dólar ($) na frente de uma cadeia de caracteres permite colocar expressões como nomes de variáveis em chaves na cadeia de caracteres. O valor da expressão é inserido na cadeia de caracteres no lugar da expressão. Essa sintaxe é conhecida como cadeia de caracteres interpolada.

  3. Salve suas alterações.

    Importante

    No Visual Studio Code, você precisa salvar as alterações explicitamente. Ao contrário do Visual Studio, as alterações de arquivo não são salvas automaticamente quando você compila e executa um aplicativo.

  4. Execute o programa novamente:

    dotnet run
    
  5. Responda ao prompt inserindo um nome e pressionando a tecla Enter.

    Janela do console com a saída do programa modificada

  6. Pressione qualquer tecla para encerrar o programa.

Recursos adicionais

Próximas etapas

Neste tutorial, você criou um aplicativo de console .NET. No próximo tutorial, você vai depurar o aplicativo.

Este tutorial mostra como criar e executar um aplicativo de console do .NET usando o Visual Studio Code e a CLI do .NET. As tarefas do projeto, como criar, compilar e executar um projeto, são feitas usando a CLI do .NET. Você também pode seguir este tutorial com um editor de código diferente e os executar comandos em um terminal.

Pré-requisitos

Criar o aplicativo

Crie um projeto de aplicativo de console do .NET chamado "HelloWorld".

  1. Inicie o Visual Studio Code.

  2. Selecione Arquivo>Abrir Pasta (Arquivo>Abrir... no macOS) no menu principal.

  3. Na caixa de diálogo Abrir Pasta, crie uma pasta HelloWorld e selecione-a. Depois, clique em Selecionar Pasta (Abrir no macOS).

    O nome da pasta se torna o nome do projeto e o nome do namespace por padrão. Você adicionará o código mais tarde no tutorial, pressupondo que o namespace do projeto seja HelloWorld.

  4. Na caixa de diálogo Você confia nos autores dos arquivos nesta pasta?, selecione Sim, confio nos autores.

  5. Abra o Terminal no Visual Studio Code selecionando Exibir>Terminal no menu principal.

    O Terminal é aberto com o prompt de comando na pasta HelloWorld.

  6. No Terminal, digite o seguinte comando:

    dotnet new console --framework net6.0 --use-program-main
    

    O modelo de projeto cria um aplicativo simples que exibe "Hello World" na janela do console chamando o método Console.WriteLine(String) em Program.cs.

    namespace HelloWorld;
    
    class Program
    {
        static void Main(string[] args)
        {
            Console.WriteLine("Hello World!");
        }
    }
    

    Na primeira vez que você editar um arquivo .cs, o Visual Studio Code solicitará que você adicione os ativos ausentes para compilar e depurar o aplicativo. Selecione Sim e o Visual Studio Code criará uma pasta .vscode com os arquivos launch.json e tasks.json.

    Observação

    Se o prompt não for exibido ou se você o ignorar sem selecionar Sim, execute as seguintes etapas para criar launch.json e tasks.json:

    • Selecione Executar>Adicionar Configuração no menu.
    • Selecione .NET 5 e posteriores e .NET Core no prompt Selecionar ambiente.

    O código define uma classe, Program, com um só método, Main, que usa uma matriz de String como um argumento. Main é o ponto de entrada do aplicativo, o método que é chamado automaticamente pelo runtime quando ele inicia o aplicativo. Quaisquer argumentos de linha de comando fornecidos quando o aplicativo for iniciado estão disponíveis na matriz args.

    Na versão mais recente do C#, um novo recurso chamado instruções de nível superior permite omitir a classe Program e o método Main. A maioria dos programas C# existentes não usa instruções de nível superior, portanto, este tutorial não usa esse novo recurso. Mas ele está disponível no C# 10 e se você usá-lo em seus programas é uma questão de preferência de estilo. dotnet new No comando que você usou para criar o projeto, a opção --use-program-main impediu que instruções de nível superior fossem usadas.

Executar o aplicativo

Execute o seguinte comando no Terminal:

dotnet run

O programa exibe "Hello World!" e é encerrado.

O comando de execução dotnet

Aprimorar o aplicativo

Aprimore o aplicativo para solicitar o nome do usuário e exibi-lo junto com a data e hora.

  1. Abra Program.cs.

  2. Substitua o conteúdo do método Main em Program.cs, que é a linha que chama Console.WriteLine, pelo seguinte código:

    Console.WriteLine("What is your name?");
    var name = Console.ReadLine();
    var currentDate = DateTime.Now;
    Console.WriteLine($"{Environment.NewLine}Hello, {name}, on {currentDate:d} at {currentDate:t}!");
    Console.Write($"{Environment.NewLine}Press any key to exit...");
    Console.ReadKey(true);
    

    Esse código mostra um prompt na janela do console e aguarda até que o usuário insira uma cadeia de caracteres seguida da tecla Enter. Ele armazena essa cadeia de caracteres em uma variável chamada name. Ele também recupera o valor da propriedade DateTime.Now, que contém a hora local atual e o atribui a uma variável chamada currentDate. E exibe esses valores na janela do console. Por fim, ele exibe um prompt na janela do console e chama o método Console.ReadKey(Boolean) para aguardar a entrada do usuário.

    NewLine é uma maneira independente de plataforma e de linguagem para representar uma quebra de linha. As alternativas são \n em C# e vbCrLf no Visual Basic.

    O sinal de dólar ($) na frente de uma cadeia de caracteres permite colocar expressões como nomes de variáveis em chaves na cadeia de caracteres. O valor da expressão é inserido na cadeia de caracteres no lugar da expressão. Essa sintaxe é conhecida como cadeia de caracteres interpolada.

  3. Salve suas alterações.

    Importante

    No Visual Studio Code, você precisa salvar as alterações explicitamente. Ao contrário do Visual Studio, as alterações de arquivo não são salvas automaticamente quando você compila e executa um aplicativo.

  4. Execute o programa novamente:

    dotnet run
    
  5. Responda ao prompt inserindo um nome e pressionando a tecla Enter.

    Janela do console com a saída do programa modificada

  6. Pressione qualquer tecla para encerrar o programa.

Recursos adicionais

Próximas etapas

Neste tutorial, você criou um aplicativo de console .NET. No próximo tutorial, você vai depurar o aplicativo.

Este tutorial só está disponível para .NET 6 e .NET 7. Selecione uma dessas opções na parte superior da página.