Compartilhar via


Solucionar problemas de backup e recuperação do Microsoft Entra (versão prévia)

Importante

O Backup e a Recuperação do Microsoft Entra estão atualmente em versão prévia. Veja os Termos de Uso Complementares para Versões Prévias do Microsoft Azure para obter termos legais que se aplicam aos recursos do Azure que estão em versão beta, versão prévia ou que, de outra forma, ainda não foram lançados em disponibilidade geral.

Este artigo ajuda você a diagnosticar e resolver problemas comuns usando o Microsoft Entra Backup and Recovery, incluindo problemas de acesso ao backup, relatórios de diferenças e atividades de recuperação.

Antes de começar

Verifique estes pré-requisitos antes de solucionar problemas:

  • Seu locatário é um locatário da força de trabalho (não há suporte para ID externa e locatários B2C).
  • Seu inquilino possui licenças Microsoft Entra ID P1 ou P2.
  • Você está conectado com uma conta que possui a função Microsoft Entra Backup role apropriada:
    • Microsoft Entra Backup Reader
    • Microsoft Entra Administrador de Backup

A função administrador global também tem as permissões necessárias.

Se esses pré-requisitos não forem atendidos, as operações poderão falhar com erros de autorização ou resultados vazios.

Problema: nenhum backup está listado

Esse problema ocorre quando a lista de backup mostra menos backups do que o esperado ou exibe carimbos de data/hora duplicados.

Symptoms

  • Menos de cinco dias de backups são visíveis, em vez dos cinco dias esperados.
  • Dois ou mais backups parecem ter o mesmo registro de data e hora na lista de backups.

Possíveis causas:

O backup mais antigo pode envelhecer mais cedo durante a inicialização do serviço, integração de locatário ou condições transientes de back-end, resultando temporariamente em menos de cinco dias de backups visíveis. Essa condição não indica perda de dados ou uma falha de backup.

Resolução

Nenhuma ação é necessária. O serviço continua a criar novos backups automaticamente.

Problema: não é possível iniciar um trabalho de recuperação ou relatório de divergências

Esse problema ocorre quando um trabalho de recuperação ou relatório de diferenças falha ao iniciar devido a um conflito, falha de autorização ou tipo de objeto não suportado.

Symptoms

  • O relatório de diferença ou tarefa de recuperação não consegue iniciar.
  • Um erro indica uma falha de conflito ou autorização.
  • O tipo de objeto que você deseja usar não aparece na lista suspensa do filtro de escopo.

Possíveis causas:

  • Outro relatório diferencial ou trabalho de recuperação já está em execução.
  • O usuário conectado não tem a necessária função de Backup do Microsoft Entra.
  • Não há suporte para o tipo de objeto selecionado para backup e recuperação na versão atual.

Resolução

  1. Verifique se outro relatório de diferença ou tarefa de recuperação está em execução. Somente um trabalho pode ser executado por vez.
  2. Verifique se sua conta tem a função apropriada: Leitor de Backup do Microsoft Entra para relatórios de diferença ou Administrador de Backup do Microsoft Entra para recuperação.
  3. Confirme que o tipo de objeto e os atributos de objeto que você está tentando delimitar são suportados. Somente os tipos e atributos de objeto compatíveis aparecem no filtro de escopo.

Problema: Problemas de relatório de diferença

Esta seção ajuda a solucionar problemas comuns relacionados a relatórios de diferença, incluindo alterações ausentes, trabalhos de longa execução, trabalhos com falha, trabalhos cancelados e relatórios ausentes.

Symptoms

  • O relatório de diferença não incluiu as alterações para o objeto que você estava procurando.
  • O relatório de diferenças está em execução há várias horas e você não sabe quando será concluído.
  • O estado do relatório de diferença é "Falha".
  • Não é possível encontrar o relatório de diferença gerado anteriormente.
  • Você selecionou Cancelar, mas o relatório de diferença ainda parece estar em execução.

Possíveis causas:

  • O objeto ou a propriedade não tem suporte para visualização na versão atual.
  • O objeto não foi alterado entre o estado de backup e o estado atual.
  • O relatório de diferença está processando um grande número de objetos ou modificações.
  • Apenas um relatório de diferença ou trabalho de recuperação pode ser executado de cada vez.
  • O relatório foi cancelado ou falhou antes da conclusão.
  • Os relatórios de diferença não são armazenados permanentemente.

Resolução

Se as alterações esperadas estiverem ausentes:

  1. Confirme se o tipo de objeto e as propriedades têm suporte para a versão atual.
  2. Verifique se o objeto foi alterado depois que o backup foi feito.
  3. Objetos excluídos permanentemente e propriedades não suportadas não estão incluídos.

Se o relatório de diferença estiver em execução por um longo tempo:

Veja a diferença estimada de tempo de geração do relatório. Grandes clientes ou grandes conjuntos de alterações podem demandar mais tempo para serem processados.

  • Permita que o relatório continue em execução, a menos que o cancelamento seja necessário.

Se o relatório de discrepância falhou:

  1. Examine o status do trabalho e a mensagem de erro mostrada nos detalhes do relatório.
  2. Tente novamente o relatório de diferença usando um escopo mais estreito, como um tipo de objeto específico ou ID de objeto.
  3. Verifique se nenhum outro relatório de diferença ou trabalho de recuperação está em execução ao mesmo tempo.

Se você não encontrar um relatório de diferença anterior:

Os relatórios de diferença estão vinculados ao backup do qual foram criados.

  1. Navegue até o backup e verifique a lista de tarefas de relatório de diferença associadas a ele.
  2. Se o relatório não estiver listado, ele poderá não estar mais disponível porque os relatórios de diferença serão mantidos por cinco dias após a data de conclusão.

Se o relatório de diferença continuar em execução após o cancelamento:

  1. O cancelamento é o melhor esforço. Alguns processamentos podem continuar brevemente depois que você selecionar Cancelar.
  2. Se o trabalho permanecer em execução, aguarde o estado ser atualizado antes de iniciar um novo relatório.

Problema: Questões com tarefas de recuperação

Esse problema ocorre quando um trabalho de recuperação não recupera objetos esperados, é executado por mais tempo do que o esperado ou é concluído com avisos.

Symptoms

  • O trabalho de recuperação não recuperou um objeto que apareceu no relatório de diferença.
  • O trabalho de recuperação está em execução há várias horas e você não sabe quando ele é concluído.
  • O estado do trabalho de recuperação é "Concluído com alertas".
  • Você cancelou o trabalho de recuperação, mas o trabalho ainda parece estar em execução.

Possíveis causas:

  • O objeto ou propriedade mostrado no relatório de diferença (por exemplo, propriedades sincronizadas no local) não é suportado para recuperação.
  • O trabalho de recuperação inclui um grande número de objetos ou alterações.
  • Apenas um relatório de diferença ou trabalho de recuperação pode ser executado de cada vez.
  • O trabalho de recuperação foi cancelado ou interrompido enquanto as alterações ainda estavam sendo processadas.
  • Algumas ações de recuperação podem ter êxito parcialmente antes que ocorra uma falha ou cancelamento.

Resolução

  1. Revise a lista de alterações que falharam nos detalhes do trabalho de recuperação.
  2. Tente novamente a recuperação com um escopo mais limitado, concentrando-se em objetos somente da nuvem que têm suporte.

Esse problema ocorre quando um trabalho de recuperação concluído anteriormente não está mais visível ou quando apenas alguns links foram recuperados.

Symptoms

  • Você não consegue encontrar a tarefa de recuperação que executou ontem.
  • O trabalho de recuperação mostra que apenas alguns links ou propriedades foram recuperados (por exemplo, 1 de 5) e outros não foram.

Possíveis causas:

  • Os detalhes da tarefa de recuperação são removidos automaticamente cinco dias após a conclusão.
  • Não há suporte para a recuperação de alguns links na versão atual.
  • Determinados links dependem de outros objetos ou estados que não existem mais.
  • O trabalho de recuperação foi concluído com avisos de advertência, indicando sucesso parcial.

Resolução

Se você não conseguir encontrar um trabalho de recuperação que você executou anteriormente:

  1. Localize a data/hora do backup usada para a recuperação.
  2. Revise o histórico de recuperação para encontrar trabalhos de recuperação associados a esse timestamp de backup.
  3. Se o trabalho não estiver mais listado, ele poderá não estar mais disponível porque os trabalhos de recuperação serão mantidos por cinco dias após a data de conclusão.

Se nem todos os links foram recuperados:

  1. Revise os detalhes do trabalho de recuperação para avisos ou alterações de links com falha.
  2. Confirme se os links que você esperava recuperar têm suporte na versão atual.
  3. Alguns links podem não ser recuperados se:
    • O objeto relacionado não existe mais.
    • Não há suporte para o tipo de link.
  4. Recriar manualmente todos os links sem suporte ou com falha, se necessário.

Condições de erro e mensagens

Condição Código de erro e mensagem
Relatório de diferença consultado com um identificador de backup inválido 404 Não Encontrado: este não é um timestamp válido para recuperação. O carimbo de data/hora fornecido deve estar na lista de backups disponíveis.
O trabalho é consultado com uma ID de trabalho inválida 404 Não Encontrado
Um trabalho é iniciado enquanto outro relatório de diferença ou trabalho de recuperação ainda está em execução Conflito 409: Um trabalho de recuperação está em andamento no momento. Aguarde até que ele seja concluído antes de iniciar um novo trabalho.
Receber atualizações enquanto o relatório de diferenças não tiver terminado 400 Solicitação Inválida: o trabalho com identificador {key} deve ter sido concluído com êxito antes de enumerar as alterações.
Função de administrador insuficiente 403 Proibido: a autorização foi negada para esta solicitação. Verifique suas credenciais.

Limitações conhecidas

As limitações conhecidas a seguir se aplicam ao Backup e à Recuperação do Microsoft Entra durante a versão de prévia.

Cobertura parcial da propriedade

O backup e a recuperação não abrangem todas as propriedades de objetos com suporte. Essa limitação inclui propriedades somente de leitura, propriedades geradas pelo sistema e propriedades que dependem da lógica de negócios especializada. Consulte a lista de propriedades com suporte para obter detalhes. A Microsoft está expandindo o suporte para mais propriedades ao longo do tempo.

Escopo de suporte do locatário

O Backup e a Recuperação do Microsoft Entra têm suporte apenas para inquilinos de usuários corporativos. Não há suporte para locatários de ID externa e B2C.

Objetos excluídos permanentemente

Objetos excluídos não podem ser recuperados. Esses objetos não estão incluídos no relatório de diferença e não podem ser recriados ou restaurados por meio de um trabalho de recuperação. Para reduzir o risco de exclusão rígida, considere configurar ações protegidas.

Objetos sincronizados locais

Usuários e grupos sincronizados do Active Directory local não podem ser restaurados pelo Microsoft Entra Backup and Recovery. Esses objetos devem ser recuperados diretamente no ambiente do Active Directory local.

Há suporte apenas para links de associação de grupo estático para recuperação. Não há suporte para links de proprietário de grupo, relações de gerência de usuários e links de patrocinador.