Observação
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Número de KB original: 3107357
Sintomas
Considere o seguinte cenário:
- Você está usando Serviços de Federação do Active Directory (AD FS) (AD FS) para autenticação de acesso ao cliente POP e IMAP.
- Você tem uma regra de declaração para bloquear o acesso se o valor do tipo de declaração X-MS-Client-Application não for Microsoft.Exchange.PopImap.
Essas configurações já haviam funcionado conforme o esperado. No entanto, você notou recentemente que os clientes POP e IMAP não conseguem autenticar mesmo que o nome de usuário e a senha corretos sejam usados.
Além disso, se você examinar o log de acesso do AD FS, poderá ver entradas que se assemelham ao seguinte:
[<Hora da data><>] "POST /microsoftonline/ws-username HTTP/1.1" 403 ... "Microsoft.Exchange.Imap"
[<Hora da data><>] "POST /microsoftonline/ws-username HTTP/1.1" 403 ... "Microsoft.Exchange.Pop"
Motivo
Uma alteração foi feita recentemente no serviço para separar a autenticação POP e IMAP. Em vez de Microsoft.Exchange.PopImap, o valor enviado no cabeçalho X-MS-Client-Application é Microsoft.Exchange.Imap ou Microsoft.Exchange.Pop.
Resolução
Na regra de declaração existente, altere o valor de X-MS-Client-Application de Microsoft.Exchange.PopImap para Microsoft.Exchange.Imap e Microsoft.Exchange.Pop.
Mais informações
Para saber mais, veja os seguintes recursos:
- Limitando o acesso aos serviços do Microsoft 365 com base na localização do cliente
- Configurando políticas de acesso ao cliente
Ainda precisa de ajuda? Acesse a Comunidade da Microsoft ou as Perguntas e Respostas da Microsoft.