Compartilhar via


Guia de problemas de rede

Este guia mostra-lhe como detetar problemas de rede ou oportunidades de otimização no painel Rede das DevTools do Microsoft Edge.

Para saber as noções básicas da ferramenta Rede , veja Inspecionar a atividade de rede.

Pedidos em fila ou bloqueados

Sintomas

Seis pedidos estão a ser transferidos em simultâneo. Depois disso, uma série de pedidos são em fila de espera ou parados. Uma vez concluído um dos primeiros seis pedidos, um dos pedidos na fila é iniciado.

Na Cascata na figura seguinte, os primeiros seis pedidos para o edge-iconx1024.msft.png recurso começam em simultâneo. Os pedidos subsequentes ficam parados até que um dos seis originais termine.

Um exemplo de uma série em fila ou parada no painel Rede

Causas

Estão a ser feitos demasiados pedidos num único domínio. Em ligações HTTP/1.0 ou HTTP/1.1, o Microsoft Edge permite um máximo de seis ligações TCP simultâneas por anfitrião.

Correções

  • Implemente a fragmentação de domínio se tiver de utilizar HTTP/1.0 ou HTTP/1.1.

  • Utilize HTTP/2. Não utilize a fragmentação de domínios com HTTP/2.

  • Remova ou adie pedidos desnecessários para que os pedidos críticos transfiram anteriormente.

Tempo lento para o primeiro byte (TTFB)

Sintomas

Um pedido passa muito tempo à espera de receber o primeiro byte do servidor.

Na figura seguinte, a barra verde longa na Cascata indica que o pedido estava a aguardar muito tempo. Isto foi simulado através de um perfil para restringir a velocidade da rede e adicionar um atraso.

Um exemplo de um pedido com um Time To First Byte lento

Causas

  • A ligação entre o cliente e o servidor é lenta.

  • O servidor demora a responder. Aloje o servidor localmente para determinar se é a ligação ou o servidor lento. Se continuar a obter um Time To First Byte (TTFB) lento ao aceder a um servidor local, o servidor será lento.

Correções

  • Se a ligação estiver lenta, considere alojar os seus conteúdos numa CDN ou alterar os fornecedores de alojamento.

  • Se o servidor estiver lento, considere otimizar as consultas da base de dados, implementar uma cache ou modificar a configuração do servidor.

Transferência lenta de conteúdo

Sintomas

A transferência de um pedido demora muito tempo.

Na figura seguinte, a barra longa e azul na Cascata junto ao png significa que demorou muito tempo a transferir.

Um exemplo de um pedido que demora muito tempo a ser transferido

Causas

  • A ligação entre o cliente e o servidor é lenta.

  • Muitos conteúdos estão a ser transferidos.

Correções

  • Considere alojar os seus conteúdos numa CDN ou alterar os fornecedores de alojamento.

  • Envie menos bytes ao otimizar os seus pedidos.

Observação

Partes desta página são modificações baseadas no trabalho criado e partilhado pela Google e utilizado de acordo com os termos descritos na Licença Internacional Creative Commons Attribution 4.0. A página original é encontrada aqui e é da autoria de Kayce Bascos e Jonathan Garbee.

Licença Creative Commons Este trabalho é licenciado ao abrigo de uma Licença Internacional creative Commons Attribution 4.0.